Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Lost web browser & email client after updates

  1. #1

    Default Lost web browser & email client after updates

    After an update, Firefox, SeaMonkey and Seamonkey Mail crash. Rekonq runs at first, but crashes when I click a bookmark. I had to install Opera just to get here. Has anyone else had this problem? I remember there were Mozilla updates (Firefox and SeaMonkey), and Qt4 "devel" package, I forget if there was anything else. Also, now I can't get IceWM to run. KDE4 is working still.

    If it matters, I used Yast to do the online update, only the "needed" updates. Guess I didn't "need" them as much as I though

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Lost web browser & email client after updates

    Quote Originally Posted by HighBloodSugar View Post
    After an update, Firefox, SeaMonkey and Seamonkey Mail crash. Rekonq runs at first, but crashes when I click a bookmark. I had to install Opera just to get here. Has anyone else had this problem? I remember there were Mozilla updates (Firefox and SeaMonkey), and Qt4 "devel" package, I forget if there was anything else. Also, now I can't get IceWM to run. KDE4 is working still.

    If it matters, I used Yast to do the online update, only the "needed" updates. Guess I didn't "need" them as much as I though
    No

    But I do see this change
    https://forums.opensuse.org/english/...s-opening.html
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Lost web browser & email client after updates

    i noticed in seamonkey preferences that some menus were appearing blank
    I created new profile and everything was fine
    I noticed this when migrating from 2.14==>2.15
    I think the same problem is affecting firefox too as SeaMonkey is closing following Firefox release cycles and backend(gecko) nowadays
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4
    dd NNTP User

    Default Re: Lost web browser & email client after updates

    On 01/12/2013 07:46 AM, HighBloodSugar wrote:
    > After an update


    i wonder if you have either (following the update) either logged out and
    back in, or shutdown and rebooted (not simply sleeping or hibernating)?

    if not, then do this in a terminal
    Code:
    zypper ps
    and see if you are running any processes using deleted files (the list
    _may_ be long)....if you are then try logging out and back it, and run
    the "zypper ps" command again and then see if any of those crashing
    programs are acting right again..

    if they remain broken i can only guess you have some conflicting repos
    and/or software in the mix somewhere--so please show us the terminal
    output *and* input, as well as the beginning prompt and exit prompt, from

    Code:
    zypper lr -d
    uname -a
    cat /etc/SuSE-release
    copy/paste the in/output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    and, next time please declare which operating system, desktop
    environment and versions are in use..

    --
    dd http://tinyurl.com/DD-Caveat

  5. #5

    Default Re: Lost web browser & email client after updates

    Quote Originally Posted by vazhavandan View Post
    i noticed in seamonkey preferences that some menus were appearing blank
    I created new profile and everything was fine
    I noticed this when migrating from 2.14==>2.15
    I think the same problem is affecting firefox too as SeaMonkey is closing following Firefox release cycles and backend(gecko) nowadays
    My problem is that is crashes immediately, I can't get in to try a new profile. There were other updates along with the Mozilla stuff, so I'm not sure if the problem is Seamonkey & Firefox/Thunderbird, or something else they depend on.

    Code:
    user@linux-fi3i:~> seamonkey
    /usr/bin/seamonkey: line 139:  4567 Segmentation fault      $MOZ_PROGRAM "$@"
    I forgot to mention before, I'm using openSuse 12.1 64 bit version.
    For now, I can use Opera, and can get my email from the Verizon web page, it'll do until this is fixed.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Lost web browser & email client after updates

    You can temp rename your .mozilla to test a clean profile
    or create a new user and try there
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Lost web browser & email client after updates

    CODE][/CODE]
    Quote Originally Posted by dd View Post
    On 01/12/2013 07:46 AM, HighBloodSugar wrote:
    > After an update


    i wonder if you have either (following the update) either logged out and
    back in, or shutdown and rebooted (not simply sleeping or hibernating)?

    if not, then do this in a terminal
    Code:
    zypper ps
    and see if you are running any processes using deleted files (the list
    _may_ be long)....if you are then try logging out and back it, and run
    the "zypper ps" command again and then see if any of those crashing
    programs are acting right again..

    if they remain broken i can only guess you have some conflicting repos
    and/or software in the mix somewhere--so please show us the terminal
    output *and* input, as well as the beginning prompt and exit prompt, from

    Code:
    zypper lr -d
    uname -a
    cat /etc/SuSE-release
    copy/paste the in/output back to this thread using the instructions
    here: Posting in Code Tags - A Guide

    and, next time please declare which operating system, desktop
    environment and versions are in use..

    --
    dd DD Caveat

    I'm running openSuse 12.1 64 bit and KDE 4.7.2 Release 5. This happened after the latest Yast online update

    Here is what I get:

    Code:
    linux-fi3i:/home/user # zypper ps
    No processes using deleted files found.
    I rebooted after I noticed troubles, so the above is not from right after the updates, if that matters.

    Code:
    linux-fi3i:/home/user # zypper lr -d
    #  | Alias                              | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                              | Service
    ---+------------------------------------+------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------+--------
     1 | Games                              | Games                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.1                    |        
     2 | Packman                            | Packman                            | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.1/                                               |        
     3 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.1/                                        |        
     4 | libdvdcss repository               | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.1/                                             |        
     5 | openSUSE-12.1-12.1-1.4             | openSUSE-12.1-12.1-1.4             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_C_3524416_288147503354,/dev/sr0 |        
     6 | repo-debug                         | openSUSE-12.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.1/repo/oss/                   |        
     7 | repo-debug-update                  | openSUSE-12.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.1/                                  |        
     8 | repo-non-oss                       | openSUSE-12.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                     |        
     9 | repo-oss                           | openSUSE-12.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                         |        
    10 | repo-source                        | openSUSE-12.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.1/repo/oss/                  |

    Code:
    linux-fi3i:/home/user # uname -a
    Linux linux-fi3i 3.1.10-1.16-desktop #1 SMP PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    linux-fi3i:/home/user # cat /etc/SuSE-release
    openSUSE 12.1 (x86_64)
    VERSION = 12.1
    CODENAME = Asparagus

  8. #8

    Default Re: Lost web browser & email client after updates

    Quote Originally Posted by caf4926 View Post
    You can temp rename your .mozilla to test a clean profile
    or create a new user and try there
    Unfortunately, that doesn't work. I still get these when I try to run Seamonkey and Firefox:

    Code:
    user@linux-fi3i:~> seamonkey
    /usr/bin/seamonkey: line 139:  4914 Segmentation fault      $MOZ_PROGRAM "$@"
    
    user@linux-fi3i:~> firefox
    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
    user@linux-fi3i:~>

  9. #9
    dd NNTP User

    Default Re: Lost web browser & email client after updates

    On 01/12/2013 09:26 AM, HighBloodSugar wrote:
    >
    > Code:
    > --------------------
    >
    > linux-fi3i:/home/user # zypper lr -d
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+------------------------------------+------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------+--------
    > 1 | Games | Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit.../openSUSE_12.1 |
    > 2 | Packman | Packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/12.1/ |
    > 3 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.1/ |
    > 4 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.1/ |
    > 5 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_C_3524416_288147503354,/dev/sr0 |
    > 6 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...12.1/repo/oss/ |
    > 7 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/12.1/ |
    > 8 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    > 9 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...12.1/repo/oss/ |
    > 10 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...12.1/repo/oss/ |
    >
    > --------------------


    the repos look pretty okay...but, while i do NOT think it will have any
    impact on your current problems, i would suggest you disable the
    following repos: 1, 4, and 5.....and, cease refreshing 1, 4, 6, 7 and
    10. rational given in the paragraph beginning with "IMPORTANT" in this
    post http://tinyurl.com/33qc9vu plus there is no need to refresh
    disabled repos or those which will never change (like oss and
    non-oss)--and not refreshing unneeded repos will SPEED up the activity
    of YaST Software Management, YaST Online Update and zypper..

    oh, and if you disable the CD (#5) it will stop asking you to insert it
    each time..


    next: i see these as your command line inputs

    > linux-fi3i:/home/user # zypper lr -d
    > linux-fi3i:/home/user # uname -a
    > linux-fi3i:/home/user # cat /etc/SuSE-release


    so, i have to wonder why you did those as root? it has long been the
    convention in *nix/bsd/linux to use root powers _only_ when required
    (this is a "security thing"--using the least powerful actor always
    increases total system security--and is ONE of the principle differences
    between Windows and industrial strength systems!)....and, none of those
    commands needed root powers!!

    so, it also appears (to me) that maybe you have logged into KDE as
    root....is that correct??

    if yes: that is something you should not do, ever...ask then how to do
    administrator duties without logging into KDE as the administrator, and
    i will explain further..

    --
    dd http://goo.gl/PUjnL http://tinyurl.com/DD-Caveat

  10. #10

    Default Re: Lost web browser & email client after updates

    Quote Originally Posted by dd View Post

    >
    next: i see these as your command line inputs

    > linux-fi3i:/home/user # zypper lr -d
    > linux-fi3i:/home/user # uname -a
    > linux-fi3i:/home/user # cat /etc/SuSE-release


    so, i have to wonder why you did those as root?
    I used "su" first, I assumed that was needed. Here they are again as a user:

    Code:
    user@linux-fi3i:~> zypper lr -d
    #  | Alias                              | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                              | Service
    ---+------------------------------------+------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------+--------
     1 | Games                              | Games                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.1                    |        
     2 | Packman                            | Packman                            | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.1/                                               |        
     3 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.1/                                        |        
     4 | libdvdcss repository               | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.1/                                             |        
     5 | openSUSE-12.1-12.1-1.4             | openSUSE-12.1-12.1-1.4             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_C_3524416_288147503354,/dev/sr0 |        
     6 | repo-debug                         | openSUSE-12.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.1/repo/oss/                   |        
     7 | repo-debug-update                  | openSUSE-12.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.1/                                  |        
     8 | repo-non-oss                       | openSUSE-12.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/non-oss/                     |        
     9 | repo-oss                           | openSUSE-12.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.1/repo/oss/                         |        
    10 | repo-source                        | openSUSE-12.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.1/repo/oss/                  |
    Code:
    user@linux-fi3i:~> uname -a
    Linux linux-fi3i 3.1.10-1.16-desktop #1 SMP PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    openSUSE 12.1 (x86_64)
    VERSION = 12.1
    CODENAME = Asparagus
    As for the "CD" in the repos, it never has asked for the disk, so I never thought to check that setting. I'll disable that anyway, and the others you suggested. Thanks for that tip!

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •