Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Graphic and Software Behavior

  1. #1

    Unhappy Graphic and Software Behavior

    So... It's been a while (1.5 year ago) since I first started using openSUSE and I enjoy it most of the time.
    But when trying to do some real work regarding graphics in software such as Inkscape or Draftsight, I don't get expected results. By that I mean, moving object on canvas is Herculean job. Elements are tearing, it is very slow.. Bottom line I can't do anything except surfing the web, watching videos and listening music.

    I'm using PC with i3 processor, radeon hd 5450 graphics with proprietary driver installed. Everything seem to work fine, with or without graphic driver installed, but when it comes to dealing with graphic software, it's just so sad... I tried tweaking AMD Control Panel, but no success.

    With having in mind all given facts, I've been wondering what's the essential problem with graphic software so it won't respond in expected way? Or I have that problem only...

  2. #2
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Graphic and Software Behavior

    I'll suggest something is not optimally setup on your PC.
    I have run gimp, inkscape, QCAD, Draftsight and other graphical applications with very good results, on platforms less powerful than i3.

    For starters and best help here, you need to be a bit more specific on what version openSUSE you have installed.
    32 bit or 64 bit?
    Did you install inkscape from a repository or compile?
    It might also be helpful to mention how much RAM you have, if you are playing with big files RAM will make a difference.

    For starters, try starting an offending application from a command prompt in a terminal (konsole) window.
    Code:
    carl@PVE-LinuxSRV5:~> inkscape
    Frequently, if the application is having issues with files or libraries, messages will appear in the CLI window while you are working in the GUI window.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  3. #3

    Default Re: Graphic and Software Behavior

    Quote Originally Posted by cmcgrath5035 View Post
    I'll suggest something is not optimally setup on your PC.
    I have run gimp, inkscape, QCAD, Draftsight and other graphical applications with very good results, on platforms less powerful than i3.

    For starters and best help here, you need to be a bit more specific on what version openSUSE you have installed.
    32 bit or 64 bit?
    Did you install inkscape from a repository or compile?
    It might also be helpful to mention how much RAM you have, if you are playing with big files RAM will make a difference.

    For starters, try starting an offending application from a command prompt in a terminal (konsole) window.
    Code:
    carl@PVE-LinuxSRV5:~> inkscape
    Frequently, if the application is having issues with files or libraries, messages will appear in the CLI window while you are working in the GUI window.

    Well I run 32 bit version of openSUSE 12.2, with 4 GB of RAM installed.
    I didn't compile any of my software, and I don't get any error messages either way I start my programs.

    I had the same problems in Ubuntu as well, but after trying various distros, I realized openSUSE does the best job.

    Is there anything else that I maybe missed?

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Graphic and Software Behavior

    I am not real familiar with i3 hardware.
    Is this a laptop or desktop?
    If it is a laptop, is it a "dual graphics" architecture (native Intel plus AMD/ATI or Nvidia, AMD/ATI in your case) ?

    If yes, you may want to head over to the hardware forum, lots to read on issues with dual graphics setups.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5

    Default Re: Graphic and Software Behavior

    Quote Originally Posted by cmcgrath5035 View Post
    I am not real familiar with i3 hardware.
    Is this a laptop or desktop?
    If it is a laptop, is it a "dual graphics" architecture (native Intel plus AMD/ATI or Nvidia, AMD/ATI in your case) ?

    If yes, you may want to head over to the hardware forum, lots to read on issues with dual graphics setups.
    It's a desktop, sorry I forgot to mention about it..

  6. #6
    dd NNTP User

    Default Re: Graphic and Software Behavior

    On 01/11/2013 05:36 PM, thermooo wrote:
    > I run 32 bit version of openSUSE 12.2, with 4 GB of RAM installed


    which kernel are you running and is all memory in play?
    to answer, please show us the output of these commands, inside code tags
    as explained here: http://goo.gl/i3wnr

    Code:
    uname -a
    free -m
    --
    dd

  7. #7
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Graphic and Software Behavior

    Hmmm, does the graphics card have its own ram or is this a "shared RAM" setup?

    I had at one time issues that seemed bios related, where graphics would not run well with certain sized shared memory spaces but OK with others.

    How did you install the radeon driver?
    On my ATI systems, I use please_try_again 's atiupgrade script to keep all the moving pieces currrent.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  8. #8

    Default Re: Graphic and Software Behavior

    Quote Originally Posted by dd View Post
    On 01/11/2013 05:36 PM, thermooo wrote:
    > I run 32 bit version of openSUSE 12.2, with 4 GB of RAM installed


    which kernel are you running and is all memory in play?
    to answer, please show us the output of these commands, inside code tags
    as explained here: Posting in Code Tags - A Guide

    Code:
    uname -a
    free -m
    --
    dd

    Here's an output

    Code:
    aid@linux-t1mh:~> uname -a
    Linux linux-t1mh 3.4.11-2.16-default #1 SMP Wed Sep 26 17:05:00 UTC 2012 (259fc87) i686 i686 i386 GNU/Linux
    aid@linux-t1mh:~> free -m
                 total       used       free     shared    buffers     cached
    Mem:          3534       3249        284          0        119       1667
    -/+ buffers/cache:       1462       2071
    Swap:         2050          0       2050

  9. #9

    Default Re: Graphic and Software Behavior

    Quote Originally Posted by cmcgrath5035 View Post
    Hmmm, does the graphics card have its own ram or is this a "shared RAM" setup?

    I had at one time issues that seemed bios related, where graphics would not run well with certain sized shared memory spaces but OK with others.

    How did you install the radeon driver?
    On my ATI systems, I use please_try_again 's atiupgrade script to keep all the moving pieces currrent.
    It has its own RAM, 1 GB

    I installed it over: https://en.opensuse.org/SDB:AMD_fglrx
    It's a one click install.

  10. #10
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Graphic and Software Behavior

    Hmmm, one has to wonder a bit if you have hardware problems with the card, given that Ubuntu had same sorts of issues.

    Does glxgears run smoothly?
    It is not a comprehensive test, but a reasonable go/no-go
    Code:
    carl@PVE-LinuxSRV5:~> glxgears
    14461 frames in 5.0 seconds = 2892.106 FPS
    At one time I thought the SDB method of install was broken, but that is long ago.
    Do a forum search on atiupgrade, it is an effortless way to avoid most ATI driver pitfalls.

    One thing you might try is to switch to the openSUSE radeon open source driver rather than the proprietary driver.
    It seems to work OK for most nominal applications.
    Drag a square around on Inkscape should not be a huge graphics load.

    For reference, I am running the AMD proprietary driver
    AMDCCCLE(Catalyst Control Center) reports Driver Package 9.002-120928m-148573C-ATI, 2D Driver 9.0.2, OpenGL Version 4.2.11931
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •