Results 1 to 10 of 10

Thread: ibus not enabled after trigger hotkey

  1. #1

    Default ibus not enabled after trigger hotkey

    Hi guys,

    I've just installed ibus, but when I hit Ctrl+Space to enable, ibus even not enabled, still "No input method". Still error if I change to another keyboard shortcuts.
    Is there anyway to fix this or to enable manually not thru keyboard shortcuts?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,142

    Default Re: ibus not enabled after trigger hotkey

    Where, what, ..................................................

    openSUSE version?

    Any desktop involved?
    Henk van Velden

  3. #3
    dd NNTP User

    Default Re: ibus not enabled after trigger hotkey

    On 01/08/2013 04:56 PM, n00bvn wrote:
    > keyboard shortcuts


    looking at http://code.google.com/p/ibus/issues/list i see
    *lots* of keyboard and shortcut issues..

    suggest you find/join the forum where ibus gurus hang out..

    that is not here! try starting at http://code.google.com/p/ibus/

    --
    dd http://goo.gl/PUjnL

  4. #4

    Default Re: ibus not enabled after trigger hotkey

    Quote Originally Posted by hcvv View Post
    Where, what, ..................................................

    openSUSE version?

    Any desktop involved?
    sorry, i'm using OpenSUSE 12.2, KDE4.9

  5. #5
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: ibus not enabled after trigger hotkey

    Quote Originally Posted by n00bvn View Post
    sorry, i'm using OpenSUSE 12.2, KDE4.9
    need more infomations
    what repo you use?

    zypper lr -d

    what's your ibus version, and packages?

    rpm -qa | grep ibus

    what's your locale?

    locale

    any error when login X

    cat ~/.xsession-errors | grep ibus

    can't active IM in all applications or some of them?

  6. #6

    Default Re: ibus not enabled after trigger hotkey

    Quote Originally Posted by swyear View Post
    what repo you use?
    zypper lr -d
    Code:
    zypper lr -d
    #  | Alias                                      | Name                                                | Enabled | Refresh | Priority | Type   | URI                                                                                           | Service
    ---+--------------------------------------------+-----------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------------------+--------
     1 | download.opensuse.org-VirtualBox_backports | openSUSE BuildService - Virtualization (VirtualBox) | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization:/VirtualBox_backports/openSUSE_12.2/ |        
     2 | download.opensuse.org-Wine                 | openSUSE BuildService - Wine CVS Builds             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_12.2/                      |        
     3 | download.opensuse.org-database             | openSUSE BuildService - Database                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/server:/database/openSUSE_12.2/                     |        
     4 | download.opensuse.org-oss                  | Main Repository (Sources)                           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/12.2/repo/oss/                               |        
     5 | download.opensuse.org-php                  | openSUSE BuildService - PHP                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/server:/php/openSUSE_12.2/                          |        
     6 | download.opensuse.org-update               | Main Update Repository                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2/                                                     |        
     7 | google-chrome                              | google-chrome                                       | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                             |        
     8 | kde49                                      | kde49                                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/49/openSUSE_12.2/                     |        
     9 | packman.inode.at-suse                      | Packman Repository                                  | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.2/                                                            |        
    10 | repo-debug                                 | openSUSE-12.2-Debug                                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.2/repo/oss/                                |        
    11 | repo-debug-update                          | openSUSE-12.2-Update-Debug                          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.2/                                               |        
    12 | repo-debug-update-non-oss                  | openSUSE-12.2-Update-Debug-Non-Oss                  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.2-non-oss/                                       |        
    13 | repo-non-oss                               | openSUSE-12.2-Non-Oss                               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/non-oss/                                  |        
    14 | repo-oss                                   | openSUSE-12.2-Oss                                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/oss/                                      |        
    15 | repo-source                                | openSUSE-12.2-Source                                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.2/repo/oss/                               |        
    16 | repo-update                                | openSUSE-12.2-Update                                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2/                                                     |        
    17 | repo-update-non-oss                        | openSUSE-12.2-Update-Non-Oss                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2-non-oss/
    what's your ibus version, and packages?

    rpm -qa | grep ibus
    Code:
    rpm -qa | grep ibus
    ibus-gtk-1.4.1-3.2.2.i586
    libibus-1_0-0-1.4.1-3.2.2.i586
    ibus-qt-1.3.1-7.1.2.i586
    ibus-m17n-1.3.4-2.2.2.i586
    ibus-gtk3-1.4.1-3.2.2.i586
    ibus-1.4.1-3.2.2.i586


    what's your locale?

    locale
    Code:
    locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=


    any error when login X

    cat ~/.xsession-errors | grep ibus
    Code:
    cat ~/.xsession-errors | grep ibus
    sourcing /etc/X11/xim.d/en/40-ibus ...
    /etc/X11/xim.d/en/40-ibus started sucessfully


    can't active IM in all applications or some of them?
    Like I said, when I hit Ctrl+Space, ibus is even not enabled, so I cannot test it for any application.

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: ibus not enabled after trigger hotkey

    I guess it is obvious - but you must have your cursor in a text window to be able to trigger ibus.

    Have you actually set up your input method in ibus preferences.

    Try deleting the triggers that are there and set up your own. I use Control+Menu in the enable / disable window.

    This is what my prefs look like







    and ibus present in sys tray


  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: ibus not enabled after trigger hotkey

    oh, just re-read your first post.

    You only mention you cannot trigger ibus using shortcuts.

    If you put your cursor into a text input field in an application (safest bet would be to use your browser for testing) when you click on the ibus icon in the tray do you see your input method listed or does nothing happen?
    If nothing happens this indicates that your input method has not been set up.

    If you can see and use your input method using this procedure then it is simply a problem with your keyboard shortcuts.

  9. #9

    Default Re: ibus not enabled after trigger hotkey

    Quote Originally Posted by farcusnz View Post
    oh, just re-read your first post.

    You only mention you cannot trigger ibus using shortcuts.

    If you put your cursor into a text input field in an application (safest bet would be to use your browser for testing) when you click on the ibus icon in the tray do you see your input method listed or does nothing happen?
    If nothing happens this indicates that your input method has not been set up.

    If you can see and use your input method using this procedure then it is simply a problem with your keyboard shortcuts.
    Thank you so much. The reason that I cannot trigger is that I didn't point to application like kwrite. Now everything is ok.


    And I've another question is that, Can you use ibus with Microsoft Office Word 2007 in Wine or PlayOnLinux? cus' I cannot.

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: ibus not enabled after trigger hotkey

    Quote Originally Posted by n00bvn View Post
    Thank you so much. The reason that I cannot trigger is that I didn't point to application like kwrite. Now everything is ok.


    And I've another question is that, Can you use ibus with Microsoft Office Word 2007 in Wine or PlayOnLinux? cus' I cannot.
    sorry - I've got no idea. I've never had a need to use wine or playonlinux.
    I've always found LibreOffice enough for me to ever miss any feature that Microsoft Office has - and ibus works just fine with libreoffice.

    You may get some idea on how to get it going if you have a read through this (perhaps)
    https://allencch.wordpress.com/2012/...th-ibus-input/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •