Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: I can's boot into Linux Desktop???

  1. #11
    Join Date
    Mar 2009
    Location
    United States
    Posts
    612

    Default Re: I can's boot into Linux Desktop???

    If possible get a log for us. When you get to the prompt instead of using startx, login as root. Then run this command:
    Code:
    cat /var/log/Xorg.0.log | tail
    Also you can try booting into failsafe mode. There should be an 'advanced options' at the grub screen.

  2. #12
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can's boot into Linux Desktop???

    On 2013-01-07 21:46, MW0DBB wrote:
    >
    > I have to use su to be able to use startx.


    As I said, su will not work correctly, you have to add a dash. Or login
    directly as root in text mode. Or change the "/etc/permissions.local"
    file, see comments inside.

    > Nothing seems to work
    > otherwise. How can I get it to go directly into desktop instead of text
    > mode?


    Well, if startx works, then see the logs. If it doesn't, startx will say
    why, probably.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  3. #13

    Default Re: I can's boot into Linux Desktop???

    John-PC:~ # cat /var/log/Xorg.0.log | tail
    [ 15.432] (II) evdev: MCE IR Keyboard/Mouse (mceusb): initialized for relative axes.
    [ 15.432] (**) MCE IR Keyboard/Mouse (mceusb): (accel) keeping acceleration scheme 1
    [ 15.432] (**) MCE IR Keyboard/Mouse (mceusb): (accel) acceleration profile 0
    [ 15.432] (**) MCE IR Keyboard/Mouse (mceusb): (accel) acceleration factor: 2.000
    [ 15.432] (**) MCE IR Keyboard/Mouse (mceusb): (accel) acceleration threshold: 4
    [ 15.433] (II) config/udev: Adding input device MCE IR Keyboard/Mouse (mceusb) (/dev/input/mouse1)
    [ 15.433] (**) MCE IR Keyboard/Mouse (mceusb): Applying InputClass "LocalKeyboard"
    [ 15.433] (II) No input driver specified, ignoring this device.
    [ 15.433] (II) This device may have been added with another device file.
    [ 213.664] (II) AIGLX: Suspending AIGLX clients for VT switch
    John-PC:~ #

    /etc/permissions.local
    #
    # This file is used by SuSEconfig and chkstat to check or set the modes
    # and ownerships of files and directories in the installation.
    #
    # In particular, this file will not be touched during an upgrade of the
    # installation. It is designed to be a placeholder for local
    # additions by the administrator of the system to reflect filemodes
    # of locally installed packages or to override file permissions as
    # shipped with the distribution.
    #
    # Format:
    # <file> <owner>:<group> <permission>
    #
    # Please see the file /etc/permissions for general usage hints of the
    # /etc/permissions* files.
    # Please remember that logfiles might be modified by the logfile
    # rotation facilities (e.g. logrotate) so settings entered here might
    # be overridden. Also devices files (/dev/*) are not static but
    # managed via udev so this file can't be used to modify device
    # permissions either.
    #

    #
    # suexec is only secure if the document root doesn't contain files
    # writeable by wwwrun. Make sure you have a safe server setup
    # before setting the setuid bit! See also
    # https://bugzilla.novell.com/show_bug.cgi?id=263789
    # suEXEC Support - Apache HTTP Server
    #
    #/usr/sbin/suexec2 root:root 4755

    # setuid bit on Xorg is only needed if no display manager, ie startx
    # is used. Beware of CVE-2010-2240.
    #
    #/usr/bin/Xorg root:root 4711


    Thats what I'm getting.....I'm at present in Linux.

    John

  4. #14
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can's boot into Linux Desktop???

    On 2013-01-07 22:36, MW0DBB wrote:
    >
    > John-PC:~ # cat /var/log/Xorg.0.log | tail


    Please use code tags. Advanced editor, '#' button.
    View this
    thread for instructions



    >
    > /etc/permissions.local


    Don't copy it, edit it. There is something it says you have to do to use
    startx as user.

    I have said it three times already...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •