Results 1 to 6 of 6

Thread: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadata API

  1. #1
    Join Date
    Jan 2009
    Location
    Germany
    Posts
    5

    Default sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadata API

    Hi All,

    I'm using openSUSE 11.4 (x86_64) and wanted to use latest darktable from git repository.
    I finally managed the build, but a modification to the officially distributed sqlite3-devel was necessary.
    I would like to share the information about this issue for others and for the SUSE build team.

    That's what I did.
    I collected all prerequisites from SUSE repositories using yast2.

    During darktable build I've got the message "unresolved symbol sqlite3_table_column_metadata"

    Google delivered a link to old MacRumors Forum from 2008 saying:
    sqlit3.h says
    ** This API is only available if the library was compiled with the
    ** SQLITE_ENABLE_COLUMN_METADATA preprocessor symbol defined.*/
    (That seems still to be true.)

    Making sure to have the latest sqlite3-devel package installed on my opsneSUSE 11.4 did not solve the issue.

    So I downloaded sqlite3 source. Building it from scratch I used following configure command:
    ./configure --prefix /opt/sqlite3 CPPFLAGS=-DSQLITE_ENABLE_COLUMN_METADATA
    (Without uninstalling the sqlite3-devel package I just replaced the sqlite... files in /usr/include and /usr/lib64 by the new files in /opt/sqlite3 .)

    After that the build process for darktable went through flawlessly.

    Wouldn't it be helpful to have a fully featured sqlite3 in the SUSE repositories???

    Hope this helps someone to save time

    Karl

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadata API

    While I appreciate your work to post this here for the general openSUSE users, I must point to the fact that openSUSE 11.4 is out of support. Thus not very many people will have the whish to do as you did.
    Last edited by hcvv; 31-Dec-2012 at 12:09.
    Henk van Velden

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadataAPI

    On 2012-12-31 18:56, kcbehler wrote:
    >
    > Hi All,
    >
    > I'm using openSUSE 11.4 (x86_64) and wanted to use latest darktable
    > from git repository.


    There is a contradiction in what you say. 11.4 is old and out of
    official maintenance, and thus wanting to use the latest of anything or
    compiling something new for it is surely going to find problems because
    of that.

    No surprise you had to jump through loops.

    > I finally managed the build, but a modification to the officially
    > distributed sqlite3-devel was necessary.
    > I would like to share the information about this issue for others and
    > for the SUSE build team.


    I'm sorry to inform you that obviously the build team will have no
    interest in anything related to 11.4, which they have already abandoned.

    There is a volunteer project, Evergreen, which tries to maintain 11.4
    for some time, but only security patches. They might have some interest
    in this IF they need it to provide some upcomming security patch. They
    do not read this forum, but use a special mail list instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  4. #4
    Join Date
    Jan 2009
    Location
    Germany
    Posts
    5

    Default Re: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadataAPI

    I guess that there are some out there trying to use darktable under openSUSE whatever version.
    However, the latest darktable for openSUSE I could find was 1.0.4 which is outdated. So they may want to build it by their own. (Which I encourage. It works.)
    So I thought it could be helpful to know about issues building darktable under openSUSE. (Even when I did it under 11.4.)

    I just checked what's the sqlite version under openSUSE 12.2 is about.
    sqlite3-3.7.12.1-2.1.2.x86_64 RPM
    If that's the relevant documentation about the current SUSE build, then I can't see that recent changes mention sqlite for SUSE is now build with SQLITE_ENABLE_COLUMN_METADATA defined. So it may still be an issue for anybody who wants to build the latest darktable from scratch under the latest openSUSE 12.2. (May be someone can check this?)

    Sorry for bothering you, but may be this is of relevance for the SUSE build team.

    Regards,

    Karl

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadataAPI

    On 2013-01-02 17:46, kcbehler wrote:
    > Sorry for bothering you, but may be this is of relevance for the SUSE
    > build team.


    I must insist that the SUSE build team does not read here.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  6. #6
    Join Date
    Jan 2009
    Location
    Germany
    Posts
    5

    Default Re: sqlite3 rpm package 3.7.5-2.1 not providing sqlite3_table_column_metadataAPI

    Quote Originally Posted by robin_listas View Post
    I must insist that the SUSE build team does not read here.
    I think I found the right place. Thanks for your feedback.

    Karl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •