Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: make

  1. #1

    Default make

    When I try to install a new program with make I get:

    Makefile. inc:91: ***KERNELCONF: /lib/modules/2.6.27.56-0.1-pae/build/.config does not exist... stopped

    What now?
    Thanks.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: make

    On 2012-12-30 17:46, dendeezen1 wrote:
    >
    > When I try to install a new program with make I get:
    >
    > Makefile. inc:91: ***KERNELCONF:
    > /lib/modules/2.6.27.56-0.1-pae/build/.config does not exist... stopped


    That's a problem of whatever you are trying to build, not of make. Did
    you run the configure phase previously?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,869

    Default Re: make

    Quote Originally Posted by dendeezen1 View Post
    When I try to install a new program with make I get:

    Makefile. inc:91: ***KERNELCONF: /lib/modules/2.6.27.56-0.1-pae/build/.config does not exist... stopped

    What now?
    Thanks.
    Try not to post the minimum of almost nothing when you have a problem, but more, much more. Even if you think it may be superfluous.

    Thus you should post the complete make session as it is on your terminal. That is prompt, the make command, the output and the next prompt. And all of that between CODE tags (use the # button in the toolbar of the post editor).

    And it wouldn't be bad either to tell what you are trying to build (not to install, you are way before even trying to install). Sometimes people have done what you try to do before and could help you, But they will not even read your thread with such a lousy title and such lack of information.
    Henk van Velden

  4. #4

    Default Re: make

    Quote Originally Posted by robin_listas View Post
    On 2012-12-30 17:46, dendeezen1 wrote:
    >
    > When I try to install a new program with make I get:
    >
    > Makefile. inc:91: ***KERNELCONF:
    > /lib/modules/2.6.27.56-0.1-pae/build/.config does not exist... stopped


    That's a problem of whatever you are trying to build, not of make. Did
    you run the configure phase previously?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

    I try to make run a wifi D-Link DWL-G650+ on SUSE11.1 with madwifi-8.9.4

    The install file doesn't mention configure or ./configure or whatever.
    I gave it a try anyway, with no effects. (command not found; I am of course su)
    It says:" Linux 2.4.x kernels starting with 2.4.22 and 2.6 kernels should work without problems."
    I have a 2.6.27.7-9-pae kernel.
    If also says:" Most people can just type:
    $ make "

    As a newbie, what do I miss?
    Thanks

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: make

    On 2012-12-31 09:06, dendeezen1 wrote:

    > As a newbie, what do I miss?
    > Thanks


    Ok, try:

    Code:
    cd /usr/src/linux
    make cloneconfig
    make prepare
    then try again your code.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: make

    As already said in the dutch thread, there's a couple of problems here:

    - old hardware of which we do not know what it is
    - an old openSUSE version which is beyond it's end of life for a long time

    Please do yourself a favour and get help on installing a recent version on your machine, get help doing so and please provide as much info as you can. Shooting in the dark is for the New Year.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: make

    Quote Originally Posted by robin_listas View Post
    On 2012-12-31 09:06, dendeezen1 wrote:

    > As a newbie, what do I miss?
    > Thanks


    Ok, try:

    Code:
    cd /usr/src/linux
    make cloneconfig
    make prepare
    then try again your code.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))
    I got the following replay (translating) :
    "make: *** There is no rule to make a goal 'cloneconfig'. Stopped "

    Other sugestions?

    Happy Newyear!!!!

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: make

    Quote Originally Posted by dendeezen1 View Post
    I got the following replay (translating) :
    "make: *** There is no rule to make a goal 'cloneconfig'. Stopped "

    Other sugestions?

    Happy Newyear!!!!
    No kernel-sources installed?
    Code:
    rpm -qa | grep kernel-source
    Mind, for madwifi you'll also need the kernel-source package matching your running kernel. I'm wondering, is this some kind of experiment, or is your goal to actually use this laptop?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: make

    Quote Originally Posted by Knurpht View Post
    No kernel-sources installed?
    Code:
    rpm -qa | grep kernel-source
    Mind, for madwifi you'll also need the kernel-source package matching your running kernel. I'm wondering, is this some kind of experiment, or is your goal to actually use this laptop?
    This is a kind of an experiment (I learn a lot) and I also plan to use the laptop (it works fine, I just want to
    go wireless on the net )

    With Yast2 I installed the kernel-default( after reboot 'uname -r' : 2.6.27.56-pae) and the kernel-source package
    (kernel-source-2.6.27.56-0.1.1)

    The 'make' command now runs fine ( so the problem is solved, the kernel-sources were not installed), but by running on the and I get some error indications:

    /home/patrick/Downloads/MadWifi/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
    /home/patrick/Downloads/MadWifi/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
    make[5]: *** [/home/patrick/Downloads/MadWifi/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
    make[4]: *** [/home/patrick/Downloads/MadWifi/madwifi-0.9.4/net80211] Error 2
    make[3]: *** [_module_/home/patrick/Downloads/MadWifi/madwifi-0.9.4] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.27.56-0.1-obj/i386/pae'
    make: *** [modules] Fout 2

    ('fout' is dutch for error)

    How do I deal with this problem?

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: make

    it runs fine
    It doesn't, it does not finish the compilation of the sources. And it does not compile against kernel-default, it compiles against kernel-pae.
    And please, post output between CODE tags(the # in the editor), it's unreadable like this.
    Last edited by Knurpht; 01-Jan-2013 at 06:18.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •