Results 1 to 2 of 2

Thread: Neuinstallation SUSE 12.2 (32bit), Kde will nicht starten

  1. #1

    Default Neuinstallation SUSE 12.2 (32bit), Kde will nicht starten

    Hallo Forum,

    ich habe nun auch meinem älteren Rechner eine frische SuSE verpasst.

    Selbst nach x Versuchen (OS nochmal installieren, nVidia installieren usw.) , schaffe ich nicht den Bootvorgang bis zum Ende mit Kde Desktop.
    Bis zum Anmeldebildschirm ist alles in Ordnung. Erst nach dem login, im letzten Schritt, wenn das Bild zum Kde wechseln soll, ist der Bildschirm schwarz, ohne Inhalt.

    Bisher ist der Rechner gut mit SUSE 12.1 und mit dem Nouveau-Treiber gelaufen. Der TFT-Bildschirm ist ein uralt-Gerät (Siemens-Fujitsu MCF 3811 TA) und wird nur für office-Anwendungen verwendet. Die Gra-Ka ist eine GeForce FX 5700LE. Im YAST Hardware Information werden beide als sauber installiert aufgeführt.

    Die Fehlermeldung, wenn ich per Text-Konsolen-Modus starte und "startx" eingebe:

    > hostname: Der Name oder der Dienst ist nicht bekannt
    > xauth: file /home/suse1/.serverauth.2283 does not exist
    > Fatal server error: Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old" ( Bemerkung: weil "/var/log/Xorg.0.log.old" bereits besteht )
    > xinit: giving up
    > xinit: unable to connect to X server: Connection refused
    > xinit: server error
    > xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
    > If so either use a display manager (strongly recommended) or adjust /etc/permissions.local

    Die Fehlermeldung, wenn ich per Text-Konsolen-Modus starte und "startkde" eingebe:

    > $DISPLAY is not set or cannot connect to the X server.

    Wenn mir jemand dazu Hilfe geben könnte, wäre ich dankbar !
    Gruß
    su_lin_user

    -
    PC TUXEDO - AMD 64 Phenom(tm) II X4(3,2MH) 945 | RAM 4GB DDR3 | GT210 (HDMI) | FP 500 GB/2000 GB | BluRay/DVD-RW | USB 3.0 - OS SUSE Leap15.0/WIN 7 | KDE 5.12.8 | Firefox

  2. #2

    Default Re: ( gelöst ) Neuinstallation SUSE 12.2 (32bit), Kde will nicht starten

    Hallo Forum,

    bei weiterer Suche nach einer Lösung, bin ich auf die richtige Ursache des Fehlers gestoßen.

    (siehe https://www.suse.com/releasenotes/i386/openSUSE/12.2/RELEASE-NOTES.de.html)

    Initialisierung der Grafik mit KMS (Kernel Mode Setting)

    Mit erscheinen von openSUSE 11.3 wechselten wir zu KMS (Kernel Mode Setting) für Intel, ATI und NVIDIA-Grafik. Wenn Probleme mit der KMS-Treiber-Unterstützung (Intel, radeon, nouveau) auftreten, deaktivieren Sie KMS indem Sie nomodeset der Kernel-Boot-Befehlszeile hinzufügen. Um diese Einstellung mit Grub 2, dem Standard-Bootloader, dauerhaft zu speichern, fügen Sie diesen Eintrag als root bei GRUB_CMDLINE_LINUX_DEFAULT in Ihre "/etc/default/grub" ein und führen anschließend, ebenfalls als root, den folgenden Befehl in einem Terminal aus:

    sudo /usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg

    damit die Änderungen in kraft treten.
    -> hat geklappt !!
    Gruß
    su_lin_user

    -
    PC TUXEDO - AMD 64 Phenom(tm) II X4(3,2MH) 945 | RAM 4GB DDR3 | GT210 (HDMI) | FP 500 GB/2000 GB | BluRay/DVD-RW | USB 3.0 - OS SUSE Leap15.0/WIN 7 | KDE 5.12.8 | Firefox

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •