Results 1 to 5 of 5

Thread: Some PDF prints gives error, maybe cups-filter version

  1. #1

    Question Some PDF prints gives error, maybe cups-filter version

    Hi all,

    I have openSUSE 12.2 (x86_64)
    Since a few weeks I have problems with printing some PDF files, it worked before with the same PDF files, and other PDF files are still working. I think it is since one of the last updates.

    When I look at the /var/log/cups/error_log file I see some error lines that triggers me:
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15988 (pdftops) crashed on signal 8!
    D [27/Dec/2012:00:07:48 +0100] [Job 56] The %%EndSetup comment is missing.
    D [27/Dec/2012:00:07:48 +0100] [Job 56] Before page loop - DEBUG: Wrote 0 pages...
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15989 (pstops) exited with no errors.

    When I search at google for this error, one of the results is https://bugs.archlinux.org/task/30786 . There they point to a bug in cups-filters 1.0.19-1 .
    I don't know how to check cups-filters version. If I looked for the software by the package manager I can't find cups-filters. When I look at
    /usr/lib/cups/filter/ , the directory exists, but something like cups-filters or pdftops --version didn't worked.
    Any clue how to check the version, and more important, if this is the same bug, how to update my cups-filters?

    Thanks for helping me.

    Jurjen

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Some PDF prints gives error, maybe cups-filter version

    Quote Originally Posted by jurjendevries View Post
    Hi all,

    I have openSUSE 12.2 (x86_64)
    Since a few weeks I have problems with printing some PDF files, it worked before with the same PDF files, and other PDF files are still working. I think it is since one of the last updates.

    When I look at the /var/log/cups/error_log file I see some error lines that triggers me:
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15988 (pdftops) crashed on signal 8!
    D [27/Dec/2012:00:07:48 +0100] [Job 56] The %%EndSetup comment is missing.
    D [27/Dec/2012:00:07:48 +0100] [Job 56] Before page loop - DEBUG: Wrote 0 pages...
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15989 (pstops) exited with no errors.

    When I search at google for this error, one of the results is https://bugs.archlinux.org/task/30786 . There they point to a bug in cups-filters 1.0.19-1 .
    I don't know how to check cups-filters version. If I looked for the software by the package manager I can't find cups-filters. When I look at
    /usr/lib/cups/filter/ , the directory exists, but something like cups-filters or pdftops --version didn't worked.
    Any clue how to check the version, and more important, if this is the same bug, how to update my cups-filters?

    Thanks for helping me.

    Jurjen
    So I am not sure I have ever heard of such a problem, but it can't hurt to upgrade printing related applications with a new repository. To fully upgrade, I would do the following tasks for openSUSE 12.2 using KDE:

    1A. Go to YaST (Enter Root Password) / Software / Software Repositories and add in the URL of the Printing Repository "http://download.opensuse.org/repositories/Printing/openSUSE_12.2/" excluding the quotes and call it Printing. I would give it a priority of 30.

    1B. Go to YaST (Enter Root Password) / Software / Software Repositories and add in the URL of the Packman Repository "http://packman.inode.at/suse/openSUSE_12.2/" excluding the quotes if not already done, call it Packman and give it a Priority of 10.

    2. Go to YaST (Enter Root Password) / Software / Software Management and select Options and check Allow Vendor Change.

    3. Again, still in Software Management select Package / All Packages / Update if newer version available and press the Accept button on the bottom right.

    See if this helps out any.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Some PDF prints gives error, maybe cups-filter version

    Quote Originally Posted by jurjendevries View Post
    Hi all,

    I have openSUSE 12.2 (x86_64)
    Since a few weeks I have problems with printing some PDF files, it worked before with the same PDF files, and other PDF files are still working. I think it is since one of the last updates.

    When I look at the /var/log/cups/error_log file I see some error lines that triggers me:
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15988 (pdftops) crashed on signal 8!
    D [27/Dec/2012:00:07:48 +0100] [Job 56] The %%EndSetup comment is missing.
    D [27/Dec/2012:00:07:48 +0100] [Job 56] Before page loop - DEBUG: Wrote 0 pages...
    D [27/Dec/2012:00:07:48 +0100] [Job 56] PID 15989 (pstops) exited with no errors.

    When I search at google for this error, one of the results is https://bugs.archlinux.org/task/30786 . There they point to a bug in cups-filters 1.0.19-1 .
    I don't know how to check cups-filters version. If I looked for the software by the package manager I can't find cups-filters. When I look at
    /usr/lib/cups/filter/ , the directory exists, but something like cups-filters or pdftops --version didn't worked.
    Any clue how to check the version, and more important, if this is the same bug, how to update my cups-filters?

    Thanks for helping me.

    Jurjen
    I am seeing there is a bug report with CUP's that sounds like your problem. You can read about it here: https://bugzilla.novell.com/show_bug.cgi?id=795582

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Some PDF prints gives error, maybe cups-filter version

    Hi James,

    Thank you for your quick response!
    I followed your instructions, and rebooted my PC. Now it is working :-)

    About bug 795582, I had the problem randomly from PDF application and browser, so not only from the browser as described at that bug.

    Kind regards,
    Jurjen

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Some PDF prints gives error, maybe cups-filter version

    Quote Originally Posted by jurjendevries View Post
    Hi James,

    Thank you for your quick response!
    I followed your instructions, and rebooted my PC. Now it is working :-)

    About bug 795582, I had the problem randomly from PDF application and browser, so not only from the browser as described at that bug.

    Kind regards,
    Jurjen
    Well I love to hear about success. Happy to hear you are up and working again.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •