Results 1 to 3 of 3

Thread: Kmail html formats quoted text as black on black in outgoing email

  1. #1

    Default Kmail html formats quoted text as black on black in outgoing email

    I have kmail set to send both text and html e-mails. In the outgoing email, if the incoming mail being quoted was in html, the outgoing quoted html text comes out as black blocks - black text on a black background. In settings, my colors are at the default - green for quoted text - and I see no place to alter settings so that kmail won't do this. I also cannot find a menu item to reformat the html text background.

    Is there a way to change this behavior, preferably as a default setting?

    Thanks.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Kmail html formats quoted text as black on black in outgoingemail

    On 2012-12-21 21:26, bearymore wrote:
    > I have kmail set to send both text and html e-mails


    IMHO, using kmail for html mails is futile, it is not finished. Use
    thundderbird instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,562

    Default Re: Kmail html formats quoted text as black on black in outgoing email

    Quote Originally Posted by bearymore View Post
    I have kmail set to send both text and html e-mails. In the outgoing email, if the incoming mail being quoted was in html, the outgoing quoted html text comes out as black blocks - black text on a black background. In settings, my colors are at the default - green for quoted text - and I see no place to alter settings so that kmail won't do this. I also cannot find a menu item to reformat the html text background.

    Is there a way to change this behavior, preferably as a default setting?

    Thanks.
    what version of kmail are you using?
    Prior to Kmail 4.8 reply in html was not supported.
    However, as robin_listas said, Thunderbird will still give you better html support than kmail.
    Having said that, I do not see the behaviour you describe in kmail 4.9 and html replies mostly look ok to me.
    The only problems I run into with html replies is when tables are involved.

    edit: what you describe could be related to character encoding. What is our default encoding? Do you have utf8 in your list of preferred codings? Have you check the box to try and reply using the same encoding as the original email?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •