Results 1 to 9 of 9

Thread: openSUSE 12.2 - Yast2 - Software management

  1. #1
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Exclamation openSUSE 12.2 - Yast2 - Software management

    Good day friends, after upgrading from 12.1 to 12.2 i have noticed that the Software Management module from Yast is not working as it should:
    "An error occurred during repository initialization." - every time it tries to refresh the repos that i have enabled.

    If the above errors does not happen, the module crashes when i try to install something. Here is the output after the crash:


    Code:
    (process:4536): Gtk-WARNING **: Locale not supported by C library.
    	Using the fallback 'C' locale.
    terminate called after throwing an instance of 'std::runtime_error'
      what():  locale::facet::_S_create_c_locale name not valid
    YaST got signal 6 at YCP file String.ycp:170
    /sbin/yast2: line 427:  4536 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    
    
    (process:4626): Gtk-WARNING **: Locale not supported by C library.
    	Using the fallback 'C' locale.
    Is there any way to fix this? And of course is there a bug opened about this ?

    System specs are: openSUSE 12.2, Gnome 3.4, 32bits.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  2. #2

    Default Re: openSUSE 12.2 - Yast2 - Software management

    This looks strange. Which locale do you use actually? (check "locale" command output)

    You could try running yast with C or with en_US locale - run as root:

    LC_ALL=C yast2 sw_single

    or

    LC_ALL=en_US.UTF-8 yast2 sw_single

  3. #3
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: openSUSE 12.2 - Yast2 - Software management

    Running locale inside the terminal as normal user i get the following output:
    Code:
    creatura@creation:~> locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    creatura@creation:~>
    Btw, do you have idea about the error i get from Software Managament module ?


    Running the command LC_ALL=en_US.UTF-8 yast2 sw_single i get the following output:

    Code:
    creation:/home/creatura # LC_ALL=en_US.UTF-8 yast2 sw_single
    /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    
    
    (process:12408): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    Running LC_ALL=C yast2 sw_single i no more output about missing files. Still very weird, i never got this before.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 12.2 - Yast2 - Software management

    On 2012-12-20 18:16, creatura85 wrote:
    >
    > Running locale inside the terminal as normal user i get the following
    > output:
    >
    > Code:
    > --------------------
    > creatura@creation:~> locale
    > locale: Cannot set LC_CTYPE to default locale: No such file or directory
    > locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    > locale: Cannot set LC_ALL to default locale: No such file or directory

    ....
    > --------------------


    IMO, that's the bad locale gzip update, you have to back to the previous
    version.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  5. #5
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: openSUSE 12.2 - Yast2 - Software management

    @robin_listas, you are corect my Geeko friend it seems that a small glitch happened when upgrading from 12.1 to 12.2 with glibc (and other packages related to him like devel, extra, i18ndata, info and locale). After a downgrade to the version offerend by the openSUSE 12.2 repos all is working again, no more errors from Software Management or crashes when trying to install packages.

    Code:
    creatura@creation:~> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    creatura@creation:~>
    If a moderator see this topic, please feel free to close it down and add the "[SOLVED]" label to it
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 12.2 - Yast2 - Software management

    On 2012-12-20 20:26, creatura85 wrote:
    >
    > @robin_listas, you are corect my Geeko friend it seems that a small
    > glitch happened when upgrading from 12.1 to 12.2 with glibc (and other
    > packages related to him like devel, extra, i18ndata, info and locale).
    > After a downgrade to the version offerend by the openSUSE 12.2 repos all
    > is working again, no more errors from Software Management or crashes
    > when trying to install packages.


    Yes, it is a known bug added by a recent update. They are trying to
    create another update to correct that - I thought that they had removed
    the bad update :-(

    > If a moderator see this topic, please feel free to close it down and
    > add the "[SOLVED]" label to it


    They don't do that on these parts :-)

    There is a tag somewhere that you can click to say solved - can't say
    where because I access the forum via nntp, not web.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  7. #7
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: openSUSE 12.2 - Yast2 - Software management

    Quote Originally Posted by robin_listas View Post
    On 2012-12-20 20:26, creatura85 wrote:
    >
    > @robin_listas, you are corect my Geeko friend it seems that a small
    > glitch happened when upgrading from 12.1 to 12.2 with glibc (and other
    > packages related to him like devel, extra, i18ndata, info and locale).
    > After a downgrade to the version offerend by the openSUSE 12.2 repos all
    > is working again, no more errors from Software Management or crashes
    > when trying to install packages.


    Yes, it is a known bug added by a recent update. They are trying to
    create another update to correct that - I thought that they had removed
    the bad update :-(

    > If a moderator see this topic, please feel free to close it down and
    > add the "[SOLVED]" label to it


    They don't do that on these parts :-)

    There is a tag somewhere that you can click to say solved - can't say
    where because I access the forum via nntp, not web.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))
    No, it seems the bad update is still here.

    Ok, i just added the "[SOLVED]" tag to the topic
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  8. #8

    Default Re: openSUSE 12.2 - Yast2 - Software management

    Quote Originally Posted by creatura85 View Post
    No, it seems the bad update is still here.

    Ok, i just added the "[SOLVED]" tag to the topic
    Solved??? How, when you cannot get to the update repository with this probem?
    Sure, there is a cure, but it is not accessible!

    Also, this does not occur with 12.2 and XFCE and Kde3, but it did when I installed 12.2 with Kde4. Another negative for kde4?

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,402
    Blog Entries
    2

    Default Re: openSUSE 12.2 - Yast2 - Software management

    So, I'm wondering and unless the OP is willing to upgrade again(undo the downgrade),

    Is this fixable by simply setting a locale through YAST (eg no corruption, setting is just missing)?
    Or, if a package is suspected missing or not properly installed, can it be forcibly re-installed?
    So, for instance I wouldn't know for sure but suspect that the appropriate packages are glibc-locale and glibc-locale-32bit on a 64bit machine so the following might be tried

    Code:
    # zypper -force in glibc-locale glibc-locale-32bit
    Followed by configuring the locale.

    TSU

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •