Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

  1. #1

    Default upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    good day dear gentlemen



    how to upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    i run openSuse version 12.2


    should i do this with the YAST and the repository or should i try to do with the Command-line!?

    look forward to hear from you

    greetings
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,386

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    The newest version is in the LibreOffice:Stable repository; so you could add that to your list of repositories. Alternatively, go to software.opensuse.org, search for libreoffice and select the alternatives and, after a couple more clicks, you should be able to one-click install the LibreOffice:Stable version.

    I'm sure someone will tell you how to do it via the command line if you prefer that.

  3. #3
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,474

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    one way of doing things with cmd line + help from yast,

    1. download libreoffice files from LibreOffice Productivity Suite Download ,
    e.g.for the British English language version its,
    - LibO_3.6.4_Linux_x86-64_helppack-rpm_en-GB.tar.gz
    - LibO_3.6.4_Linux_x86-64_install-rpm_en-US.tar.gz
    - LibO_3.6.4_Linux_x86-64_langpack-rpm_en-GB.tar.gz
    and expand the above into a single directory then split the files into wanted and unwanted directories

    for my requirements the
    wanted ones are,
    Code:
    libobasis3.6-base-3.6.4.3-3.x86_64.rpm
    libobasis3.6-binfilter-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-calc-3.6.4.3-3.x86_64.rpm
    libobasis3.6-core01-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core02-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core03-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core04-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core05-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core06-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-core07-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-draw-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-base-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-calc-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-help-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-math-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-GB-res-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-en-GB-writer-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-extension-beanshell-script-provider-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-javascript-script-provider-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-mediawiki-publisher-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-nlpsolver-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-extension-pdf-import-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-presentation-minimizer-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-presenter-screen-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-python-script-provider-3.6.4.3-3.x86_64.rpm
    libobasis3.6-extension-report-builder-3.6.4.3-3.x86_64.rpm
    libobasis3.6-graphicfilter-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-images-3.6.4.3-3.x86_64.rpm
    libobasis3.6-impress-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-javafilter-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-kde-integration-3.6.4.3-3.x86_64.rpm
    libobasis3.6-math-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-ogltrans-3.6.4.3-3.x86_64.rpm
    libobasis3.6-onlineupdate-3.6.4.3-3.x86_64.rpm
    libobasis3.6-ooofonts-3.6.4.3-3.x86_64.rpm
    libobasis3.6-ooolinguistic-3.6.4.3-3.x86_64.rpm
    libobasis3.6-postgresql-sdbc-3.6.4.3-3.x86_64.rpm
    libobasis3.6-pyuno-3.6.4.3-3.x86_64.rpm
    libobasis3.6-writer-3.6.4.3-3.x86_64.rpm
    libobasis3.6-xsltfilter-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-base-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-calc-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-dict-en-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-dict-es-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-dict-fr-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-draw-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-en-GB-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-impress-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-math-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-stdlibs-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-suse-menus-3.6.4-3.noarch.rpm
    libreoffice3.6-ure-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-writer-3.6.4.3-3.x86_64.rpm
    unwanted ones are,
    Code:
    libobasis3.6-en-US-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-US-base-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-US-calc-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-US-math-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-US-res-3.6.4.3-3.x86_64.rpm
    libobasis3.6-en-US-writer-3.6.4.3-3.x86_64.rpm 
    libobasis3.6-gnome-integration-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-en-US-3.6.4.3-3.x86_64.rpm
    libreoffice3.6-freedesktop-menus-3.6.4-3.noarch.rpm
    libreoffice3.6-mandriva-menus-3.6.4-3.noarch.rpm
    README_en-US
    2. in yast program manager, search for libreoffice, and delete all installed files (do a warm reboot for safety)

    3. in the wanted directory run the cmd (correct output is shown)
    Code:
    rpm -Uhv --test *.rpm
    Preparing...                ########################################### [100%]
    if there are no dependency issues, run cmd without the --test parameter
    Code:
    rpm -Uhv *.rpm
    Preparing...                ########################################### [100%]
       1:libreoffice3.6-ure     ########################################### [  2%]
       2:libobasis3.6-core01    ########################################### [  4%]
       3:libobasis3.6-core02    ########################################### [  5%]
       4:libobasis3.6-core03    ########################################### [  7%]
       5:libobasis3.6-core04    ########################################### [  9%]
       6:libobasis3.6-core05    ########################################### [ 11%]
       7:libobasis3.6-core06    ########################################### [ 13%]
       8:libobasis3.6-core07    ########################################### [ 15%]
       9:libobasis3.6-en-GB     ########################################### [ 16%]
      10:libobasis3.6-base      ########################################### [ 18%]
      11:libobasis3.6-impress   ########################################### [ 20%]
      12:libobasis3.6-en-GB-base########################################### [ 22%]
      13:libobasis3.6-en-GB-calc########################################### [ 24%]
      14:libobasis3.6-en-GB-math########################################### [ 25%]
      15:libobasis3.6-en-GB-res ########################################### [ 27%]
      16:libobasis3.6-en-GB-writ########################################### [ 29%]
      17:libobasis3.6-calc      ########################################### [ 31%]
      18:libobasis3.6-draw      ########################################### [ 33%]
      19:libobasis3.6-images    ########################################### [ 35%]
      20:libreoffice3.6         ########################################### [ 36%]
      21:libobasis3.6-math      ########################################### [ 38%]
      22:libobasis3.6-writer    ########################################### [ 40%]
      23:libreoffice3.6-writer  ########################################### [ 42%]
      24:libreoffice3.6-math    ########################################### [ 44%]
      25:libreoffice3.6-base    ########################################### [ 45%]
      26:libreoffice3.6-calc    ########################################### [ 47%]
      27:libreoffice3.6-dict-en ########################################### [ 49%]
      28:libreoffice3.6-dict-es ########################################### [ 51%]
      29:libreoffice3.6-dict-fr ########################################### [ 53%]
      30:libreoffice3.6-draw    ########################################### [ 55%]
      31:libreoffice3.6-en-GB   ########################################### [ 56%]
      32:libreoffice3.6-impress ########################################### [ 58%]
      33:libobasis3.6-ogltrans  ########################################### [ 60%]
      34:libobasis3.6-postgresql########################################### [ 62%]
      35:libobasis3.6-en-GB-help########################################### [ 64%]
      36:libobasis3.6-extension-########################################### [ 65%]
      37:libobasis3.6-extension-########################################### [ 67%]
      38:libobasis3.6-extension-########################################### [ 69%]
      39:libobasis3.6-extension-########################################### [ 71%]
      40:libobasis3.6-extension-########################################### [ 73%]
      41:libobasis3.6-extension-########################################### [ 75%]
      42:libobasis3.6-extension-########################################### [ 76%]
      43:libobasis3.6-extension-########################################### [ 78%]
      44:libobasis3.6-extension-########################################### [ 80%]
      45:libobasis3.6-binfilter ########################################### [ 82%]
      46:libobasis3.6-graphicfil########################################### [ 84%]
      47:libobasis3.6-javafilter########################################### [ 85%]
      48:libobasis3.6-kde-integr########################################### [ 87%]
      49:libobasis3.6-onlineupda########################################### [ 89%]
      50:libobasis3.6-ooofonts  ########################################### [ 91%]
      51:libobasis3.6-ooolinguis########################################### [ 93%]
      52:libobasis3.6-pyuno     ########################################### [ 95%]
      53:libobasis3.6-xsltfilter########################################### [ 96%]
      54:libreoffice3.6-suse-men########################################### [ 98%]
    Unknown media type in type 'all/all'
    Unknown media type in type 'all/allfiles'
    Unknown media type in type 'uri/mms'
    Unknown media type in type 'uri/mmst'
    Unknown media type in type 'uri/mmsu'
    Unknown media type in type 'uri/pnm'
    Unknown media type in type 'uri/rtspt'
    Unknown media type in type 'uri/rtspu'
      55:libreoffice3.6-stdlibs ########################################### [100%]
    if all has gone to plan do another warm reboot.

    4. If you had previously loaded language packages, you most likely will have to re-install them,
    In Writer its,
    - Tools, -- Extersion Manager, --- Add
    and then point to where the required .oxt files are stored.

    Alternatively follow the instructions in the README file.

    have fun

  4. #4

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)to the newest version!?

    On Sat, 15 Dec 2012 22:06:01 GMT
    dilbertone <dilbertone@no-mx.forums.opensuse.org> wrote:

    >
    > how to upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)
    > to the newest version!?
    >
    > i run openSuse version 12.2
    >


    Warning: If you use Calc and want to create graphs, don't upgrade! LO
    3.6.3 will remove both new and existing graphs.

    I haven't entered a bug report yet as I wanted to get reaction here and
    on LO newsgroup. I think I also should try LO 3.6.4 from their
    web-site. On this newsgroup, the problem has been raised and verified.
    The LO newsgroup remains silent.


    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 12.3-M2 (64-bit); KDE 4.9.90; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,796

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)to the newest version!?

    Quote Originally Posted by Cloddy View Post
    If you use Calc and want to create graphs, don't upgrade! LO
    3.6.3 will remove both new and existing graphs.
    Running version 3.6:build-303 (3.6.3.2.3-1.1_x86_64) from LO community repo.

    Tested with existing .odt spreadsheet with XY (dispersion) graphics, loaded, saved as new title and reloaded OK, no graphics corruption/deletion.

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,796

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    Obs: tested on openSUSE 11.4 x86_64, KDE 4.8.5.

  7. #7

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)to the newest version!?

    On Sun, 16 Dec 2012 12:36:01 GMT
    brunomcl <brunomcl@no-mx.forums.opensuse.org> wrote:

    >
    > Cloddy;2511149 Wrote:
    > > If you use Calc and want to create graphs, don't upgrade! LO
    > > 3.6.3 will remove both new and existing graphs.

    >
    > Running version 3.6:build-303 (3.6.3.2.3-1.1_x86_64) from LO community
    > repo.
    >
    > Tested with existing .odt spreadsheet with XY (dispersion) graphics,
    > loaded, saved as new title and reloaded OK, no graphics
    > corruption/deletion.
    >
    >


    Did you try to edit the graphs after saving them from 3.6.3? Sorry that
    I failed to mention this vital point originally.

    See https://bugzilla.novell.com/show_bug.cgi?id=794698

    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 12.3-M2 (64-bit); KDE 4.9.90; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,796

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)to the newest version!?

    Quote Originally Posted by Cloddy View Post
    Did you try to edit the graphs after saving them from 3.6.3? Sorry that
    I failed to mention this vital point originally.
    Just did. Selected the data line, changed the graphics type from XY to Area. Graphics changed OK. Saved, closed, opened again, area graph still there, no errors. Perhaps the problem is related to the oS 12.2 build (I'm using oS 11.4)?

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,474

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403) to the newest version!?

    @cloddy

    I've never seen such a problem with any version of LibreOffice, my install is

    Code:
    Kernel:     3.6.10-1-desktop x86_64 (64 bit), AMD Phenom II X4 940
    Desktop:    KDE 4.9.4 "release 5"
    Distro:     openSUSE 12.2 (x86_64)
    LibreOffice:     Version 3.6.4.3 (Build ID: 2ef5aff)
    but then you are ahead of me on the beta installs

    my files / charts / graphs are updated on a daily basis

  10. #10

    Default Re: upgrade LibreOffice 3.5:build-403 Build-ID: 350m1(Build:403)to the newest version!?

    On Sun, 16 Dec 2012 13:16:01 GMT
    keellambert <keellambert@no-mx.forums.opensuse.org> wrote:

    >
    > @cloddy
    >
    > I've never seen such a problem with any version of LibreOffice, my
    > install is
    >
    >
    > Code:
    > --------------------
    >
    > Kernel: 3.6.10-1-desktop x86_64 (64 bit), AMD Phenom II X4 940
    > Desktop: KDE 4.9.4 "release 5"
    > Distro: openSUSE 12.2 (x86_64)
    > LibreOffice: Version 3.6.4.3 (Build ID: 2ef5aff)
    >
    > --------------------
    >
    >
    > but then you are ahead of me on the beta installs
    >
    > my files / charts / graphs are updated on a daily basis
    >
    >


    But you are ahead of me on the LibreOffice installs. ;-)

    I tried installing 3.6.4 in 12.3-M2 but it wasn't successful so
    reverted to the openSUSE version of 3.6.3. Maybe I'll have to switch
    back to 12.2 and try to install it there.

    As to not seeing this behaviour before with LO, I know I've seen it
    before but it may have been back in the days of OOo! Anyway, at least
    other people have reported the same trouble with 3.6.3 so I'm not
    alone.


    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 12.3-M2 (64-bit); KDE 4.9.90; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •