Results 1 to 6 of 6

Thread: Thunderbird does not work properly with Enigmail gnuPGP pinentry

  1. #1

    Default Thunderbird does not work properly with Enigmail gnuPGP pinentry

    I have installed

    OpenSUSE 12.2
    GnuPGP 2.0.19
    Thunderbird 17.0
    Enigmail 1.4.6
    pinentry 0.8.1

    Everythin was installed using yast. Yes the Enigmail addon too.

    Now I have the problem that I am not able to creat in Thunderbird/Enigmail an new key pair that is protected with an passphrase. Everything works fine when I use an key pair without passphrase, I can encrypt and decrypt E-Mails and so on. But when I try to create an key pair with pw the first problem is that the creation of an revocation zertificat fails. The wizzard is hanging and after a minute there is an error that the creation has failed. So far so good. If I then try to decrypt an E-Mail same thing first nothing happens an then the error no secret key.

    I think it is relatet to pinentry. Because the problem are always when there should be an pw input window. I try to install the qt and qt4 packages but nothing changed.

    I found a lot of forum entries about a missing pinentry installation but not much about such kind of problems. Anyone have an idear waht that could be about?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,630
    Blog Entries
    3

    Default Re: Thunderbird does not work properly with Enigmail gnuPGP pinentry

    Did you install enigmail from the mozilla extensions site? Or did you install it from the opensuse repos?

    As far as I know, you have to install from the repos, for it to work properly.

    I have not tried creating a new keypair in thunderbird, so I'm not sure if that works here.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Thunderbird does not work properly with Enigmail gnuPGP pinentry

    FWIW, I have Thunderbird installed manually (extracted the .tar.gz and
    went with it) plus Enigmail and I created a key from within Thunderbird...
    just this week.

    Good luck.

  4. #4

    Default Re: Thunderbird does not work properly with Enigmail gnuPGP pinentry

    Quote Originally Posted by nrickert View Post
    Did you install enigmail from the mozilla extensions site? Or did you install it from the opensuse repos?

    As far as I know, you have to install from the repos, for it to work properly.

    I have not tried creating a new keypair in thunderbird, so I'm not sure if that works here.

    Yes everything was installed with the repos.

    If you don't use thunderbird for creating your keys then do you use a key with an passphrase? And ask thunderbird then for this passphrase when you decrypt an E-Mail? Without an passphras it works for me too but not with.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,630
    Blog Entries
    3

    Default Re: Thunderbird does not work properly with Enigmail gnuPGP pinentry

    Quote Originally Posted by sorbo13 View Post
    If you don't use thunderbird for creating your keys then do you use a key with an passphrase? And ask thunderbird then for this passphrase when you decrypt an E-Mail?
    Yes, and Yes, for those questions.

    These days claws-mail is my preferred software, so I just ran a test with thunderbird to verify that it works.

    It occurs to me, that you did not mention your desktop. I am using KDE, where it all works fine. I'm thinking that you are perhaps using XFCE.

    In my experience, gpg related stuff works out of the box in Gnome and KDE, but not with XFCE (and I don't remember for LXDE because I haven't tested that recently).

    With KDE, gpg-agent is automatically started if you have a ".gnupg" directory. With Gnome, seahorse is started to provide the same service. With XFCE, it was not starting out of the box. I had to get into XFCE settings for startup programs, and turn on the option to start Gnome services. With that set, seahorse should handle gpg-agent requests. You may have to logout and log back in for that to work.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,630
    Blog Entries
    3

    Default Re: Thunderbird does not work properly with Enigmail gnuPGP pinentry

    Let me add a bit more.

    If I am using KDM as the login manager, then I think XFCE does work fine out of the box. It is with GDM as login manager, that ssh-agent is not started and you need to enable Gnome services to have both an ssh-agent and a gpg-agent. If you try to start the agents in ".profile" or other shell startup file, then that seems to lead to pinentry problems. So comment out any such entries in shell startup files and start Gnome services, then see if that helps.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •