Results 1 to 4 of 4

Thread: libavg compliation error

  1. #1

    Exclamation libavg compliation error

    Hello.
    I have downloaded libavg from https://www.libavg.de
    When I do ./configure it gives me error

    Code:
    checking for libpython2.7... configure: error: could not find files required to build python plugin
    I have installed libpython2.7_1.0 and python-devel.
    I am using OpenSUSE 12.2 (64 bit).Help.

  2. #2
    dd NNTP User

    Default Re: libavg compliation error

    On 12/14/2012 01:16 PM, abhijitnavale wrote:
    > I have installed libpython2.7_1.0 and python-devel.


    how did you do that?

    which:

    -by using YaST Software Management?

    -zypper after becoming root using "su -" [just su probably won't work,
    and neither may "sudo zypper"]?

    -manually download (from where) and run the rpm command?

    -download source and compile locally?

    -other (please give us the details)

    and in a terminal please just pop open a terminal, x-term, konsole, etc
    and type in the following:

    Code:
    ls -hal /usr/lib/libpytho*
    and, then hit enter....then copy/paste the output AND input, from prompt
    to prompt back to this thread using the instructions here:
    http://goo.gl/i3wnr

    should look something like this

    Code:
    denverd@linux-os114:~> ls -hal /usr/lib/libpytho*
    -rw-r--r-- 1 root root 1.5M Jan 18  2012 /usr/lib/libpython2.7.so.1.0
    denverd@linux-os114:~>
    --
    dd http://goo.gl/PUjnL


  3. #3

    Default Re: libavg compliation error

    Quote Originally Posted by dd View Post
    On 12/14/2012 01:16 PM, abhijitnavale wrote:
    > I have installed libpython2.7_1.0 and python-devel.


    how did you do that?

    which:

    -by using YaST Software Management?

    -zypper after becoming root using "su -" [just su probably won't work,
    and neither may "sudo zypper"]?

    -manually download (from where) and run the rpm command?

    -download source and compile locally?

    -other (please give us the details)

    and in a terminal please just pop open a terminal, x-term, konsole, etc
    and type in the following:

    Code:
    ls -hal /usr/lib/libpytho*
    and, then hit enter....then copy/paste the output AND input, from prompt
    to prompt back to this thread using the instructions here:
    Posting in Code Tags - A Guide

    should look something like this

    Code:
    denverd@linux-os114:~> ls -hal /usr/lib/libpytho*
    -rw-r--r-- 1 root root 1.5M Jan 18  2012 /usr/lib/libpython2.7.so.1.0
    denverd@linux-os114:~>
    --
    dd Kick Ass! | Henne
    This is output of the command:
    Code:
    ls -hal /usr/lib/libpytho*
    -rw-r--r-- 1 root root 1.5M Aug  9 02:14 /usr/lib/libpython2.7.so.1.0
    i installed libpython and python devel using zypper command line tool.

  4. #4
    Join Date
    Sep 2012
    Posts
    5,140

    Default Re: libavg compliation error

    Quote Originally Posted by abhijitnavale View Post
    This is output of the command:
    Code:
    ls -hal /usr/lib/libpytho*
    -rw-r--r-- 1 root root 1.5M Aug  9 02:14 /usr/lib/libpython2.7.so.1.0
    i installed libpython and python devel using zypper command line tool.
    Something is wrong with python-devel installation. You should have /usr/lib/libpython2.7.so which should be link to libpython2.7.so.1.0. Library that you have is run-time library. To build programs you need version that ends with ".so".

    Also some more required files may be missing in this case (e.g. pkg-config files that are part of python-devel).

    What are results of
    Code:
    rpm -qi python-devel
    rpm -V python-devel
    Also are you using 32 or 64 bit installation?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •