Results 1 to 8 of 8

Thread: Apper dependency resolution failed

  1. #1

    Default Apper dependency resolution failed

    Hello,

    I'm on 12.2 i586 and Apper tells me I have one critical update needed (openSUSE-2012-848 - glibc: fix <fenv.h> with -m32) but I can't install it due to a failed dependency (ctxusb-2.2-1.i386 requires /lib/ld-linux.so.2, but this requirement cannot be provided). I understand this has something to do with the dynamic loader but I don't know how to fix it. How do I go about fixing the dependency?

    Thanks.
    Rob

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Apper dependency resolution failed

    This comment will not solve your issue, but may narrow the possibilities. As for every 12.2 update so far, I recently installed it using Apper but the 64 bit version with no dependency issues. Mine is a pretty standard installation originally from the KDE liveCD and fully updated. This may just be a problem with the 32bit update. Hopefully someone will either confirm it as that, or suggest a shortcoming on your system.

  3. #3

    Default Re: Apper dependency resolution failed

    hi,

    thanks for the response. my 12.2 system is a fresh install and has been quite healthy (except for problems saving scanned images, but that's another story). the problem i'm having is in a particular update recommended by apper. I've also tried to run the same update in zypper with the same result (not surprising).

    rob

  4. #4
    dd NNTP User

    Default Re: Apper dependency resolution failed

    On 12/14/2012 12:06 AM, rericsson wrote:

    > I'm on 12.2 i586 and Apper tells me I have one critical update needed
    > (openSUSE-2012-848 - glibc: fix <fenv.h> with -m32) but I can't


    are you on openSUSE 12.2 or on Tumbleweed (it is not 12.2, it is past
    [newer than] 12.2] and today another Tumbleweed user [or was that also
    you] noted in the mail list that there are problems with the glibc in
    the repo ... and, apparently also the 12.1 and 12.2 repo...

    as of the time of this post, there has been no resolution..you may
    follow the thread at:
    http://lists.opensuse.org/opensuse-f.../msg00171.html

    my suggestion would be to cease all attempts to force in a update...just
    let it sit....if need be go into YaST Online update and mark it taboo,
    never install....and, then when it gets fixed, run it in..

    others may have different (and far better) opinions...so, ymmv

    --
    dd http://tinyurl.com/DD-Caveat

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,885
    Blog Entries
    3

    Default Re: Apper dependency resolution failed

    Quote Originally Posted by rericsson View Post
    I'm on 12.2 i586 and Apper tells me I have one critical update needed (openSUSE-2012-848 - glibc: fix <fenv.h> with -m32) but I can't install it due to a failed dependency (ctxusb-2.2-1.i386 requires /lib/ld-linux.so.2, but this requirement cannot be provided).
    I'm in the middle of applying this update (via Yast online update) right now on a 32 bit system.

    There were no dependency issues. Okay, patch install went through without problems.

    If there was a problem with the patch, then that has presumably been fixed, so try again. If there's still a problem, then something might be broken on your system.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: Apper dependency resolution failed

    Quote Originally Posted by nrickert View Post
    I'm in the middle of applying this update (via Yast online update) right now on a 32 bit system.

    There were no dependency issues. Okay, patch install went through without problems.

    If there was a problem with the patch, then that has presumably been fixed, so try again. If there's still a problem, then something might be broken on your system.
    Thanks. That's helpful. I'll look into it.

  7. #7

    Default Re: Apper dependency resolution failed

    Quote Originally Posted by dd View Post
    On 12/14/2012 12:06 AM, rericsson wrote:

    > I'm on 12.2 i586 and Apper tells me I have one critical update needed
    > (openSUSE-2012-848 - glibc: fix <fenv.h> with -m32) but I can't


    are you on openSUSE 12.2 or on Tumbleweed (it is not 12.2, it is past
    [newer than] 12.2] and today another Tumbleweed user [or was that also
    you] noted in the mail list that there are problems with the glibc in
    the repo ... and, apparently also the 12.1 and 12.2 repo...
    12.2. Not Tumbleweed.

    Quote Originally Posted by dd View Post
    as of the time of this post, there has been no resolution..you may
    follow the thread at:
    Re: [opensuse-factory] glibc update w/ arch change i586->i686? (Tumblewe

    my suggestion would be to cease all attempts to force in a update...just
    let it sit....if need be go into YaST Online update and mark it taboo,
    never install....and, then when it gets fixed, run it in..

    others may have different (and far better) opinions...so, ymmv
    Thanks for the advice. It doesn't seem to affect anything so I'll remove it from the list and try zypper later.

    Rob

  8. #8
    dd NNTP User

    Default Re: Apper dependency resolution failed

    On 12/15/2012 02:56 PM, rericsson wrote:
    > It doesn't seem to affect anything so I'll
    > remove it from the list and try zypper later.


    you can't "remove it from the list", you can mark it taboo..

    do that before you try "zypper patch" or "zypper up"...otherwise it will
    be offered for install..

    --
    dd

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •