Results 1 to 9 of 9

Thread: Login Screen Problem

  1. #1

    Default Login Screen Problem

    I use desktop version of openSUSE 12.2 on KDE 4.8.5 (4.8.5) "release 2", and I'm running if on Raden HD 5450 graphics with fglrx.

    So the problem in LOGIN SCREEN/SYSTEM SETTINGS is next..

    1. It won't change the login theme;
    2. It won't install new login theme in the same place as default ones after downloading it from internet;
    3. I can't make password-less logins to work;
    4. I can't make my main account to auto-login after booting.

    I'm beginner on openSUSE, so maybe we can try with basic suggestions.

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Login Screen Problem

    Quote Originally Posted by thermooo View Post
    I use desktop version of openSUSE 12.2 on KDE 4.8.5 (4.8.5) "release 2", and I'm running if on Raden HD 5450 graphics with fglrx.

    So the problem in LOGIN SCREEN/SYSTEM SETTINGS is next..

    1. It won't change the login theme;
    2. It won't install new login theme in the same place as default ones after downloading it from internet;
    3. I can't make password-less logins to work;
    4. I can't make my main account to auto-login after booting.

    I'm beginner on openSUSE, so maybe we can try with basic suggestions.

    Thanks!
    for question 3 & 4
    for auto login or password-less login go to

    yast > security and users > user and group management > expert options

    and select either auto-login or password-less login as desired.
    If you select auto-login then you don't need to worry about question 1 & 2 because you wont be presented with the KDM login screen.
    Personally I'd avoid both these options for security reasons but it is really up to you.

    If you still want to change the kdm theme there are quite a few threads in the Opensuse forums about how to do this.
    Haven't tried to change it myself so can't vouch for whether it works or not.

    Take a look here for example:
    https://forums.opensuse.org/english/...t-changed.html

  3. #3

    Default Re: Login Screen Problem

    Quote Originally Posted by farcusnz View Post
    for question 3 & 4
    for auto login or password-less login go to

    yast > security and users > user and group management > expert options

    and select either auto-login or password-less login as desired.
    If you select auto-login then you don't need to worry about question 1 & 2 because you wont be presented with the KDM login screen.
    Personally I'd avoid both these options for security reasons but it is really up to you.

    If you still want to change the kdm theme there are quite a few threads in the Opensuse forums about how to do this.
    Haven't tried to change it myself so can't vouch for whether it works or not.

    Take a look here for example:
    https://forums.opensuse.org/english/...t-changed.html


    I couldn't make it work.
    I've seen somewhere that this is the problem for a quite time now... I hope they'll fix it in next version, cause openSUSE is definitely OS for me.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Login Screen Problem

    Quote Originally Posted by thermooo View Post
    I couldn't make it work.
    ???

    You're going to have to be a little clearer than that.

  5. #5

    Default Re: Login Screen Problem

    Quote Originally Posted by farcusnz View Post
    ???

    You're going to have to be a little clearer than that.
    I've tried everything you suggested but all I could do is to make password-less login for all users and not for specific ones.
    I need my main account to be password protected, but the other one I need to use as a guest account without a password.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Login Screen Problem

    On 2012-12-17 18:36, thermooo wrote:

    > I've tried everything you suggested but all I could do is to make
    > password-less login for all users and not for specific ones.
    > I need my main account to be password protected, but the other one I
    > need to use as a guest account without a password.


    All users must have a strong password, guests or not.

    You can have the system boot with a predefined user desktop already
    opened. Autologin works, but not the way you expect. It is not broken
    and will not be repaired on the next version.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  7. #7

    Default Re: Login Screen Problem

    Quote Originally Posted by robin_listas View Post
    On 2012-12-17 18:36, thermooo wrote:

    > I've tried everything you suggested but all I could do is to make
    > password-less login for all users and not for specific ones.
    > I need my main account to be password protected, but the other one I
    > need to use as a guest account without a password.


    All users must have a strong password, guests or not.

    You can have the system boot with a predefined user desktop already
    opened. Autologin works, but not the way you expect. It is not broken
    and will not be repaired on the next version.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

    I was speaking about password-less logins. But it's not working...

    Configure Desktop>Convenience>HELP :

    Password-Less Login
    Using this feature, you can allow CERTAIN users to login without having to provide their password.
    Enable this feature using the Enable Password-Less Logins option.
    Below this option you'll see a list of users on the system.
    Enable password-less login for SPECIFIC users by checking the checkbox next to the login names.
    By default, this feature is disabled for all users.

    I tried it but nothing...

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Login Screen Problem

    On 2012-12-18 03:36, thermooo wrote:

    > Configure Desktop>Convenience>HELP :
    >
    > Password-Less Login
    > Using this feature, you can allow *CERTAIN* users to login without
    > having to provide their password.


    Notice that this means that they DO have a password, but they do not
    have to type it to enter KDE. It is a KDE only feature.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  9. #9
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Login Screen Problem

    Quote Originally Posted by robin_listas View Post
    On 2012-12-18 03:36, thermooo wrote:

    > Configure Desktop>Convenience>HELP :
    >
    > Password-Less Login
    > Using this feature, you can allow *CERTAIN* users to login without
    > having to provide their password.


    Notice that this means that they DO have a password, but they do not
    have to type it to enter KDE. It is a KDE only feature.
    There does appear to be a bit of a bug with it in Yast.
    I tried giving it a spin last night.
    expert options wouldn't let me select the user - it would only give me the first user listed.
    When I did select that and applied, it actually applied password-less logins for all users.

    I guess I may have done something wrong as I have never used it before but I tried the settings that seemed obvious.

    I'd suggest the OP file a bug report if he is seeing the same as what I saw when testing it.
    Having said that, I'm not sure what the problem would be with assigning a password to all users.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •