Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: launching firefox shows vlc icon and fails

  1. #1

    Default launching firefox shows vlc icon and fails

    Hi!

    There is a estrange behavior (just for my user) in kde4.
    For instance, I'm using openscad, I select Help-OpenScad manual (it must open the web page showing the manual), then it launches Firefox, or at least it is what it shows at the task bar (launch feedback), but the icon of the application is not firefox icon but vlc icon. No program opens (neither firefox nor vlc) and launch feedback disappear. No error reported.
    I think it might be a configuration error anywhere, but i can't find it.

    Where can i find?


    regards

  2. #2
    dd NNTP User

    Default Re: launching firefox shows vlc icon and fails

    On 12/09/2012 08:46 PM, fperal wrote:
    > I'm using openscad


    how did you install openscad?
    what version of openSUSE are you using?

    --
    dd

  3. #3

    Default Re: launching firefox shows vlc icon and fails

    Quote Originally Posted by dd View Post
    On 12/09/2012 08:46 PM, fperal wrote:
    > I'm using openscad


    how did you install openscad?
    what version of openSUSE are you using?

    --
    dd

    I downloaded it from https://build.opensuse.org/package/b...=openSUSE_12.2

    I'm using Opensuse 12.2 x86_64

    regards

  4. #4
    dd NNTP User

    Default Re: launching firefox shows vlc icon and fails

    On 12/09/2012 09:26 PM, fperal wrote:
    > I downloaded it fromhttp://tinyurl.com/cxks4l8


    ok, that tells part of the story....you downloaded it and then how did
    you install it...did you use YaST, zypper or manually run the rpm command..

    forget that, because how ever you did it didn't work....you could try
    going to http://software.opensuse.org, dial in your version of openSUSE,
    put openscad in the search block, find the "1 Click Install" link and
    that should trigger a proper install with YaST...hopefully over your
    broken install and fix all the wrong configurations..

    let us know how that goes...and, for future installs you might want to
    review the best ways to do it on openSUSE, here:
    http://doc.opensuse.org/documentatio...cha.y2.sw.html

    (going to a url in a browser and downloading is the last century way--i
    use YaST Software Management for about 98% of my installs...and, zypper
    or compiling from source for the rest)

    --
    dd

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: launching firefox shows vlc icon and fails

    Quote Originally Posted by fperal View Post
    Hi!

    There is a estrange behavior (just for my user) in kde4.
    For instance, I'm using openscad, I select Help-OpenScad manual (it must open the web page showing the manual), then it launches Firefox, or at least it is what it shows at the task bar (launch feedback), but the icon of the application is not firefox icon but vlc icon. No program opens (neither firefox nor vlc) and launch feedback disappear. No error reported.
    I think it might be a configuration error anywhere, but i can't find it.

    Where can i find?


    regards
    So I installed this app and it does not run for me. It complains that it can not find: "/usr/share/opencascade/6.5.0/src/DrawResources/DrawDefault" You can open its documentation from here using Firefox: file:///opt/OpenCASCADE/doc/ReferenceDocumentation/html/index.html and their Web Site can be found here: Open CASCADE.

    Its not a native openSUSE application and while it may be packaged incorrectly, you should get help from their web site I think.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: launching firefox shows vlc icon and fails

    I don't remember. I Think I installed it with zypper. I'm sure there was no problem installing it. The program runs nicely, but the
    Anyway, it is not an openscad issue. The same happen with other programs, for instance MPlabX: menu-help-online docs and support might open firefox but it shows the icon as if firefox is being launched but it shows the VLC player icon and firefox never appears



    Quote Originally Posted by dd View Post
    On 12/09/2012 09:26 PM, fperal wrote:
    > I downloaded it fromhttp://tinyurl.com/cxks4l8


    ok, that tells part of the story....you downloaded it and then how did
    you install it...did you use YaST, zypper or manually run the rpm command..

    forget that, because how ever you did it didn't work....you could try
    going to software.opensuse.org: Download openSUSE 12.2, dial in your version of openSUSE,
    put openscad in the search block, find the "1 Click Install" link and
    that should trigger a proper install with YaST...hopefully over your
    broken install and fix all the wrong configurations..

    let us know how that goes...and, for future installs you might want to
    review the best ways to do it on openSUSE, here:
    openSUSE 12.2: Chapter 5. Installing or Removing Software

    (going to a url in a browser and downloading is the last century way--i
    use YaST Software Management for about 98% of my installs...and, zypper
    or compiling from source for the rest)

    --
    dd

  7. #7

    Default Re: launching firefox shows vlc icon and fails

    Quote Originally Posted by jdmcdaniel3 View Post
    So I installed this app and it does not run for me. It complains that it can not find: "/usr/share/opencascade/6.5.0/src/DrawResources/DrawDefault"
    Thank You,

    I've searched in the history and I installed two packages:

    Code:
      
    362  2012-05-10 16:20:35 zypper install libcgal8
    363  2012-05-10 16:24:02 zypper install openscad-2011.12-2.2.x86_64.rpm
    But, as I said, the program works fine, I think it is not a OpenScad problem but any kind of misconfiguration.

    Trying with MY user the help menu in openscad or mplabx fails to open the help (is a web page) but gimp for instance open it's web help correctly.

    With another user (a test user) all of them open the web help correctly.

    regards

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: launching firefox shows vlc icon and fails

    What's the filename extension for the help files? Sure it's html? I'd say a mime-type is set wrong, my bet is that FF doesn't start at all, but VLC is used to open the help files, which it can't.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: launching firefox shows vlc icon and fails

    Installed, tested the help feature, I'm sent to the wiki webpage.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: launching firefox shows vlc icon and fails

    Quote Originally Posted by Knurpht View Post
    What's the filename extension for the help files? Sure it's html? I'd say a mime-type is set wrong, my bet is that FF doesn't start at all, but VLC is used to open the help files, which it can't.

    Launching openscad from konsole for a test user, then I click Help-OpenScad manual

    Code:
    pruebas@andromeda:~> openscad
    START /usr/bin/firefox "http://en.wikibooks.org/wiki/OpenSCAD_User_Manual"

    and firefox is opened.


    Then launching openscad from konsole for my usual user, then I click Help-OpenScad manual


    Code:
    fernando@andromeda:~> openscad
    nothing more, launch feedback appears at taskbar with "Firefox" name, the pointer change to VLC icon, but nothing happens

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •