Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: OpenSuse 10 installed, no ssh or ftp

  1. #1

    Default OpenSuse 10 installed, no ssh or ftp

    Good day all.

    I've just installed OpenSuse 10 on one of my PCs. Everything looks ok, however, although I can ping it successfully, I'm unable to ssh/telnet or ftp to the machine.

    netstat -an shows that ports 22 and 23 are not listening and ps -ef |egrep 'ssh|ftp' show nothing.

    Any ideas?

    Regards,
    Bjoern

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 10 installed, no ssh or ftp

    It unlikely anyone here even has SuSE 10
    It's so old and went out of support forever ago...

    Are you use it's not SLED?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: OpenSuse 10 installed, no ssh or ftp

    Quote Originally Posted by JoeMoer View Post
    Good day all.

    I've just installed OpenSuse 10 on one of my PCs. Everything looks ok, however, although I can ping it successfully, I'm unable to ssh/telnet or ftp to the machine.

    netstat -an shows that ports 22 and 23 are not listening and ps -ef |egrep 'ssh|ftp' show nothing.

    Any ideas?

    Regards,
    Bjoern
    If I remember correctly (yes, I am that as least as old as SuSE 10), even in those days the ssh and ftp services did not run when they where not switched on.

    And I guess that was done in those times already using YaST > System > System services (Runlevel).

    But like others here, I would advise you to download 12.2 and use that. Then asking things in these forums would be more fruitfull.
    Henk van Velden

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse 10 installed, no ssh or ftp

    On 2012-12-08 05:26, JoeMoer wrote:
    >
    > Good day all.
    >
    > I've just installed OpenSuse 10 on one of my PCs.


    openSUSE 10 does not exist.

    You may have 10.1, 10.2, 10.3... all of them totally different distros.

    Or you may have SUSE 10.

    What do you have really?

    Code:
    cat /etc/SuSE-release
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #5

    Default Re: OpenSuse 10 installed, no ssh or ftp

    Quote Originally Posted by robin_listas View Post
    On 2012-12-08 05:26, JoeMoer wrote:
    >
    > Good day all.
    >
    > I've just installed OpenSuse 10 on one of my PCs.


    openSUSE 10 does not exist.

    You may have 10.1, 10.2, 10.3... all of them totally different distros.

    Or you may have SUSE 10.

    What do you have really?

    Code:
    cat /etc/SuSE-release
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    I'm sorry, I don't know why I said 10, it is in fact openSUSE 12.1

    Regards,
    Bjoern

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 10 installed, no ssh or ftp

    So did you open the ports in suse firewall?
    Have you configured ssh and set it in the runlevel to start at boot?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: OpenSuse 10 installed, no ssh or ftp

    Quote Originally Posted by caf4926 View Post
    So did you open the ports in suse firewall?
    Have you configured ssh and set it in the runlevel to start at boot?
    I checked in yast2, vsftpd in enabled, but sshd was not. I enabled sshd and rebooted. I checked the processes and sshd is running now, however ftp is still not working.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse 10 installed, no ssh or ftp

    On 2012-12-08 16:56, JoeMoer wrote:

    >
    > I'm sorry, I don't know why I said 10, it is in fact openSUSE 12.1


    Ok then.

    ssh is installed by default, but disabled. There is an option for it in
    the installation menu. Now you have to activate the service (yast system
    services) and open the firewall for that port.

    Telnet server is not installed by default, it is considered dangerous.

    ftp server is also not installed by default. There is a yast module to
    configure it, but you probably need to install the yast ftp module
    first. Configuration of the firewall for this service is not trivial.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse 10 installed, no ssh or ftp

    On 2012-12-08 17:56, JoeMoer wrote:
    > however ftp is still not working.


    You have to configure it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10

    Default Re: OpenSuse 10 installed, no ssh or ftp

    Thanks for all helpfull hints guys. At least I can Putty to the machine and although ftp isn't working, since sshd is running I can ftp using WinSCP.

    Regards,
    Bjoern

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •