Results 1 to 6 of 6

Thread: Why emacs gets a better GTK theme on second installation

  1. #1

    Unhappy Why emacs gets a better GTK theme on second installation

    Hi,

    I have openSuse 12.2 on two machines. On the first machine I installed a few months ago and later it upgraded to emacs 24. It looks like this:



    But on new install where I upgraded soon after first login I get emacs 24 as:



    Apart from font face and solarized theme (which is well configured in earlier screenshot), the next one better with nice toolbar, menus and scrollbars. I checked that on both machines I have GTK3 installed. I tried copying GTK rc files, but it didn't help.

    What should I do to make emacs on my original installation look better?

  2. #2
    Join Date
    Mar 2009
    Location
    United States
    Posts
    612

    Default Re: Why emacs gets a better GTK theme on second installation

    gtk3-metatheme-adwaita was installed?

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Why emacs gets a better GTK theme on second installation

    When i installed gedit on KDE i got something similar to first image
    But gedit looks like the second image on gnome 3.x
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4

    Default Re: Why emacs gets a better GTK theme on second installation

    @nightwishfan I installed gtk3-metatheme-adwaita, deleted all gtk rc files in my home and logged out and in. But still my Emacs doesn't look good. On the other hand all other GTK programs inherit the KDE's gtk settings.

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Why emacs gets a better GTK theme on second installation

    You may try the things that are specified here
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6

    Default Re: Why emacs gets a better GTK theme on second installation

    I modified /etc/gtk-3.0/settings.ini with following values

    Code:
    [Settings]
    gtk-theme-name = Adwaita
    gtk-icon-theme-name = Adwaita
    gtk-fallback-icon-theme = gnome
    It worked. Now I have to work to find out to reduce tool bar size.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •