Results 1 to 4 of 4

Thread: can't connect to XDM - MIT-MAGIC-COOOKIE

  1. #1

    Default can't connect to XDM - MIT-MAGIC-COOOKIE

    I'm trying to connect remotely from a Windows 7 computer to a linux (ubuntu) server.

    I like to use XDM; using Xming on the Windows 7 machine.

    I configured ubuntu to allow connecting but getting hung
    Thu Nov 29 16:44:20 2012 xdm info (pid 2063): Starting X server on 192.168.1.6:0
    Thu Nov 29 16:46:20 2012 xdm error (pid 3576): Hung in XOpenDisplay(192.168.1.6:0), aborting
    Thu Nov 29 16:46:20 2012 xdm error (pid 3576): server open failed for 192.168.1.6:0, giving up
    Thu Nov 29 16:46:20 2012 xdm error (pid 2063): Display 192.168.1.6:0 cannot be opened
    Thu Nov 29 16:46:20 2012 xdm error (pid 2063): Display 192.168.1.6:0 is being disabled

    In wireshark I'm seeing MIT-MAGIC-COOKIE being sent from the linux server but I thought connecting via XDM MIT-MAGIC-COOKIE isn't passed. Is this correct?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,400

    Default Re: can't connect to XDM - MIT-MAGIC-COOOKIE

    If I am correct, this is the openSUSE forum and neither a Windows 7 nor an Ubuntu one.
    Do you mind explaining while you think your problem will be solved here better/sooner then in the approptiate forums?
    Henk van Velden

  3. #3

    Default Re: can't connect to XDM - MIT-MAGIC-COOOKIE

    sorry my bad - saw xdm and didn't realize susu -

  4. #4

    Default Re: can't connect to XDM - MIT-MAGIC-COOOKIE

    Quote Originally Posted by hcvv View Post
    If I am correct, this is the openSUSE forum and neither a Windows 7 nor an Ubuntu one.
    Do you mind explaining while you think your problem will be solved here better/sooner then in the approptiate forums?
    Because he heard people are smarter here.

    @susujames

    Whether on Ubuntu or openSUSE, remote login is disabled by default. You have to uncomment this line (remove the leading "!") in /etc/X11/xdm/xdm-config to enable it:

    Code:
    ! SECURITY: do not listen for XDMCP or Chooser requests
    ! Comment out this line if you want to manage X terminals with xdm
    !DisplayManager.requestPort:    0
    and remove the option "-nolisten tcp" in the line starting the X server in /etc/X11/xdm/Xservers - and read the SECURITY NOTE in this file before.

    Rather than using xdm, I'd suggest installing NoMachine NX or FreeNX under Ubuntu and the NoMachine NX client on Windows. NX can use xdm on the server or not - meaning you don't need to have xdm running on the server - not even X - to open a desktop session. NoMachine Free edition is available on NoMachine website. FreeNX is available in a ppa repo for each Ubuntu LTS release. You'll have to install the precise version ... unless they released a version for 12.10, but I don't think so.

    Code:
    # cat /etc/apt/sources.list.d/freenx-team-ppa-precise.list
    deb http://ppa.launchpad.net/freenx-team/ppa/ubuntu precise main
    deb-src http://ppa.launchpad.net/freenx-team/ppa/ubuntu precise main

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •