I installed Oracle Virtual Box from the Oracle site after not finding it in YaST.
I subsequently realized that I needed to run: /etc/init.d/vboxdrv setup
which led me to install make, gcc, and the kernel source files using YaST.
Then I ran the /usr/bin/X11/virtualbox by hand to find the failure in line 77
which led me to add myself to the group vboxusers.

At this point I tried to start the Windows7 as a virutal machine in VirtualBox (to install it), and I received the following message:
(I created the Windows7 space using the New button previously.)

Failed to open a session for the virtual machine Windows_7.

Unable to load R3 module /usr/lib/virtualbox/VBoxDD.so (VBoxDD):
/usr/lib/virtualbox/VBoxDD.so: undefined symbol: VDAsyncDiscardRanges (VERR_FILE_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}


I went to the forums and found I should have started there. :-(

I also installed the matching Oracle extension file (actually VirtualBox installed it for me). It had no effect on this error even after a reboot.

Here is what is installed:
$ rpm -qa | grep virtualbox
virtualbox-qt-4.1.22-1.6.1.x86_64
virtualbox-host-kmp-desktop-4.1.22_k3.4.6_2.10-1.6.1.x86_64
virtualbox-guest-kmp-desktop-4.1.22_k3.4.6_2.10-1.6.1.x86_64
virtualbox-4.1.22-1.6.1.x86_64
virtualbox-guest-tools-4.1.22-1.6.1.x86_64

Running
Linux 3.4.11-2.16-desktop x86_64
openSUSE 12.2 (x86_64)

#define LINUX_VERSION_CODE 197632 (from /usr/include/linux/version.h.)

/proc/version
Linux version 3.4.11-2.16-desktop (geeko@buildhost) (gcc version 4.7.1 20120723
[gcc-4_7-branch revision 189773] (SUSE Linux) ) #1 SMP PREEMPT Wed Sep 26 17:05:
00 UTC 2012 (259fc87)

I'm sure this is something simple, but I'm not seeing it. Any ideas what I have failed to install or configure properly?

Thank you.