Results 1 to 7 of 7

Thread: vBox - VMWare question

  1. #1

    Default vBox - VMWare question

    Running 12.2 x64 w/ KDE.

    I have Oracle vBox 4.2.4 installed. And some other stuff that I wonder if I need.

    This is from my log/messages:
    Code:
    vboxdrv[899]: Starting VirtualBox kernel modules..done
    vmtoolsd[904]: Starting vmtoolsd FATAL: Error inserting vmw_balloon  (/lib/modules/3.4.11-2.16-desktop/kernel/drivers/misc/vmw_balloon.ko):  No such device
    According to YaST2 I have open-vm-tools installed and some other vmware packages, including VMware X server mouse & video drivers.

    I am thinking that I should remove these packages but I am not certain that I should be doing that.

    And is there a way to capture a list from YaST2 of the vm* packages that I have installed that I can then post here?

    Thanks, Jon

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: vBox - VMWare question

    Quote Originally Posted by 6520302 View Post
    Running 12.2 x64 w/ KDE.

    I have Oracle vBox 4.2.4 installed. And some other stuff that I wonder if I need.

    This is from my log/messages:
    Code:
    vboxdrv[899]: Starting VirtualBox kernel modules..done
    vmtoolsd[904]: Starting vmtoolsd FATAL: Error inserting vmw_balloon  (/lib/modules/3.4.11-2.16-desktop/kernel/drivers/misc/vmw_balloon.ko):  No such device
    According to YaST2 I have open-vm-tools installed and some other vmware packages, including VMware X server mouse & video drivers.

    I am thinking that I should remove these packages but I am not certain that I should be doing that.

    And is there a way to capture a list from YaST2 of the vm* packages that I have installed that I can then post here?

    Thanks, Jon
    You only need to install VirtualBox and with VBox, your extension pack. Nothing else is required. Have a look here for the most recent links: https://forums.opensuse.org/english/...box-4-2-a.html

    And I use this guide to install it: https://forums.opensuse.org/content/...umbleweed.html

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: vBox - VMWare question

    You only need to install VirtualBox and with VBox, your extension pack. Nothing else is required.
    James:

    So are you are confirming that I can remove the following (I guess they were installed in the original fresh install)?
    libvmtools0, open-vm-tools, open-vm-tools-gui, vmscripts, vmware-guest-kmp-desktop, xf86-input-vmmouse, & xf86-video-vmware.

    I previously used the link you provided to install the extensions. I just wanted to make sure I'm not removing something I need to have.
    I'm too new with this OS and don't want to make a blunder...

    Thanks, Jon

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: vBox - VMWare question

    Quote Originally Posted by 6520302 View Post
    James:

    So are you are confirming that I can remove the following (I guess they were installed in the original fresh install)?
    libvmtools0, open-vm-tools, open-vm-tools-gui, vmscripts, vmware-guest-kmp-desktop, xf86-input-vmmouse, & xf86-video-vmware.

    I previously used the link you provided to install the extensions. I just wanted to make sure I'm not removing something I need to have.
    I'm too new with this OS and don't want to make a blunder...

    Thanks, Jon
    Of the files you list, I find that only "xf86-video-vmware" is loaded and I am not sure why it was installed. I have never used Vmware on my PC. (Though I was just today working at a VMWare office here in Austin, on their A/C system) None the less, unless a file is causing a problem, their size is of little consequence and I am not sure of any worry about them being loaded or not.

    Thank You,
    Last edited by jdmcdaniel3; 27-Nov-2012 at 19:42.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: vBox - VMWare question

    Quote Originally Posted by jdmcdaniel3 View Post
    None the less, unless a file is causing a problem, their size is of little consequence and I am not sure of any worry about them being loaded or not.
    Except that I get an error in the message file. Of course, unless I read that log I don't know about it.
    I'm just trying to clean up my install. Maybe it is not worth that effort.

    Thanks, jon

  6. #6

    Default Re: vBox - VMWare question

    Quote Originally Posted by 6520302 View Post

    So are you are confirming that I can remove the following (I guess they were installed in the original fresh install)?
    libvmtools0, open-vm-tools, open-vm-tools-gui, vmscripts, vmware-guest-kmp-desktop, xf86-input-vmmouse, & xf86-video-vmware.
    I see in your list a package that I built (vmscripts), and I assure you that this one is not causing the error that you get - and had nothing to do with vmware anyway.

    Quote Originally Posted by 6520302 View Post
    Running 12.2 x64 w/ KDE.

    I have Oracle vBox 4.2.4 installed. And some other stuff that I wonder if I need.

    This is from my log/messages:
    Code:
    vboxdrv[899]: Starting VirtualBox kernel modules..done
    vmtoolsd[904]: Starting vmtoolsd FATAL: Error inserting vmw_balloon  (/lib/modules/3.4.11-2.16-desktop/kernel/drivers/misc/vmw_balloon.ko):  No such device
    The culprit is the vmtoolsd service which is still enable and doesn't work. If you either disable this service or deinstall the package which contains vmtoolsd, you won't get this error message anymore.

    You can check its status:

    Code:
    $ sudo /sbin/service vmtoolsd status
    and disable it:

    Code:
    $ sudo /sbin/chkconfig vmtoolsd off
    or if it's a systemd service (I dont' know vmware):

    Code:
    $ sudo systemctl disable vmtoolsd.service
    But deinstalling the package which contains vmtoolsd will just solve the problem - assuming you don't need vmware of course.

  7. #7

    Default Re: vBox - VMWare question

    Quote Originally Posted by please_try_again View Post
    I see in your list a package that I built (vmscripts), and I assure you that this one is not causing the error that you get - and had nothing to do with vmware anyway.

    The culprit is the vmtoolsd service which is still enable and doesn't work. If you either disable this service or deinstall the package which contains vmtoolsd, you won't get this error message anymore.

    ..<snip>..

    But deinstalling the package which contains vmtoolsd will just solve the problem - assuming you don't need vmware of course.
    PTA:

    Thanks for the great info! I don't really know if I need vmtools or not, that is why I queried here. But I *assume* that my Oracle vBox install doesn't need it and I have not installed any vmware product AFAIK.

    The status check says it is loaded and failed. FWIW, the final command you gave me resulted in:
    Code:
    sudo systemctl disable vmtoolsd.service
    vmtoolsd.service is not a native service, redirecting to /sbin/chkconfig.
    Executing /sbin/chkconfig vmtoolsd off
    I'll remove it via YaST2.

    Thanks for mentioning vmscripts, I'll leave it alone. BTW, did you get a chance to read the comment I left a few weeks ago in the atiupgrade article?

    Rgds, Jon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •