Results 1 to 6 of 6

Thread: libssh2 / libcurl errors

  1. #1

    Default libssh2 / libcurl errors

    Has anyone seen any problems after a zypper update.

    I am getting the following issues:

    Example #1:
    VirtualBox
    VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
    VirtualBox: dlopen("/usr/lib/virtualbox/VBoxRT.so",) failed: /usr/lib64/libcurl.so.4: symbol libssh2_scp_send64, version LIBSSH2_1.3.0 not defined in file libssh2.so.1 with link time reference

    VirtualBox: Tip! It may help to reinstall VirtualBox.

    Example #2
    zypper update
    zypper: /lib64/libssh2.so.1: no version information available (required by /usr/lib64/libcurl.so.4)
    Loading repository data...
    Reading installed packages...

    Nothing to do.


    I have done the following:
    Several google searches have shown a similar issue with 11.2. They also had reinstalled.
    I also deinstalled the 32bit versions of these libs and found that it broke a few things so I put them back.
    I have forced an update of all packages I believe that are involved.

    I have updated VB, and recomplied.

    No joy. Any ideas would be helpful.

    More Info:
    uname -a = Linux dude 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux
    lsb_release -irc
    Distributor ID: SUSE LINUX
    Release: 12.2
    Codename: Mantis

  2. #2
    dd NNTP User

    Default Re: libssh2 / libcurl errors

    On 11/27/2012 04:36 PM, unixlover wrote:
    >
    > Has anyone seen any problems after a zypper update.


    i am sure i can't help you, but i do offer this (which the real helper
    might need to know):

    - please tell if the openSUSE 12.2 with these example problems is the
    host, or the hosted, or both....if both, are both throwing these zypper
    errors?

    - if the openSUSE throwing these errors is hosted, please tell us the
    operating system being used as the host

    and, i wonder why you elected to post into the application forum and not
    the http://tinyurl.com/8xrn2nt Virtualization forum

    --
    dd

  3. #3

    Default Re: libssh2 / libcurl errors

    Thanks for the reply

    To answer your questions:

    1) It is the host for the vm's

    2) I did not put this in the virtual area as it seemed
    to relate to other apps as well. It would appear
    libcurl has a problem with some symbols in libssh,
    as zypper was also throwing errors/warnings.

    I will be happy to resubmit in a different area.


    Quote Originally Posted by dd View Post
    On 11/27/2012 04:36 PM, unixlover wrote:
    >
    > Has anyone seen any problems after a zypper update.


    i am sure i can't help you, but i do offer this (which the real helper
    might need to know):

    - please tell if the openSUSE 12.2 with these example problems is the
    host, or the hosted, or both....if both, are both throwing these zypper
    errors?

    - if the openSUSE throwing these errors is hosted, please tell us the
    operating system being used as the host



    and, i wonder why you elected to post into the application forum and not
    the http://tinyurl.com/8xrn2nt Virtualization forum


    --
    dd

  4. #4
    dd NNTP User

    Default Re: libssh2 / libcurl errors

    On 11/27/2012 05:46 PM, unixlover wrote:
    >
    > 1) It is the host for the vm's


    ok, so you have a problem in 12.2 64 which may or may not impact the VM...

    no, lets wait and see if someone can help with that zypper comment..

    if you can get that straight and the VM then works--DONE! if not, then
    you can post the _unrelated_ VM question to the correct forum...ok?

    oh, many will probably want to see, so please show us the terminal
    output *and* input from

    Code:
    zypper lr -d
    copy/paste the in/output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    --
    dd

  5. #5

    Default Re: libssh2 / libcurl errors

    zypper lr -d
    zypper: /lib64/libssh2.so.1: no version information available (required by /usr/lib64/libcurl.so.4)
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------+--------
    1 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_DVD_A_DH16AAL_3D9949033550 |
    2 | repo-debug | openSUSE-12.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.2/repo/oss |
    3 | repo-debug-update | openSUSE-12.2-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.2 |
    4 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | Index of /debug/update/12.2-non-oss |
    5 | repo-non-oss | openSUSE-12.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.2/repo/non-oss |
    6 | repo-oss | openSUSE-12.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.2/repo/oss |
    7 | repo-source | openSUSE-12.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.2/repo/oss |
    8 | repo-update | openSUSE-12.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.2 |
    9 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/12.2-non-oss |

  6. #6

    Default Re: libssh2 / libcurl errors

    Thanks for all the help folks, but I have given up.

    I did a backup of my important data and will be reloading 12.2.

    This can be closed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •