Results 1 to 6 of 6

Thread: Question about a certain package

  1. #1

    Default Question about a certain package

    Hi again.

    Each time I do a system packages update through Software Manager I always see a package in @System repo which is always highlighted red:

    libx264-125
    Version: 0.125svn20120525-1.4 (x86_64)
    Description: A free h264/avc encoder - encoder binary

    Why is it always in red, as though it was outdated or similar? Should I try to "downgrade" it, replace it or do something about it?
    Thanks for your help.

  2. #2

    Default Re: Question about a certain package


  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Question about a certain package

    If a package is marked red, it is either not available from any of the repoes currently active, or a package is made ready to be reverted back to a previous version. Packman does downgrade packages from time to time, I suppose it has to do with a failure/inconsistency in the most recent version, not recognised initially? Packman does also remove certain packages to be replaced by new ones, in that case it will be as in the first red example; although it derives from Packman (given that the packman repo is active) it is not available as it does not any longer exist.

    If the package libx264-125 isn't available no more just remove it, the dependency solver should auto-correct the matter and the package should be replaced. If an older version is available just downgrade.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Question about a certain package

    Quote Originally Posted by F_style View Post
    Hi again. Each time I do a system packages update through Software Manager I always see a package in @System repo which is always highlighted red: libx264-125 Version: 0.125svn20120525-1.4 (x86_64) Description: A free h264/avc encoder - encoder binary Why is it always in red, as though it was outdated or similar? Should I try to "downgrade" it, replace it or do something about it? Thanks for your help.
    Typically this package updates numerically and leaves behind the old < number.
    The old package can be removed, but it&#39;s not harmful to leave it either.
    View the versions in software manager, theat should make it clear
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Question about a certain package

    Quote Originally Posted by caf4926 View Post
    Typically this package updates numerically and leaves behind the old < number. The old package can be removed, but it&#39;s not harmful to leave it either. View the versions in software manager, theat should make it clear
    Sorry, thats the bug affecting Chrome
    should read: its not harmful to leave it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Question about a certain package

    Quote Originally Posted by F_style View Post
    Hi again.

    Each time I do a system packages update through Software Manager I always see a package in @System repo which is always highlighted red:

    libx264-125
    Version: 0.125svn20120525-1.4 (x86_64)
    Description: A free h264/avc encoder - encoder binary

    Why is it always in red, as though it was outdated or similar? Should I try to "downgrade" it, replace it or do something about it?
    Thanks for your help.
    In the case of that package it's obsolete, you can remove it. It's gone from the repos, and as caf4926 suggests, always check first under the versions tab in YaST.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •