Results 1 to 10 of 10

Thread: Qt 4 Designer do not start

  1. #1

    Default Qt 4 Designer do not start

    "Heya Geekos..."

    System: freshly installed 12.2 64bit with KDE.
    Problem: The Qt interface designer, Qt 4 Designer just won't start up.

    I have installed the pattern Qt development.
    Qt Creator, Qt 4 Assistant and Qt 4 Linguist start up okay from kickoff menu.
    However, the Qt interface designer, Qt 4 Designer won't start up. After starting it from the kickoff menu, the system waits for the application with the mouse animation, but that's all.
    I've experienced a similar case with Virtualbox, when my user was not added to to the group 'vboxusers'. But then I could do some debugging by starting the application from a terminal, and by the output error message it was easy to solve the problem. Unfortunately, I do not know how to start this program from terminal (I didn't find it in /usr/bin).

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt 4 Designer do not start

    Am 22.11.2012 19:26, schrieb ropeist:
    > how to start this program from terminal (I didn't find it in /usr/bin).
    >

    Code:
    designer
    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  3. #3

    Default Re: Qt 4 Designer do not start

    Thanks, that's a start. Started 'designer' from terminal brought up the program I was looking for.
    However there are two new questions.

    1.) Why Qt 4 designer won't start from kickoff menu? Is it a well-known issue, or is it only for me?
    2.) There is an interesting output on the terminal, is it okay?

    Output:

    Error while reparenting!
    QMetaProperty::read: Unable to handle unregistered datatype 'QList<QColor>' for property 'KColorCombo::colors'
    QMetaProperty::read: Unable to handle unregistered datatype 'SelectionBehavior' for property 'QTabBar::selectionBehaviorOnRemove'
    QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
    QMetaProperty::read: Unable to handle unregistered datatype 'QList<QChar>' for property 'KCharSelect::displayedChars'
    QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
    Enchant dict for "en_US" 0x3043a80
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /home/rope/.local/share/marble/maps/earth/placemarks/
    X Error: BadWindow (invalid Window parameter) 3
    Major opcode: 20 (X_GetProperty)
    Resource id: 0x5c0008e
    X Error: BadWindow (invalid Window parameter) 3
    Major opcode: 20 (X_GetProperty)
    Resource id: 0x5c000de

    [QUOTE=martin_helm;2505749]Am 22.11.2012 19:26, schrieb ropeist:
    > how to start this program from terminal (I didn't find it in /usr/bin).
    >

    Code:
    designer

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt 4 Designer do not start

    Am 22.11.2012 19:56, schrieb ropeist:
    > 1.) Why Qt 4 designer won't start from kickoff menu? Is it a well-known
    > issue, or is it only for me?

    It starts on my machine from the menu, so that it does not start on
    yours is not normal.

    > 2.) There is an -interesting- output on the terminal, is it okay?
    >

    That's typical useless noise from Qt programs, ignore it.
    I cannot directly help with the question why the menu entry fails, but
    you could lookup what command it invokes
    Code:
    martinh@ganymed:~> cat /usr/share/applications/designer4.desktop
    [Desktop Entry]
    Categories=Qt;Development;GUIDesigner;Qt;
    Encoding=UTF-8
    Exec=/usr/bin/designer
    Name=Qt 4 Designer
    GenericName=Interface Designer
    X-KDE-StartupNotify=true
    MimeType=application/x-designer;
    Icon=designer
    Terminal=false
    Type=Application
    
    
    
    martinh@ganymed:~>
    compare if what you see is different.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  5. #5

    Default Re: Qt 4 Designer do not start

    The contents of my .destkop file is exactly the same.

    Edit: normally I do not swear, but WTF...

    I searched for design in kickoff, it listed Run: designer, and Qt 4 Designer.
    The Run: designer worked just okay.
    And after that, the Qt 4 Designer also started to work.

    Okay...

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt 4 Designer do not start

    Am 22.11.2012 20:56, schrieb ropeist:
    >
    > The contents of my .destkop file is exactly the same.
    >
    >

    What happens if you do a
    Code:
    kioclient exec /usr/share/applications/designer4.desktop
    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  7. #7

    Default Re: Qt 4 Designer do not start

    After restart, the bug returned.
    So I can start Designer from kickoff menu after once started from terminal. Then it works okay. But I have to do it after every boot.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt 4 Designer do not start

    Am 23.11.2012 11:36, schrieb ropeist:
    >
    > After restart, the bug returned.
    > So I can start Designer from kickoff menu after once started from
    > terminal. Then it works okay. But I have to do it after every boot.
    >
    >

    That sounds absolutely weird, no idea how to diagnose that, what version
    of libqt4-devel do you have (designer is part of that package) and is
    this version the same as the versions you see for the other qt packages with
    Code:
    rpm -qa '*qt4*'
    ?
    This is so far my only idea here that something has a inconsistent
    version and leads to such a funny side effect.
    Other than that I am clueless.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  9. #9

    Default Re: Qt 4 Designer do not start

    terminal:~> rpm -qa '*qt4*'
    libqt4-sql-4.8.1-2.4.1.x86_64
    patterns-openSUSE-devel_qt4-12.2-5.5.1.x86_64
    libqt4-devel-doc-4.8.1-2.4.2.x86_64
    python-qt4-4.9.1-2.1.2.x86_64
    libqt4-devel-4.8.1-2.4.1.x86_64
    libqt4-4.8.1-2.4.1.x86_64
    libqt4-sql-mysql-4.8.1-2.4.1.x86_64
    libpoppler-qt4-4-0.20.0-2.5.1.x86_64
    libqt4-sql-sqlite-4.8.1-2.4.1.x86_64
    libqt4-qt3support-4.8.1-2.4.1.x86_64
    pinentry-qt4-0.8.1-16.1.2.x86_64
    libqt4-devel-doc-data-4.8.1-2.4.2.noarch
    qt4-qtscript-0.2.0-2.1.2.x86_64
    libqt4-x11-4.8.1-2.4.1.x86_64

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt 4 Designer do not start

    The relevant packages have the same version 4.8.1, sorry I run out of ideas.

    > libqt4-devel-4.8.1-2.4.1.x86_64
    > libqt4-4.8.1-2.4.1.x86_64
    > libqt4-x11-4.8.1-2.4.1.x86_64



    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •