Results 1 to 5 of 5

Thread: nxserver on opensuse 12.2 - second user account

  1. #1

    Default nxserver on opensuse 12.2 - second user account

    Hi,

    I've installed nxserver, nxnode and nxclient on my workstation (OS OpenSuse 12.2) as well as nxclient on my notebook (Windows 7).
    After a long period of trouble shooting I could establish one working nxserver session (username 'bee39476') and log on to the workstation.

    On my workstation exist two user accounts:
    user1: elisabeth
    user2: bee39476

    I've installed the software package OpenFoam on the workstation in /home/elisabeth/.... but it is not possible to start my simulation cases if I connect to
    the workstation via nxserver with user 'bee34976'. If I navigate to the case directory to start the solver from there, simulation does not start.

    Therefore I've tried to create another nxserver user account 'elisabeth' to bypass that problem. But the login process provides me the well-known error message:

    NX> 203 NXSSH running with pid: 5952
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 194.95.107.19 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 3.5.0-11 - LFE
    NX> 105 Hello NXCLIENT - Version 3.5.0
    NX> 134 Accepted protocol: 3.5.0
    NX> 105 Set shell_mode: shell
    NX> 105 Set auth_mode: password
    NX> 105 Login
    NX> 101 User: elisabeth
    NX> 102 Password: ********
    NX> 103 Welcome to: rfhmab678 user: elisabeth
    NX> 105 Listsession --user="elisabeth" --status="suspended\054running" --geometry="1536x960x32+render" --type="unix-kde"
    NX> 127 Available sessions:

    Display Type Session ID Options Depth Screen Status Session Name
    ------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

    NX> 148 Server capacity: not reached for user: elisabeth
    NX> 105 Start session with: --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --samba="1" --media="1" --mediahelper="esd" --imagecompressionmethod="3" --imagecompressionlevel="-1" --render="1" --session="CFD" --type="unix-kde" --geometry="1471x932" --client="winnt" --keyboard="pc102\057de" --screeninfo="1471x932x32+render"
    NX> 502 ERROR: Public key authentication failed
    NX> 502 ERROR: NX server was unable to login as user: elisabeth
    NX> 502 ERROR: Please check that the account is enabled to login,
    NX> 502 ERROR: the user's home directory, the directory ~/.ssh
    NX> 502 ERROR: and the file ~/.ssh/authorized_keys2 have correct
    NX> 502 ERROR: permissions setting according to the StrictModes
    NX> 502 ERROR: of your SSHD configuration.
    NX> 999 Bye.
    NX> 280 Exiting on signal: 15



    Why can one user (bee39476) connect the workstation whereas the other (elisabeth) can not?
    What do I have to change to make my simulation cases from my windows notebook running if I access the workstation with user 'bee39476'?

    Please help me!
    Lisa

  2. #2
    josephkk NNTP User

    Default Re: nxserver on opensuse 12.2 - second user account

    On Tue, 20 Nov 2012 19:16:01 GMT, elisabethbeer
    <elisabethbeer@no-mx.forums.opensuse.org> wrote:

    >
    >Hi,
    >
    >I've installed nxserver, nxnode and nxclient on my workstation (OS
    >OpenSuse 12.2) as well as nxclient on my notebook (Windows 7).
    >After a long period of trouble shooting I could establish one working
    >nxserver session (username 'bee39476') and log on to the workstation.
    >
    >On my workstation exist two user accounts:
    >user1: elisabeth
    >user2: bee39476


    ? Do you have the same two users configured on the laptop? It just might
    matter.
    >
    >I've installed the software package OpenFoam on the workstation in
    >/home/elisabeth/.... but it is not possible to start my simulation cases
    >if I connect to
    >the workstation via nxserver with user 'bee34976'. If I navigate to the
    >case directory to start the solver from there, simulation does not
    >start.
    >
    >Therefore I've tried to create another nxserver user account
    >'elisabeth' to bypass that problem. But the login process provides me
    >the well-known error message:
    >
    >NX> 203 NXSSH running with pid: 5952
    >NX> 285 Enabling check on switch command
    >NX> 285 Enabling skip of SSH config files
    >NX> 285 Setting the preferred NX options
    >NX> 200 Connected to address: 194.95.107.19 on port: 22
    >NX> 202 Authenticating user: nx
    >NX> 208 Using auth method: publickey
    >HELLO NXSERVER - Version 3.5.0-11 - LFE
    >NX> 105 Hello NXCLIENT - Version 3.5.0
    >NX> 134 Accepted protocol: 3.5.0
    >NX> 105 Set shell_mode: shell
    >NX> 105 Set auth_mode: password
    >NX> 105 Login
    >NX> 101 User: elisabeth
    >NX> 102 Password: ********
    >NX> 103 Welcome to: rfhmab678 user: elisabeth
    >NX> 105 Listsession --user="elisabeth" --status="suspended\054running"
    >--geometry="1536x960x32+render" --type="unix-kde"
    >NX> 127 Available sessions:
    >
    >Display Type Session ID Options
    >Depth Screen Status Session Name
    >------- ---------------- -------------------------------- --------
    >----- -------------- ----------- ------------------------------
    >
    >NX> 148 Server capacity: not reached for user: elisabeth
    >NX> 105 Start session with: --link="adsl" --backingstore="1"
    >--encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1"
    >--strict="0" --composite="1" --samba="1" --media="1" --mediahelper="esd"
    >--imagecompressionmethod="3" --imagecompressionlevel="-1" --render="1"
    >--session="CFD" --type="unix-kde" --geometry="1471x932" --client="winnt"
    >--keyboard="pc102\057de" --screeninfo="1471x932x32+render"
    >NX> 502 ERROR: Public key authentication failed
    >NX> 502 ERROR: NX server was unable to login as user: elisabeth
    >NX> 502 ERROR: Please check that the account is enabled to login,
    >NX> 502 ERROR: the user's home directory, the directory ~/.ssh
    >NX> 502 ERROR: and the file ~/.ssh/authorized_keys2 have correct
    >NX> 502 ERROR: permissions setting according to the StrictModes
    >NX> 502 ERROR: of your SSHD configuration.
    >NX> 999 Bye.
    >NX> 280 Exiting on signal: 15
    >
    >
    >
    >Why can one user (bee39476) connect the workstation whereas the other
    >(elisabeth) can not?
    >What do I have to change to make my simulation cases from my windows
    >notebook running if I access the workstation with user 'bee39476'?
    >
    >Please help me!
    >Lisa


  3. #3

    Default Re: nxserver on opensuse 12.2 - second user account

    Quote Originally Posted by elisabethbeer View Post
    Why can one user (bee39476) connect the workstation whereas the other (elisabeth) can not?
    Each user needs ssh access to the NX server. Further you can not have more that 2 users with NoMachine NX free edition.

    You can list the NX users with

    Code:
    nxserver --userlist
    check the status of a user with

    Code:
    nxserver --usercheck elisabeth
    add, remove, enable, disable users with:

    Code:
    nxserver --useradd USERNAME
    nxserver --userdel  USERNAME
    nxserver --userenable  USERNAME
    nxserver --userdisable  USERNAME
    See more details with

    Code:
    nxserver --help

    If you need more users, you should use FreeNX. You can also use both FreeNX and NoMachine NX and have them listening to different ports.
    Howtos are available here:



    Please don't ask me to rewrite these Howtos here! Just read and follow them carefully and you will get FreeNX and/or NoMachine NX installed and correctly set up.

  4. #4

    Default Re: nxserver on opensuse 12.2 - second user account

    Hi pta,

    both Users are list in the userlist: nxserver --userlist

    - bee39476
    - elisabeth

    I am aware of the fact that NX free edition restricts the number of users to two. I have added exactly two users so that should be all right (I hope).

    I spent ages about that problem and haven't been able to solve it since today. Currently I've one user (bee39476) which can connect to the server without any problems. This user has his own user account on the client notebook.
    I am not allowed to install a second user on the Client-Notebook. That might be the problem as well (?).

    For daily work it would be absolutely fine to work with user 'bee39476' but this one can not start the solver installed on the Linux server. Though this is now more a Linux OpenSuse 12.2 topic. I am not able to give both server users the same rights.

    Originally I've installed the simulation package (the reason for which I stumbled upon nxserver) of OpenFoam in the file structure of user account 'elisabeth' on the workstation.
    Since I've managed to set up nxserver with my official client user 'bee39476' from my notebook I've tried to start OpenFoam (via NX server) from my notebook. That did not work. Probably because the software is/was installed in another user's file structure. To bypass that point I've installed OpenFoam package in /opt/OpenFOAM as root and expected now to be able to use it with each other user as well. But this does not work either!!! Why?
    As well I've tried to change owner and rights of the software's installation folder: read, write, execute for others, owner of installation folder = bee39476.
    That idea failed as well :-(

    The last point to try out would be to install OpenFoam package finally in the 'bee39476' users file structure on the server.
    But even if that works I would really like to know how to solve the problem regularly! There must be some way to allow user2 to access software packages of user1 on a Linux distribution.
    I am still to unversed in Linux, probably that problem could be solved quickly???

    Do you have an idea?

    Lisa

  5. #5

    Default Re: nxserver on opensuse 12.2 - second user account

    Quote Originally Posted by elisabethbeer View Post
    I am not allowed to install a second user on the Client-Notebook. That might be the problem as well (?).
    No. You don't need to have an account on the client. The user who runs the nx client doesn't need to be the same as the user who connects to the server. The latter needs a ssh account on the server.

    If you have root access to the nxserver, you can add an nx user with nxserver --userad <username>. Here's an example:

    Code:
    # nxserver --useradd tester
    NX> 801 User: tester uses SSHD authentication.
    NX> 900 Adding public key for user: tester to the authorized keys file.
    NX> 900 Verifying public key authentication for NX user: tester.
    NX> 900 Public key authentication succeeded.
    NX> 301 User: tester enabled in the NX user DB.
    NX> 999 Bye.
    and check if he's able to connect:

    Code:
    # nxserver --usercheck tester
    NX> 900 Verifying public key authentication for NX user: tester.
    NX> 900 Public key authentication succeeded.
    NX> 999 Bye.
    As you already know, NoMachine nx won't let you add a third user:

    Code:
    # nxserver --useradd tester2
    NX> 536 ERROR: Reached the maximum number of allowed users on this server.
    NX> 999 Bye.
    User 'tester' doesn't need to exist on the client. On the server, you can check the session files and error logs in the directory created for the session in /home/tester/.nx.


    Quote Originally Posted by elisabethbeer View Post
    Originally I've installed the simulation package (the reason for which I stumbled upon nxserver) of OpenFoam in the file structure of user account 'elisabeth' on the workstation.
    Since I've managed to set up nxserver with my official client user 'bee39476' from my notebook I've tried to start OpenFoam (via NX server) from my notebook. That did not work. Probably because the software is/was installed in another user's file structure.
    Indeed. But it is not an nx problem. I don't know OpenFoam, but someone built a package for openSUSE in his home repo. You might want to try this package and install it properly as root.
    software.opensuse.org: OpenFoam

    If you're not able to use this software as any user on the server, you should open a new thread with 'OpenFoam' in the subject, to catch the attention of someone who knows about this program.


    Quote Originally Posted by elisabethbeer View Post
    But even if that works I would really like to know how to solve the problem regularly! There must be some way to allow user2 to access software packages of user1 on a Linux distribution.
    Any user can use any package, as long as the software is installed properly (as root) and doesn't have specific user restrictions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •