Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: OpenSUSE 12.2 - Skype microphone doesn't work

  1. #1
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default OpenSUSE 12.2 - Skype microphone doesn't work

    Hello,

    after many years of happy life with opensuse 11.2 I'm here trying the "breeze" of the new 12.2.
    I've spent a lot of hours trying to make latest version of Skype (4.1.0.20) working... but no way.

    Using skype options I can test sound (it's ok) and I can make a test call too but... mic doesn't register.
    I'm lost a lot of hours, I'm exhausted...

    On Yast I see 2 audio device:

    1) 5 series/3400 (I think is the oone embedded in the motherboard of my AsRock mini-pc)
    2) nVidia corporation (I think is the one from graphic card providing HDMI output too)

    here the output issuing the "arecord - l" command:
    Code:
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 2: ALC892 Analog [ALC892 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Here the output issuing the "aplay - l" command:
    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
      Subdevices: 1/1
    Basically, as I understand, I have two devices: 1 only for capture (HDA Intel) and 2 for playback (HDA Intel + HDA NVidia).
    Again (as I understand) there are 3 "area" where one can do something:

    A) Phonon
    B) Yast
    C) Kmix

    About Phonon:
    I've read the Phonon is a virtualization tool that can manage different input sound device, it's great, it's cool and so on... okay. I know that devices should be listed in the right order 'cause some software doesn't care of Phonon (e.g. Skype).
    I have fight with Phonon and I think I've reached a compromise, no more error messages from Skype (like "playback device problem" or "capture device problem"). But... MIC is not capturing nothing (but for Skype is all ok ! )

    About Yast:
    I've read somewhere that in openSUSE 12.2 one can solve microphone problems by deleting the card that you don't want use (NVidia HDMI in my case) going in Yast -> Hardware -> Sound (I think the source is this SDB:Skype - openSUSE)
    Nevertheless, that article is talkink about Logitech Videocamera, so I'm scared to make disasters... I decided to touch nothing in Yast.
    Above sentence is not completely true. I tried to remove Pulseaudio management from both devices (you can do this in Yast using the misteryious button "Other" below on the left). Anyway, this soved nothing, so I have re-enabled Pulseaudio again on both devices.

    About Kmix:
    In the mixer there are no many things that one can do, apart playing with cursors to raise levels for palyback and capture devices. My capture device is at 70% of level. I think is ok.
    Anyway, I see 4 tabs in the mixer window:

    [Playback device] (2 devices - correct)
    [Capture device] (1 device correct)
    [Playback streams] (1 device called "event sounds" - I don't want to know what is... )
    [Capture streams] (0 device - correct)

    Nothing more to see/do here.


    I've played with all skype options combinations... no way... the strange thing is that (I repeat) for Skype is all ok. But that stupid microphone is died... (yes I tried to move from back connector to back connector for dozen of times... no result...)
    Now I'have discovered a big post form oldcpu illustrating another approach: installing Pavucontrol could solve the problem (see Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums ) but... I'm little suspicious, how can a program that is basically a volume-control solve my problem
    As usual, I'm a coward and I'm always scared in installing things "only to try"...
    Is pulsecontrol a solution?
    It can work with Phonon and Pulseaudio installed?
    Somebody can help me?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,649
    Blog Entries
    14

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    Check in KDE - Systemsettings - Multimedia - Phonon if your mic is on top.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    Quote Originally Posted by giulio_buccini View Post
    Hello, As usual, I'm a coward and I'm always scared in installing things "only to try"...
    Is pulsecontrol a solution?
    It can work with Phonon and Pulseaudio installed?
    Somebody can help me?
    Hi, I don't know if it is a "help", but in my case I had to uninstall pulseaudio to have a working mic.
    but in my case this command

    Code:
    arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav
    worked...:-)
    thnx, ciao, Pier:-)

  4. #4
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    Quote Originally Posted by Knurpht View Post
    Check in KDE - Systemsettings - Multimedia - Phonon if your mic is on top.
    Yes, it's on top in all sections:

    In "audio playback" section I have two cards and "Internal audio analog stereo" is always the first one;

    In "audio recording" I have only the "Internal audio analog stereo" device, so nothing to do here;

    In "video recording" I see nothing 'cause I have to web camera connected to my pc




  5. #5
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    Quote Originally Posted by pier_andreit View Post
    Hi, I don't know if it is a "help", but in my case I had to uninstall pulseaudio to have a working mic.
    but in my case this command

    Code:
    arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav
    worked...:-)
    thnx, ciao, Pier:-)
    arecord doesn't work for me... it's strange... here some output:
    Code:
    giulio@linux-5wvn:~> cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.25.
    
    giulio@linux-5wvn:~> cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xf9ff4000 irq 52
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xfbc7c000 irq 17
    Speaker test is ok:
    Code:
    speaker-test -Dplug:front -c2 -l5 -twav
    But testing the MIC with arecord +aplay doesn't work... it register nothing:
    Code:
    giulio@linux-5wvn:~> arecord -d 10 myrecording.wav
    giulio@linux-5wvn:~> aplay -vv myrecording.wav


    What can I do now? I go to uninstal pulseaudio? Or I uninstall NVidia hdmi device? Or I install Pavucontrol?

    p.s: the microphone is ok... I use it everyday with my old, crappy, damaged computer running the magnificient openSUSE 11.2 (with Gnome2 obviously )

  6. #6
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    As I see, nobody can suggest me something. Unfortunately in this days I have not so much time to make some test, maybe in the next week...

    Anyway, I'm a little bit disappointed from latest version of OpenSUSE, honestly I think that technology should simplify our life, but more time passes more I see thing getting complicated. In my opinion there was no need for big revolution after Gnome2 and opensuse 11.x, but... you know...

    We will see if I will became acquainted with 12.2 and his "fashion/cool" KDE-plasma interface. For now it's just enough for me to discover where the shutdown button is located before switching back to my old pc.
    eheheheheh...

  7. #7
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    [SOLVED]

    After trying all possible combinations, I've solved.
    My problem was that nott all possible device-configurations was displayed in Skye (when you're going to adjust sound device settings in the "Option" item).
    Only HDMI card was displayed and/or something useless devices named "default", "system default" and so on...
    pavucontrol program helped, but not in the way oldCPU suggested.

    If you have HDMI hardware in your PC (like me) then you should have 2 audio device too: Internal audio card + HDMI blablabla

    Do what follows (KDE 4.8 plasma interface)

    STEP 1) Disable your "HDMI blablabla" device

    a) Go in "dektop settings", select "multimedia" then select Phonom
    b) select the "Audio Hardware setup"
    c) you will see 2 devices, disable the "HDMI blablabla" (or nvidia blablabla) by setting Profile to "Off"
    d) now select "internal audio" and put "profile" to "analog stereo duplex"
    e) stay again on "internal audio" and look below to "device configuration", use the dropdown menu to set
    e1) sound device = "playback..." with connector = "analog output"
    e2) sound device = "recording..." with connector = "Front microphone" (in my case, otherwise choose something different)
    f) click on "Apply" button and exit

    STEP 2) Be sure PulseAudio is enabled
    a) start YAST
    b) go to the "hardware" item, then select "sound"
    c) a "quite empty" windows opens, but there is all you need. You will see 1 row with your internal card and 1 row for the other "multimedia" one.
    d) Ignore the multimedia row, select your internal card (the name usually includes the "chipset" word) and...
    d1) set you internal card as "Primary card" by using the anonym button called "Other" in the bottom-right part of the window
    d2) not finished yet, using the same meaningful button, selecte PulseAudio configuration and be sure that pulseaudio is activated (click on the checkbox if necessary)
    e) click on the "ok" button

    STEP 3) turn off your pc

    a) don't logout, don't restart, turn it off.
    b) turn on it again

    STEP 4) run pavucontrol
    a) download pavucontrol and install it (for example by using YAST and searching in standard opensuse repositories)
    b) close the kmixer program (it should be displayed on the taskbar below of the screen, so just right-click and quit)
    c) start pavucontrol (for example by a terminal window, or search in KDE menus) and play a little with it (raise up levels, check if a capture device is present)
    d) pavucontrol makes the miracle! all of the possible carddevices will be listed in skype!
    e) go in skype, settings, sound devices and start trying combinations of card device until the test call doesn't work. Here the conf that works for me:




    STEP 5) turn off your pc again

    a) don't logout, don't restart, just turn it off.
    b) turn on it again
    c) now kmixer should start again, but pavucontrol not. That is exaclty what we want
    e) go in skype and check settings again, they should be exactly as you set before*.

    (*) don't laugh, but sometimes, immediately after starting the pc, skype-settings return back to some no-sense standard configuration. After that I start working for 2-3 minutes, I go back to take a look at skype settings and... magically, all right settings are restored!
    I think there are some greemlins living inside openSUSE...
    In this case I would like go back to my Commodore64.

  8. #8
    dd NNTP User

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    On 01/19/2013 02:46 PM, giulio buccini wrote:
    >
    > [SOLVED]
    > (*) don't laugh, but sometimes, immediately after starting the pc,
    > skype-settings return back to some no-sense standard configuration.
    > After that I start working for 2-3 minutes, I go back to take a look at
    > skype settings and... magically, all right settings are restored!
    > I think there are some greemlins living inside openSUSE...


    yep, there probably are strange things in there..

    i was lucky and didn't have the problem you (and others) had but anyway
    want to THANK YOU for taking the time to document your path to success!!

    --
    dd
    openSUSE®, the "German Engineered Automobile" of operating systems!


  9. #9
    Join Date
    Mar 2009
    Location
    United States
    Posts
    612

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    I don't think it has anything to do with openSUSE. Sound under Linux is just a mess. For example, no matter what I set mixers sometimes my mic will not work. Though after reboot or etc, it works... I am debating if I should have pulseaudio installed or not.

  10. #10
    Join Date
    Feb 2010
    Location
    Munich (Germany)
    Posts
    137

    Default Re: OpenSUSE 12.2 - Skype microphone doesn't work

    Quote Originally Posted by dd View Post
    On 01/19/2013 02:46 PM, giulio buccini wrote:
    >
    > [SOLVED]
    > (*) don't laugh, but sometimes, immediately after starting the pc,
    > skype-settings return back to some no-sense standard configuration.
    > After that I start working for 2-3 minutes, I go back to take a look at
    > skype settings and... magically, all right settings are restored!
    > I think there are some greemlins living inside openSUSE...


    yep, there probably are strange things in there..

    i was lucky and didn't have the problem you (and others) had but anyway
    want to THANK YOU for taking the time to document your path to success!!
    Essentially, the point is that you need to have pavucontrol running (with pulseaudio enabled and kmixer stopped) in order to see all possible sound devices listed in the Skype configuration settings. Otherwise... you're done! You can even spend weeks on your pc trying to make skype working....
    I've discovered it casually, no help, no docs, only lucky. I think it's a shame for a modern operating system.
    For this reason I think that the Commodore64 was a great PC...

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •