Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: NVIDIA issues, Mac Mini + openSUSE 12.1

  1. #1

    Unhappy NVIDIA issues, Mac Mini + openSUSE 12.1

    My screen is quite messed up, from what I can tell the top of my screen is fine but the left and bottom (side-bars) are out of view.
    As far as I'm aware it's an NVIDIA issue and I've been messing around with it for the past 48 hours trying to fix it, following various
    how-to's and past threads.

    During an attempt to install a driver that supports my GPU I had to disable "the x server" using the "init 3" command and run the install. The install failed due to
    some kernel relate issue.*

    I'm not really sure where to begin.

    After reading the bug lists and other people's issues I went along adding NVIDIA to the repositories and doing all sorts of things
    I don't 100% understand and shouldn't have done.

    I'm not sure if it's a resolution issue or what. All I can tell you is that my screen doesn't fit and nomodeset doesn't work (anymore).
    I didn't like the 800x600 resolution the nomodeset gave me. So I continued looking for ways to fix it, I've managed to install an
    NVIDIA driver of some-sort (automated after adding the NVIDIA repository) allowing a bit more detailed configuration of my display.
    Much to my dismay this prevents the nomodeset solution from working, leaving me with a very high-res, but still too-big screen.

    I'm an Ubuntu person so trouble-shooting is a but more difficult. E.g. apt-get does not exist, but zypper does.

    My Graphics card is an NVIDIA GeForce 9400M.
    I did find an NVIDIA driver for my graphics card but it complained about my kernel and me needing to set directories etc. *
    If it helps I'm using an adapter (converts my mac mini's output to HDMI) and using my TV as a monitor.

    * - same thing repeated twice.

    Thanks in advance,

    LeChameleon

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Since we cannot see what the "things you don't 100% understand" are, I strongly suggest you reinstall, preferably 12.2. That should bring a clean working install, though in wrong resolution. After install, first perform an update, then add the NVIDIA repository, and install the driver packages the system suggests. Then reboot.
    A bit of background: the NVIDIA driver does not support modesetting, so the install changes the value of "NO_KMS_IN_INITRD" to "yes". That has exactly the same effect as putting "nomodeset" on the kernel option line at boot. (KMS = Kernel Mode Setting)
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Thanks, sorry for my lack of clarity.

    Will install within the next few hours, hopefully this'll work...

  4. #4

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    After installing 12.2, I did as you said. Installing updates and then adding the NVIDIA repository, but this time it didn't suggest a driver at all (and dont worry, I made it refresh and check etc) I used zypper for this.

    I decided to google up what other mac users did. I then stumbled upon a mac guide, it appears one of the mac books also has the NVIDIA GeForce 9400M and I attempted to install a driver mentioned there.

    The driver failed (as always), but offered to remove some nouveau stuff from some configs, I accepted hoping it would fix it, but no the driver still failed to install. I then rebooted.

    I then saw some other people mentioning editing the grub config I decided to go to Yast -> Boot Loader and checked to see if I could do the same as them. I then noticed the VGA 800x600... I decided to click on it and try out the best resolution on there.

    To my luck it worked!

    I know, I didn't exactly follow your instructions, but it looks amazing! No issues now except for a login issue.

    I'd prefer not to create 2 threads within the same day so I'll just mention it here.

    *** SEPERATE ISSUE:

    When at the login screen, I have to login in twice for it to work. It doesn't say my password is wrong, the password I entered dissappears and I have to retype it again. (Not a major issue) Just find it a bit annoying.

    thanks in advance,

    Le Chameleon

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Quote Originally Posted by LeChameleon View Post
    *** SEPERATE ISSUE:

    When at the login screen, I have to login in twice for it to work. It doesn't say my password is wrong, the password I entered dissappears and I have to retype it again. (Not a major issue) Just find it a bit annoying.

    thanks in advance,

    Le Chameleon
    We'd normally rather see a second thread created, if this issue was unrelated to the above. IMHO something that changed during the experiment mentioned. I've seen the issue before though. Please check if an xorg.conf exists:
    Code:
    ls -l /etc/X11/xorg.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Question Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Quote Originally Posted by Knurpht View Post
    We'd normally rather see a second thread created, if this issue was unrelated to the above. IMHO something that changed during the experiment mentioned. I've seen the issue before though. Please check if an xorg.conf exists:
    Code:
    ls -l /etc/X11/xorg.conf
    I installed java, you can only guess what happened...
    It installed an NVIDIA driver which then messed up everything again.

    I then used

    Code:
    zypper remove nvidia*
    Or something simialar to the above to remove the nvidia drivers. Which allowed me to reboot with a fitting screen.
    As for the xorg.conf, no it doesn't exist. I've just realised how problematic this is...

    Would you like me to reinstall that nvidia driver or is there another approach you'd recommend?

    (I really appreciate the patience),

    LeChameleon

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Java did not pull in the NVIDIA driver, it auto installs since you have the repo active.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Quote Originally Posted by Knurpht View Post
    Java did not pull in the NVIDIA driver, it auto installs since you have the repo active.
    Are you sure? Because from what I could see it was a dependacy...
    Anyways, I'll remove the repository and see if the java stuff still works, thanks though.

  9. #9

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.3 [UPDATED through 12.1]

    Greetings everyone, i am new to opensuse and i have also issues with my opensuse installation on my mac mini(late 2009).

    I have installed the 64bit version of opensuse 12.1 a few weeks ago and then upgraded to the 12.3. When i first installed 12.1 i had no issues with graphics at all, after the upgrade this are the results:

    First i run the commands below [i found them in a forum but unfortunately i can't locate right now the url from my history]:

    Code:
    sudo zypper ar --refresh Index of /repositories/home:/ealin:/apple/openSUSE_12.3 "Apple Stuff"
    
    sudo zypper in macfanctld applesmc-kmp-default applesmc-kmp-desktop applesmc pommed mbp-nvidia-bl nvidia-bl mbp-nvidia-bl-kmp-default mbp-nvidia-bl-kmp-desktop nvidia-bl-kmp-desktop nvidia-bl-kmp-default
    
    
    sudo zypper ar --refresh Index of /pub/mirrors/packman/suse/openSUSE_12.3/ "Packman Repository"
    
    
    sudo zypper in broadcom-wl broadcom-wl-kmp-desktop broadcom-wl-kmp-default
    
    
    sudo zypper in alsa-utils
    
    
    sudo /usr/bin/alsamixer
    then i did the following 2 approaches:

    0. with the configuration "blacklist noueavu"@/etc/modprobe.d/nvidia-desktop.conf i have just a green login screen in terminal, everything is ok but after login-in and press "X" i get a black screen and the terminal@ctrl+alt+F10 returns this:





    1.
    then i removed the "nvidia-desktop.conf" file and the result after boot was this:









    and the results from the terminal@ctrl+alt+F10:








    If i got the latest instructions from the NVRM right, then the i had to do the first approach were i'm blacklisting the noueavu mod. I'm a little bit confused, so any directions on what to study would be welcome :-D

    Also my Xorg.0.log file: http://pastebin.com/ixCiaX2t

    Thanks in advance :-D

  10. #10

    Default Re: NVIDIA issues, Mac Mini + openSUSE 12.1

    Yes, you have to blacklist nouveau if you want to use the nvidia driver.

    But from your Xorg.0.log:
    Code:
    [   588.475] 
    
    X.Org X Server 1.10.4
    
    Release Date: 2011-08-19
    That's the X Server included in 12.1!
    You didn't fully upgrade your system to 12.3 and have a mixture between 12.1 and 12.3 now. That's most likely causing your problem.

    So please remove all 12.1 repos and then do a zypper dup to fully upgrade to 12.3.
    If you're not sure, post your repo list to get more specific advice:
    Code:
    zypper lr -d

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •