Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Update problems

  1. #1
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Update problems

    For awhile now I've had problems with the following:

    openSUSE-2012-565- kdeenlive: align mlt dependencies with packman
    openSUSE-2012-588- KDE: 4.8.5 stable update
    openSUSE-2012-751- update for libqt4

    Any attempt to 'Apply' in Apper yields:

    patchpenSUSE-2012-588-1.noarch conflicts with kdeartwork4-
    wallpapers.noarch < 4.8.5-2.4.1 provided by kdeartwork4-
    wallpapers-4.8.4-186.1.noarch<br>patchpenSUSE-2012-565-1.noarch conflicts
    with libmlt4.i586 < 0.7.8-2.4.1 provided by
    libmlt4-0.7.6-1.8.i586<br>patchpenSUSE-2012-751-1.noarch conflicts with
    libqt4-devel-doc-data.noarch < 4.8.1-2.4.2 provided by libqt4-devel-doc-
    data-4.8.0-247.2.noarch

    zypper lr -d below:

    1 | nvidia | nvidia | Yes
    | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.2/
    |
    2 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | No
    | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-
    TSSTcorpCD_DVDW_SH-W162L |
    3 | packman-essentials | packman-essentials | Yes
    | Yes | 99 | rpm-md |
    http://packman.inode.at/suse/openSUSE_12.2/Essentials/ |
    4 | packman-multimedia | packman-multimedia | Yes
    | Yes | 99 | rpm-md |
    http://packman.inode.at/suse/openSUSE_12.2/Multimedia/ |
    5 | repo-debug | openSUSE-12.2-Debug | No
    | Yes | 99 | NONE |
    http://download.opensuse.org/debug/d...12.2/repo/oss/ |
    6 | repo-debug-update | openSUSE-12.2-Update-Debug | No
    | Yes | 99 | NONE |
    http://download.opensuse.org/debug/update/12.2/ |
    7 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No
    | Yes | 99 | NONE |
    http://download.opensuse.org/debug/update/12.2-non-oss/ |
    8 | repo-non-oss | openSUSE-12.2-Non-Oss | Yes
    | Yes | 99 | yast2 |
    http://download.opensuse.org/distrib.../repo/non-oss/ |
    9 | repo-oss | openSUSE-12.2-Oss | Yes
    | Yes | 99 | yast2 |
    http://download.opensuse.org/distrib...12.2/repo/oss/ |
    10 | repo-source | openSUSE-12.2-Source | No
    | Yes | 99 | NONE |
    http://download.opensuse.org/source/...12.2/repo/oss/ |
    11 | repo-update | openSUSE-12.2-Update | Yes
    | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.2/
    |
    12 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss | Yes
    | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.2-
    non-oss/

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update problems

    On 2012-11-16 19:38, GofBorg wrote:
    > zypper lr -d below:


    Unreadable.
    Please use code tags. Advanced editor, '#' button.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Update problems

    > Advanced editor, '#' button.

    I don't know what this means. I am posting via NNTP.
    Here is my best effort at cleaning it up.

    <code>
    1 |nvidia | nvidia Yes| Yes| 99|rpm-md | ftp://download.nvidia.com/opensuse/12.2/
    2 | openSUSE-12.2-1.6| openSUSE-12.2-1.6 | No| No|99|yast2| cd:///?devices=/dev/disk/by-id/ata-TSSTcorpCD_DVDW_SH-W162L
    3 | packman-essentials| packman-essentials | Yes| Yes|99| rpm-md | http://packman.inode.at/suse/openSUSE_12.2/Essentials/
    4 | packman-multimedia| packman-multimedia| Yes| Yes|99| rpm-md | http://packman.inode.at/suse/openSUSE_12.2/Multimedia/
    5 | repo-debug| openSUSE-12.2-Debug| No| Yes|99| NONE | http://download.opensuse.org/debug/d...12.2/repo/oss/
    6 | repo-debug-update | openSUSE-12.2-Update-Debug| No | Yes |99 | NONE | http://download.opensuse.org/debug/update/12.2/
    7 | repo-debug-update-non-oss|openSUSE-12.2-Update-Debug-Non-Oss|No|Yes|99|NONE|http://download.opensuse.org/debug/update/12.2-
    non-oss/
    8 | repo-non-oss| openSUSE-12.2-Non-Oss| Yes | Yes|99|yast2| http://download.opensuse.org/distrib.../repo/non-oss/
    9 | repo-oss| openSUSE-12.2-Oss| Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...12.2/repo/oss/
    10 | repo-source| openSUSE-12.2-Source | No| Yes|99| NONE| http://download.opensuse.org/source/...12.2/repo/oss/
    11 | repo-update | openSUSE-12.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.2/
    12 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss| Yes| Yes |99 |rpm-md | http://download.opensuse.org/update/12.2-non-oss/
    </code>

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update problems

    On 2012-11-16 20:09, GofBorg wrote:
    >> Advanced editor, '#' button.

    >
    > I don't know what this means. I am posting via NNTP.


    Me too.

    Then use open square bracket, CODE, close bracket. At the end, same
    thing with a '/' before the code word. Like this:

    Code:
    code inside.

    > Here is my best effort at cleaning it up.


    It is wrapped, difficult to read. Look how I do it:

    Code:
    
    > minas-tirith:~ # zypper lr --details
    > #  | Alias                              | Name                                        | Enabled | Refresh | Priority | Type   | URI                                                                                                      | Service
    > ---+------------------------------------+---------------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------------------------+--------
    >  1 | Ext_Packman                        | Packman Repository                          | Yes     | Yes     |  120     | rpm-md | http://packman.mirrors.skynet.be/pub/packman/suse/11.4/                                                  |
    >  2 | Ext_google-talkplugin              | Google Talk Plugin                          | Yes     | Yes     |  110     | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                                                  |
    >  3 | Ext_libdvdcss                      | libdvdcss repository                        | Yes     | Yes     |  120     | rpm-md | http://opensuse-guide.org/repo/11.4/
    ....

    You have to use a fixed width font and make sure your editor does not wrap.

    I'll have to edit yours.

    Code:
    
    > 1 |nvidia                           | nvidia                               Yes| Yes|99| rpm-md | ftp://download.nvidia.com/opensuse/12.2/
    > 2 | openSUSE-12.2-1.6               | openSUSE-12.2-1.6                  | No | No |99| yast2| cd:///?devices=/dev/disk/by-id/ata-TSSTcorpCD_DVDW_SH-W162L
    > 3 | packman-essentials              | packman-essentials                 | Yes| Yes|99| rpm-md | http://packman.inode.at/suse/openSUSE_12.2/Essentials/
    > 4 | packman-multimedia              | packman-multimedia                 | Yes| Yes|99| rpm-md | http://packman.inode.at/suse/openSUSE_12.2/Multimedia/
    > 5 | repo-debug                      | openSUSE-12.2-Debug                | No | Yes|99| NONE   | http://download.opensuse.org/debug/distribution/12.2/repo/oss/
    > 6 | repo-debug-update               | openSUSE-12.2-Update-Debug         | No | Yes|99| NONE   | http://download.opensuse.org/debug/update/12.2/
    > 7 | repo-debug-update-non-oss       | openSUSE-12.2-Update-Debug-Non-Oss | No | Yes|99| NONE   |http://download.opensuse.org/debug/update/12.2- non-oss/
    > 8 | repo-non-oss                    | openSUSE-12.2-Non-Oss              | Yes| Yes|99| yast2  | http://download.opensuse.org/distribution/12.2/repo/non-oss/
    > 9 | repo-oss                        | openSUSE-12.2-Oss                  | Yes| Yes|99| yast2  | http://download.opensuse.org/distribution/12.2/repo/oss/
    > 10 | repo-source                    | openSUSE-12.2-Source               | No | Yes|99| NONE   | http://download.opensuse.org/source/distribution/12.2/repo/oss/
    > 11 | repo-update                    | openSUSE-12.2-Update               | Yes| Yes|99| rpm-md | http://download.opensuse.org/update/12.2/
    > 12 | repo-update-non-oss            | openSUSE-12.2-Update-Non-Oss       | Yes| Yes|99|rpm-md  | http://download.opensuse.org/update/12.2-non-oss/
    Your repo list looks fine to me. Maybe I would set packman priorities
    different. I don't see you have any extra repo, like for kde.


    I would just use plain Yast Online Update module to apply patches, and
    see what happens. I'm not familiar with apper to try solve its nuances.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Update problems

    Don't use Apper is my recommend

    Do this on repos 3 and 4
    https://dl.dropbox.com/u/10573557/Sw...man_switch.png

    From here on only use
    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    dd NNTP User

    Default Re: Update problems

    On 11/16/2012 07:48 PM, Carlos E. R. wrote:
    > Please use code tags.


    he is using nntp.

    --
    dd

  7. #7
    dd NNTP User

    Default Re: Update problems

    On 11/16/2012 07:38 PM, GofBorg wrote:
    > Any attempt to 'Apply' in Apper yields:


    what happens if you don't use Apper and instead

    1. reset the update repo to a higher priority, like say 95 (you can do
    that easily in YaST Software Repositories..)

    2. then launch YaST Online Update

    some of 'they' say apper works great in 12.2; other 'they' say to use
    apper only as a signal that you should run either YaST or zypper (but
    never actually use apper to install/uninstall anything); other 'they'
    say to disable or uninstall apper!

    you be the judge or what is best for you!! if you disable or uninstall
    it then it will be up to you to run YaST Online Update or 'zypper patch'
    occasionally (weekly, daily or ???)..

    [note the developing 'they' are discussing if apper will be included in
    12.3, or not...stay tuned]

    --
    dd

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update problems

    On 2012-11-17 09:15, dd wrote:
    > On 11/16/2012 07:48 PM, Carlos E. R. wrote:
    >> Please use code tags.

    >
    > he is using nntp.


    So are we :-)
    And I use code tags.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,854
    Blog Entries
    14

    Default Re: Update problems

    Done like this

    [CODE] output text here[/CODE]
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    dd NNTP User

    Default Re: Update problems

    On 11/17/2012 01:26 PM, Knurpht wrote:
    > Done like this


    looks like this: http://susepaste.org/76028734

    --
    dd

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •