Results 1 to 7 of 7

Thread: Window Manager not Running -- Help Fix Please

  1. #1
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Window Manager not Running -- Help Fix Please

    After using "online update" in Yast2 I no longer have a working Window Manager. The windows have no menu bars to open/close and I can not move them around. Previous to this the system was working fantastically.

    Here is the update history where I believe something went wrong.

    2012-11-13 10:05:50|install|libuuid1-32bit|2.21.2-4.5.1|x86_64||repo-update|c94afa212933232dba568fd53c4ec7fbde9167b357ce6f42fac0f220cfa3cf06
    2012-11-13 10:05:50|install|libupower-glib1|0.9.16-2.4.1|x86_64||repo-update|a6beeb30a77c6b47bbffa3fd1266adda2dc01266a6f6730cce8dcfc6e0c8f88d
    2012-11-13 10:05:50|install|libuuid1|2.21.2-4.5.1|x86_64||repo-update|1fd1316033264aae69d8b69f09973baa0065f8bec26c8758828c75ea2b254ed2
    # 2012-11-13 10:05:55 subversion-1.7.7-4.4.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/svnserve...
    # redirecting to systemctl
    #
    2012-11-13 10:05:55|install|subversion|1.7.7-4.4.1|x86_64||repo-update|0ea988193c01237a6bded134a33d070d0540f72b5485f5da8321b478b307af07
    2012-11-13 10:06:05|install|upower|0.9.16-2.4.1|x86_64||repo-update|8ee4a4c377608fe82f73c08af81f5ddb64c3c47eb4d36edfda69dcf82056b916
    2012-11-13 10:06:06|install|libblkid1|2.21.2-4.5.1|x86_64||repo-update|3447d8b7ea643ad5b273a75e46363596ae6ad53a77609f21c98df866cb7d35af
    2012-11-13 10:06:07|install|subversion-perl|1.7.7-4.4.1|x86_64||repo-update|8957af318e54ec496f331b7d65f5a2d6648518427fda1ef0572158d575250d97
    2012-11-13 10:06:08|install|libmount1|2.21.2-4.5.1|x86_64||repo-update|69c7dfdf34808d697bec3e5a6e615624ab6a5ace9ec291e79cbbb5944ccea465
    # 2012-11-13 10:06:10 util-linux-2.21.2-4.5.1.x86_64.rpm installed ok
    # Additional rpm output:
    # setting /usr/bin/wall to root:tty 2755. (wrong permissions 0755)
    # setting /usr/bin/write to root:tty 2755. (wrong permissions 0755)
    #
    2012-11-13 10:06:10|install|util-linux|2.21.2-4.5.1|x86_64||repo-update|fb3a5a297dd1bc2022324aaa8f0e5435e4d8ccd442525affa39de405189e587e
    # 2012-11-13 10:06:11 aaa_base-12.2-2.14.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/language...
    # Updating /etc/sysconfig/backup...
    # Updating /etc/sysconfig/boot...
    # Updating /etc/sysconfig/suseconfig...
    # Updating /etc/sysconfig/clock...
    # Updating /etc/sysconfig/proxy...
    # Updating /etc/sysconfig/windowmanager...
    # Updating /etc/sysconfig/cron...
    # Updating /etc/sysconfig/news...
    # Updating /etc/sysconfig/shutdown...
    # Updating etc/passwd...unchanged
    # Updating etc/group...unchanged
    # Updating etc/shadow...unchanged
    Notice the Updating windowmanager bit.

    How can I roll back these changes or at least see what the problems are exactly?
    I have looked at Xorg.0.log but it seems normal (newbie assessment).
    Of course I have shut down and rebooted several times but that failed to magically fix anything.


    Any Ideas?

  2. #2
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: Window Manager not Running -- Help Fix Please

    Do you save your session at log off (it is the default setting) ? If yes, then rebooting won't help, but try this in a terminal
    Code:
    kwin --replace
    Just a guess though, I'm not sure if it's going to help at all (or if you haven't tried it already).

  3. #3
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Window Manager not Running -- Help Fix Please

    Thanks for reply billypap,

    That command returns an error >> kwin can not find shared library libkwineffects.so.1

    Now this makes me think, hmmm, I went on a big Wine (folders etc...) killing spree, so I could re-install Wine the MS emulator from scratch. I wonder if I accidentally wiped out some important folder/file. I remember deleting a wine folder under /root (not good I know).

    Does anyone know if I can re-install kde-workplace OR if this is even related?

    I am running from the icewm for now until someone smarter than me can advise.

  4. #4
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: Window Manager not Running -- Help Fix Please

    I'm not sure about wine, but indeed deleting files like that doesn't sound good.

    The missing file is part of the 'kwin' package, so after all your comments I suggest a full reinstall of the package.

    See if that helps.

  5. #5
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Window Manager not Running -- Help Fix Please

    Quote Originally Posted by billypap View Post
    I'm not sure about wine, but indeed deleting files like that doesn't sound good.

    The missing file is part of the 'kwin' package, so after all your comments I suggest a full reinstall of the package.

    See if that helps.

    Yes, that did it. Thank you so much .

    Now I wonder what else I zapped by accident. It was weird though because zypper and Yast kept leaving bits of an older version of Wine around and it was causing some problems. Normally I don't go Rooting around like that.

    Thanks again.

  6. #6
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: Window Manager not Running -- Help Fix Please

    Well at least if a problem comes up again, you'll have a first guess to begin with

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Window Manager not Running -- Help Fix Please

    Nice you have a solution.

    But please, next time when you copy/paste computer text in a post (as you did in your first post above), put it between CODE tags by using the # button and not between QUOTE tags. Quote tags are for quoting human stories.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •