Results 1 to 9 of 9

Thread: SSH Access Denied from Windows using PuTTY

  1. #1

    Default SSH Access Denied from Windows using PuTTY

    Sorry for the newbie post - first time poster, long time reader....

    I recently installed SUSE 12.2 x64 on a new machine with the default configuration. After installation, I am able to ssh to the new box from another linux box without problem (all is well). However, when I try to use PuTTY on Windows and ssh to the new SUSE box, I receive the following error in PuTTY:
    Using username "myusername".
    Using keyboard-interactive authentication.
    Password:
    Access denied
    Using keyboard-interactive authentication.
    Password:

    When I check /var/log/message I see the following:
    sshd : error : PAM : authentication failure for myusername from xxx.xxx.xxx.xxx

    It seems strange to me that ssh would work from other linux boxes and not from windows boxes (I even tried from an iPad with the same result as using PuTTY).


    All boxes are connected through a network switch (TRENDnet Gigabit Switch TEG-S240TX) which is then connected to my DSL box (ActionTech M1000).

    I have been searching the web for similar posts and working on a resolution for several days now...

    Any comments would be greatly appreciated.

    Thanks in advance!!

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SSH Access Denied from Windows using PuTTY

    On 2012-11-11 04:36, AzDiver wrote:
    > Any comments would be greatly appreciated.


    If I recall correctly, I had the same problem, not solved. I'm not sure
    if it was putty or winscp which fails.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  3. #3
    Join Date
    Sep 2012
    Posts
    4,977

    Default Re: SSH Access Denied from Windows using PuTTY

    Which PuTTY version? I remember seeing this with relatively old PuTTY and relatively new Linux (or rather OpenSSH) versions. With current PuTTY I never have seen it so far.

  4. #4

    Default Re: SSH Access Denied from Windows using PuTTY

    Carlos,

    Thanks for the reply!! I'm not so sure the problem is related to the ssh client. I have used several ssh clients; all with the same result.

    I think the PAM authentication error is pointing towards the real issue?? I have been blindly trying different things:
    1. Adding "auth required pam_access.so" to /etc/pam.d/sshd and then appending "+ : ALL : ALL" to /etc/security/access.conf

    So far - no dice!!

    Any ideas??

    Thanks again...

  5. #5

    Default Re: SSH Access Denied from Windows using PuTTY

    Quote Originally Posted by arvidjaar View Post
    Which PuTTY version? I remember seeing this with relatively old PuTTY and relatively new Linux (or rather OpenSSH) versions. With current PuTTY I never have seen it so far.
    I'm using PuTTY Release 0.62 from putty.org. I just downloaded and installed it this week. Seems like the release number is pretty low ???

    As mentioned to Carlos, I have tried other ssh clients; one from BitVise on Windows7, another on the iPad (don't remember the name).

    Any suggestions on which Windows ssh client I should be using??

    Thanks again,
    Dave

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: SSH Access Denied from Windows using PuTTY

    Am 11.11.2012 07:26, schrieb AzDiver:
    > I'm not so sure the problem is related to the
    > ssh client. I have used several ssh clients; all with the same result.


    I doubt that it is the client. For testing I downloaded putty 0.62 to a
    Win7 Prof. and can without problem log into my PC and my laptop (both
    openSUSE 12.2).
    Other than that feedback I am afraid to be of no help.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  7. #7
    dd NNTP User

    Default Re: SSH Access Denied from Windows using PuTTY

    On 11/11/2012 04:36 AM, AzDiver wrote:
    >
    > sshd : error : PAM : authentication failure for myusername from


    make absolutely certain that the password you set on the linux machine
    is the _same_ as the password your window's client is sending..

    that is, neither "PASSWORD" nor "PåssWõrd" nor "password" being
    _actually_ sent from the windows client will unlock linux if "PassWord"
    is the actually expected pass phrase..

    so, you have to make sure the combo of your keyboard setting and Windows
    system's character encoding/code page selection is passing the *exactly*
    same character to Linux as you told linux to expect..

    and, there are some characters which are not 'legal' in a
    password...don't use any of those.. (no, i don't know for sure what may
    be 'legal' in linux but may be blocked as illegal in the windows client,
    or vice versa)

    you can easy check for all of that by making a very simple *temporary*
    password on the linux side and see if you get in then, from windows..

    --
    dd http://tinyurl.com/DD-Caveat

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SSH Access Denied from Windows using PuTTY

    On 2012-11-11 07:26, AzDiver wrote:
    > Thanks for the reply!! I'm not so sure the problem is related to the
    > ssh client. I have used several ssh clients; all with the same result.


    Well, my laptop double boots with Linux and Windows. With linux I could
    login, with Windows not. What changed was the client...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  9. #9
    Ian Gay NNTP User

    Default Re: SSH Access Denied from Windows using PuTTY

    AzDiver wrote:

    >
    > Carlos,
    >
    > Thanks for the reply!! I'm not so sure the problem is related to the
    > ssh client. I have used several ssh clients; all with the same
    > result.
    >
    > I think the PAM authentication error is pointing towards the real
    > issue?? I have been blindly trying different things:
    > 1. Adding "auth required pam_access.so" to /etc/pam.d/sshd and then
    > appending "+ : ALL : ALL" to /etc/security/access.conf
    >
    > So far - no dice!!
    >
    > Any ideas??
    >
    > Thanks again...
    >
    >

    Putty 0.60 running on XP connects to my OpenSuse 11.4 with no problems
    at all.

    --
    *********** To reply by e-mail, make w single in address **************

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •