Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Kernel Modules: <not available>

  1. #1

    Default Kernel Modules: <not available>

    Kernel Modules: <not available>
    Could not find map /boot/System.map, please specify a correct file with -M.
    There was an error generating the initrd (9)


    I'm scared to reboot my laptop. Is there anything I can try to repair?


    Code:
    The following package is going to be upgraded:
      kernel-desktop 
    
    1 package to upgrade.
    Overall download size: 40.4 MiB. After the operation, additional 3.2 KiB will be used.
    Continue? [y/n/?] (y): y
    Retrieving package kernel-desktop-3.6.6-1.1.x86_64        (1/1),  40.4 MiB (153.7 MiB unpacked)
    Retrieving: kernel-desktop-3.6.6-1.1.x86_64.rpm ...........................[done (609.8 KiB/s)]
    Installing: kernel-desktop-3.6.6-1.1 ....................................................[done]
    Additional rpm output:
    
    Kernel image:   /boot/vmlinuz-3.6.6-1-desktop
    Initrd image:   /boot/initrd-3.6.6-1-desktop
    Kernel Modules: <not available>
    Could not find map /boot/System.map, please specify a correct file with -M.
    There was an error generating the initrd (9)

  2. #2

    Default Re: Kernel Modules: <not available>

    Forgot to add that I have a System.map-3.6.6-1-desktop file in my /boot folder.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,255

    Default Re: Kernel Modules: <not available>

    Quote Originally Posted by Static2k View Post
    Forgot to add that I have a System.map-3.6.6-1-desktop file in my /boot folder.
    And you forgot to add what version of openSUSE you are using.
    And you forgot to add when/where you get this.
    Henk van Velden

  4. #4

    Default Re: Kernel Modules: <not available>


  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Kernel Modules: <not available>

    Quote Originally Posted by Static2k View Post
    As long as you have more than one kernel, just don't select the newest one. In openSUSE 12.2, select the advanced menu and pick any other installed kernels version that you got. Further, you can get kernel 3.6.6 source file from here: http://www.kernel.org/pub/linux/kern...-3.6.6.tar.bz2 and then compile it using this: S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.78 - Blogs - openSUSE Forums and if we can assume there is nothing wrong with your ability to create the right initrd, you should get the right map file that you seek.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: Kernel Modules: <not available>

    Quote Originally Posted by jdmcdaniel3 View Post
    As long as you have more than one kernel, just don't select the newest one. In openSUSE 12.2, select the advanced menu and pick any other installed kernels version that you got. Further, you can get kernel 3.6.6 source file from here: http://www.kernel.org/pub/linux/kern...-3.6.6.tar.bz2 and then compile it using this: S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.78 - Blogs - openSUSE Forums and if we can assume there is nothing wrong with your ability to create the right initrd, you should get the right map file that you seek.

    Thank You,
    Thanks, I don't have more than 1 kernel I disabled having multiples =/. Can I still proceed to the automated compiler?

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Kernel Modules: <not available>

    Quote Originally Posted by Static2k View Post
    Thanks, I don't have more than 1 kernel I disabled having multiples =/. Can I still proceed to the automated compiler?
    Yes, you can compile and install a new kernel using SAKC and it does not mess with any kernels installed using YaST. I would surely give SAKC a try and then Grub 2 should have more than one kernel to select from. You could also install my Grub 2 utility before you try to reboot to actually look at your grub 2 menu:

    GNU Grub2 Command Help/Config Editor - Version: 1.85 - Blogs - openSUSE Forums

    You can also use FastBoot to see what kernel version you have installed without electing to reboot:

    FastBoot for Grub 2 or Grub Legacy Menu using Kexec - Version 2.13 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8
    Join Date
    Sep 2012
    Posts
    5,186

    Default Re: Kernel Modules: <not available>

    Quote Originally Posted by Static2k View Post
    Code:
    Kernel Modules: <not available>
    Could not find map /boot/System.map, please specify a correct file with -M.
    There was an error generating the initrd (9)
    Did you update mkinitrd from Kernel:stable? It does not work on 12.2 and below due to changed path to /sbin/get_kernel_version. As workaround use "ln -s /sbin/get_kernel_version /usr/bin"

  9. #9

    Default Re: Kernel Modules: <not available>

    Quote Originally Posted by arvidjaar View Post
    Did you update mkinitrd from Kernel:stable? It does not work on 12.2 and below due to changed path to /sbin/get_kernel_version. As workaround use "ln -s /sbin/get_kernel_version /usr/bin"
    Yes =/. Why is mkinitrd released on a stable repository if it does not work?

  10. #10

    Default Re: Kernel Modules: <not available>

    On Thu, 08 Nov 2012 08:56:01 GMT Static2k wrote:

    > Yes =/. Why is mkinitrd released on a stable repository if it does not
    > work?


    From my past experience for i686 the only stable thing is the name of
    the repo.


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •