Results 1 to 6 of 6

Thread: Default email Service - How to make it work?

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Default email Service - How to make it work?

    I am recently upgraded to 12.2/KDE 4.9.3

    I am once again trying to make the Dolphin Service "Send as Email Attachment" work; I have never been able to succeed in recent past.

    When one has a folder view open in Dolphin, right clicking on a file and selecting "Action" offers up a menu of services that includes "Send as an Email Attachment"

    I have Opened SystemSettings-DefaultApplications-Email Client and selected the Use different email client: where I selected thunderbird from the Internet menu; "thunderbird %u" is entered in the command field. I Selected Apply and exited SystemSettings
    I logged out and logged back in, just to be sure.

    Thunderbird runs fine from the desktop folder. Kmail is loaded on the system but I never use it.

    However, right clicking a file in Dolphin and selecting Actions-Send as an Email attachment" still opens Kmail.

    Is there a secret to this, or is it just a bug?
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,653
    Blog Entries
    14

    Default Re: Default email Service - How to make it work?

    I can confirm this behaviour. Using kmail myself, but I changed the mailclient to Opera, and nothing changes. IMHO this is a bug.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Default email Service - How to make it work?

    Quote Originally Posted by Knurpht View Post
    I can confirm this behaviour. Using kmail myself, but I changed the mailclient to Opera, and nothing changes. IMHO this is a bug.
    What do you think - openSUSE bug or straight to KDE?

    I'll gather more complete info and log one

    First, I'll try uninstalling Kmail, since I don't use it not a major impact to my system.
    Perhaps that will shake something loose
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Default email Service - How to make it work?

    Ah so, interesting.
    I removed Kmail from my system with YAST-Software management and the Attach to Email service disappeared from Dolphin.
    I guess that service is hard wired to Kmail.

    So I opened Dolphin-Control-Configure Dolphin-Services and Searched Download New Services.
    There is a downloadable for "attach file to Thunderbird"
    Installed and works!

    I note that setting Thunderbird as the default mail client DOES work with mailto: URLs in Firefiox,
    so this is probably not a bug.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5
    josephkk NNTP User

    Default Re: Default email Service - How to make it work?

    On Thu, 08 Nov 2012 01:36:01 GMT, cmcgrath5035
    <cmcgrath5035@no-mx.forums.opensuse.org> wrote:

    >
    >Ah so, interesting.
    >I removed Kmail from my system with YAST-Software management and the
    >Attach to Email service disappeared from Dolphin.
    >I guess that service is hard wired to Kmail.
    >
    >So I opened Dolphin-Control-Configure Dolphin-Services and Searched
    >Download New Services.
    >There is a downloadable for "attach file to Thunderbird"
    >Installed and works!
    >
    >I note that setting Thunderbird as the default mail client DOES work
    >with mailto: URLs in Firefiox,
    >so this is probably not a bug.


    The KDE folks need a spanking for displaying something that doesn't work
    and hiding what does work. That is not the Linux way.

    ?-/

  6. #6

    Default Re: Default email Service - How to make it work?

    Quote Originally Posted by cmcgrath5035 View Post
    So I opened Dolphin-Control-Configure Dolphin-Services and Searched Download New Services.
    There is a downloadable for "attach file to Thunderbird"
    Installed and works!
    Thanks. Unfortunately, the "install" didn't work for me -- reports as being installed but it was neither in the context menu, nor was the file to be found in ~/.kde4/share/kde4/services

    Where did it go me wonders? Fortunately google had an answer (from an not too unfamiliar place): http://forums.opensuse.org/english/g...ces-menus.html

    Works now. I followed the instructions (from clicking on the details button for the "Attach-to-Thunderbird" service) for adding the icon ... but its not showing up yet ... perhaps a logout-login will resolve that little detail.. not too worried if it doesn't

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •