Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: My apper is definitly broken :(

  1. #1
    Join Date
    Apr 2011
    Location
    Secunda, South Africa
    Posts
    80

    Default My apper is definitly broken :(

    Now matter how long (hours) with good network connection I keep apper open to check for updates it stays on this screen all the time:


    snapshot1 by georgelappies, on Flickr

    Is there a way to reinstall / reset configs / clear cache for apper so it will actually work again?

    I am an 12.2 64 bit

  2. #2
    dd NNTP User

    Default Re: My apper is definitly broken :(

    On 11/07/2012 11:46 AM, georgelappies wrote:
    >
    > Now matter how long (hours) with good network connection I keep apper
    > open to check for updates it stays on this screen all the time:
    >
    > '[image:
    > http://farm9.staticflickr.com/8201/8...3f26d18_z.jpg]'
    > (http://www.flickr.com/photos/79382089@N03/8163597457/)
    > 'snapshot1' (http://www.flickr.com/photos/79382089@N03/8163597457/) by
    > 'georgelappies' (http://www.flickr.com/people/79382089@N03/), on Flickr
    >
    > Is there a way to reinstall / reset configs / clear cache for apper so
    > it will actually work again?
    >
    > I am an 12.2 64 bit
    >
    >


    use YaST Software Management: search on apper and mark it for
    reinstall...then try it...if it does not, there is a person around here
    who promises apper works great on 12.2...so, you can check back and see
    when he comes, maybe he will tell you how to fix it..

    i'll tell you how to live with it:

    -don't use it

    -right click on its icon and disable it

    -use YaST Online Updater to fetch/install security patches

    -use YaST Software Management to install new, or uninstall current
    applications/software

    by disabling apper you will no longer receive a notice that new software
    is waiting to be installed....therefore, every so often run YaST Online
    updater....i run it everyday, some folks say once a week is enough..

    --
    dd

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: My apper is definitly broken :(

    On 2012-11-07 11:46, georgelappies wrote:
    >
    > Now matter how long (hours) with good network connection I keep apper
    > open to check for updates it stays on this screen all the time:


    I can not look at the photo, I have a 500 Mb/month cap. Tell me what it
    says.

    Typically apper stalls the first time, I don't know if until after the
    reboot or the first update. So kill it, or configure your desktop not to
    initiate it, log out, log in, and then initiate YOU (yast online update)
    to do that first update.

    If the photo indicates some type of error, tell which. Please :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  4. #4
    dd NNTP User

    Default Re: My apper is definitly broken :(

    On 11/07/2012 12:34 PM, Carlos E. R. wrote:
    > If the photo indicates some type of error, tell which. Please


    just shows an Apper "Refreshing package cache" progress bar with
    "Waiting for other tasks" over it..

    press the Cancel button, disable apper..

    --
    dd

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: My apper is definitly broken :(

    I have not seen that refreshing the cache forever myself so I can only
    guess. Where to start?
    I would open a terminal and do a "zypper refresh" as root, if it tells
    you that packagekit is blocking it cancel it and it should show you the
    id of the blocking process, kill that process and repeat the "zypper
    refresh".
    When it runs through does the refresh show you any warnings or errors?
    That at least would give some clue.
    After that refresh by zypper was done restart apper and check for
    updates - what happens?

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.2 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  6. #6
    Join Date
    Apr 2011
    Location
    Secunda, South Africa
    Posts
    80

    Default Re: My apper is definitly broken :(

    Quote Originally Posted by martin_helm View Post
    I have not seen that refreshing the cache forever myself so I can only
    guess. Where to start?
    I would open a terminal and do a "zypper refresh" as root, if it tells
    you that packagekit is blocking it cancel it and it should show you the
    id of the blocking process, kill that process and repeat the "zypper
    refresh".
    When it runs through does the refresh show you any warnings or errors?
    That at least would give some clue.
    After that refresh by zypper was done restart apper and check for
    updates - what happens?

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.2 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server
    Hi, ok here is the command line output of the 'zypper refresh'

    Code:
    devbox:~ # zypper refresh
    Repository '12.2' is up to date.
    Repository '12.2' is up to date.
    Repository 'AMD/ATI-FGLRX' is up to date.
    Repository 'Packman Repository' is up to date.
    Repository 'libdvdcss repository' is up to date.
    Repository 'openSUSE-12.2-Addon-NonOss' is up to date.
    Repository 'openSUSE-12.2-DVD-x86_64' is up to date.
    Retrieving repository 'openSUSE_12.2' metadata ...........................[done]
    Building repository 'openSUSE_12.2' cache ................................[done]
    Repository 'openSUSE-12.2-Non-Oss' is up to date.
    Repository 'openSUSE-12.2-Oss' is up to date.
    Repository 'openSUSE-12.2-Source' is up to date.
    Repository 'openSUSE-12.2-Update' is up to date.
    Repository 'openSUSE-12.2-Update-Non-Oss' is up to date.
    All repositories have been refreshed.
    devbox:~ #
    But apper still does the same... Think I will just uninstall it and use YaST for updates.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: My apper is definitly broken :(

    On 2012-11-07 15:56, georgelappies wrote:
    > Hi, ok here is the command line output of the 'zypper refresh'
    >
    >
    > Code:
    > --------------------
    >
    > devbox:~ # zypper refresh
    > Repository '12.2' is up to date.
    > Repository '12.2' is up to date.
    > Repository 'AMD/ATI-FGLRX' is up to date.
    > Repository 'Packman Repository' is up to date.
    > Repository 'libdvdcss repository' is up to date.
    > Repository 'openSUSE-12.2-Addon-NonOss' is up to date.
    > Repository 'openSUSE-12.2-DVD-x86_64' is up to date.
    > Retrieving repository 'openSUSE_12.2' metadata ...........................[done]
    > Building repository 'openSUSE_12.2' cache ................................[done]
    > Repository 'openSUSE-12.2-Non-Oss' is up to date.
    > Repository 'openSUSE-12.2-Oss' is up to date.
    > Repository 'openSUSE-12.2-Source' is up to date.
    > Repository 'openSUSE-12.2-Update' is up to date.
    > Repository 'openSUSE-12.2-Update-Non-Oss' is up to date.
    > All repositories have been refreshed.
    > devbox:~ #
    >
    > --------------------


    At this point, do "zypper patch".

    > But apper still does the same... Think I will just uninstall it and use
    > YaST for updates.


    Wait.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: My apper is definitly broken :(

    Or use zypper for updates if you don't care about a fancy gui

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: My apper is definitly broken :(

    Am 07.11.2012 16:01, schrieb Martin Helm:
    > Or use zypper for updates if you don't care about a fancy gui
    >

    Ok, more to the point, I doubt somehow it is an apper (frontend problem)
    but sounds a bit like packagekit (backend) has a problem refreshing.
    There is a command line tool for that
    Code:
    pkcon -v refresh
    refreshes (you have to run that as NORMAL user, you MUST NOT run that as
    root!!!) from the command line the packagekit cache.
    The -v will give you more detailed debug output, may help to diagnose
    what your problem is.

    The refresh option also takes a --force (though I do not know exactly
    what that does).

    Here is an example output from my machine where it went well
    Code:
    martinh@ganymed:~> pkcon -v refresh
    16:08:03        PackageKit          Verbose debugging enabled (on console 1)
    16:08:03        PackageKit          notify::connected
    16:08:03        PackageKit          notify::connected
    16:08:03        PackageKit          filter=(null), filters=0
    16:08:03        PackageKit          adding state 0x22018b0
    16:08:03        PackageKit          role now refresh-cache
    Zwischenspeicher wird aktualisiert[                         ] (0%)
    16:08:03    PackageKit          role now unknown
    [=========================]
    Warten in Warteschlange       [=========================]
    Warten auf Legitimierung      [=========================]
    Warten in Warteschlange       [                         ] (0%)  16:08:03
    PackageKit          emit transaction-list-changed
    [=========================]
    Starten                       [=========================]
    Software-Liste wird aktualisiert[=========================]
    16:09:07    PackageKit          remove state 0x22018b0
    [=========================]
    martinh@ganymed:~>
    ignore the german parts its just to illustrate what to expect.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  10. #10
    Join Date
    Apr 2011
    Location
    Secunda, South Africa
    Posts
    80

    Default Re: My apper is definitly broken :(

    Quote Originally Posted by martin_helm View Post
    Or use zypper for updates if you don't care about a fancy gui

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server
    What exactly would the proper command be to use for zypper? Will it obey the fact that I set for instance pakman and KDE49 as the system repo's?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •