Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Oracle VM Virtualbox errors

  1. #1
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Oracle VM Virtualbox errors

    I need help with the following output:

    wellywu@linux-pn0z:~> sudo su -
    root's password:
    linux-pn0z:~ # /etc/init.d/vboxdrv setup
    Stopping VirtualBox kernel modules done
    Uninstalling old VirtualBox DKMS kernel modules done
    Trying to register the VirtualBox kernel modules using DKMS
    Error! Your kernel headers for kernel 3.6.5-10-desktop cannot be found at
    /lib/modules/3.6.5-10-desktop/build or /lib/modules/3.6.5-10-desktop/source.
    failed
    (Failed, trying without DKMS)
    Recompiling VirtualBox kernel modules failed
    (Look at /var/log/vbox-install.log to find out what went wrong)
    linux-pn0z:~ # zypper install kernel-headers
    Loading repository data...
    Reading installed packages...
    'kernel-headers' not found in package names. Trying capabilities.
    'linux-glibc-devel' providing 'kernel-headers' is already installed.
    Resolving package dependencies...

    Nothing to do.
    linux-pn0z:~ # zypper update
    Loading repository data...
    Reading installed packages...

    The following package updates will NOT be installed:
    gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good
    gstreamer-0_10-plugins-ugly k3b kernel-default-base kernel-default-devel kernel-desktop-devel
    kernel-devel kernel-source kernel-syms kfilebox libxine2-pulse

    Nothing to do.
    linux-pn0z:~ # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    Problem: nothing provides kdebase4-runtime >= 4.9.3 needed by kfilebox-0.4.9-1.6.i586
    Solution 1: keep obsolete kfilebox-0.4.9-1.5.x86_64
    Solution 2: break kfilebox-0.4.9-1.6.i586 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Computing distribution upgrade...

    The following packages are going to be downgraded:
    kernel-default-devel kernel-desktop-devel kernel-devel kernel-source kernel-syms kernel-xen-devel
    libx264-128

    The following packages are going to change vendor:
    kernel-default-devel obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    kernel-desktop-devel obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    kernel-devel obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    kernel-source obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    kernel-syms obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    kernel-xen-devel obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE


    7 packages to downgrade, 6 to change vendor.
    Overall download size: 78.7 MiB. After the operation, 15.5 MiB will be freed.
    Continue? [y/n/?] (y): n
    linux-pn0z:~ # ^C
    linux-pn0z:~ # zypper install linux-headers-$(uname -r)
    Loading repository data...
    Reading installed packages...
    'linux-headers-3.6.5-10-desktop' not found in package names. Trying capabilities.
    No provider of 'linux-headers-3.6.5-10-desktop' found.
    Resolving package dependencies...

    Nothing to do.
    linux-pn0z:~ # zypper install kernel-headers kernel-devel gcc
    Loading repository data...
    Reading installed packages...
    'gcc' is already installed.
    No update candidate for 'gcc-4.7-2.1.1.x86_64'. The highest available version is already installed.
    'kernel-headers' not found in package names. Trying capabilities.
    'linux-glibc-devel' providing 'kernel-headers' is already installed.
    Resolving package dependencies...

    Problem: nothing provides kernel-xen-devel = 3.6.5-10 needed by kernel-syms-3.6.5-10.1.x86_64
    Solution 1: Following actions will be done:
    deinstallation of kernel-syms-3.6.4-9.1.x86_64
    deinstallation of kernel-xen-devel-3.6.4-9.1.x86_64
    Solution 2: do not install kernel-devel-3.6.5-10.1.noarch
    Solution 3: break kernel-syms-3.6.5-10.1.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/3/c] (c): c
    linux-pn0z:~ #



    What do I need to do in order to get Oracle VM Virtualbox to work properly again?

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Oracle VM Virtualbox errors

    First, what version of openSUSE are you using? You seem to have mixed Tumbleweed with another release, and that will lead to more problems. Show the output of

    Code:
    zypper lr -d

  3. #3
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    wellywu@linux-pn0z:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------------------+--------
    1 | KDE_SC_4.9_Core | KDE SC 4.9 Core | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Release:/49/openSUSE_12.2 |
    2 | KDE_SC_4.9_Extra | KDE SC 4.9 Extra | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_49_openSUSE_12.2 |
    3 | OpenSUSE_Current_OSS | OpenSUSE Current OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/oss |
    4 | OpenSUSE_Current_Updates | OpenSUSE Current Updates | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-current |
    5 | OpenSUSE_Current_non-OSS | OpenSUSE Current non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/non-oss |
    6 | OpenSUSE_non-OSS-current_Tumbleweed | OpenSUSE non-OSS-current | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-non-oss-current |
    7 | Oracle_VM_Virtualbox_OpenSuSE | Oracle VM Virtualbox OpenSuSE | Yes | Yes | 99 | rpm-md | Index of /virtualbox/rpm/opensuse/11.4/ |
    8 | Packman_Tumbleweed | Packman Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_Tumbleweed/ |
    9 | Realtek_Drivers | Realtek Drivers | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/malcolmlewis:/realtek_drivers/openSUSE_Tumbleweed |
    10 | X11:QtDesktop | X11:QtDesktop | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop/openSUSE_Tumbleweed |
    11 | X11:QtDesktop:trunk | X11:QtDesktop:trunk | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop:/trunk/openSUSE_Tumbleweed |
    12 | google-earth | google-earth | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64 |
    13 | isv:heinlein-support | isv:heinlein-support | Yes | Yes | 99 | rpm-md | Index of /repositories/isv:/heinlein-support/openSUSE_Tumbleweed |
    14 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.2/ |
    15 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | No | Yes | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208AB_R8JT6GFC400NYX,/dev/sr0 |
    16 | openSUSE:Tumbleweed | openSUSE:Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Tumbleweed/standard |
    wellywu@linux-pn0z:~>

  4. #4
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    Did I mix up Tumbleweed with another software repository or not? It looks like libdvdcss is version 12.2. I'm not sure about the others. I was very careful to read, re-read, and follow the exact guidelines for switching to Tumbleweed from OpenSuSE 64 bit 12.2. I might have made a small mistake, but I doubt it.

  5. #5
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Oracle VM Virtualbox errors

    What's openSUSE current? Are those the tumbleweed repos? From your first post,

    Code:
    The following packages are going to change vendor:
      kernel-default-devel  obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
      kernel-desktop-devel  obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
      kernel-devel          obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
      kernel-source         obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
      kernel-syms           obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
      kernel-xen-devel      obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE
    it looks like you kernel sources switched from tumbleweed to one of the standard repositories, but I can't see any in your repos. Can anyone else see what this "openSUSE" vendor is?

  6. #6
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    I canceled that zypper dup command. It would have reverted me from Linux kernel 3.6.5-10-desktop to 3.4.x. I did not change vendors.

  7. #7

    Default Re: Oracle VM Virtualbox errors

    On 11/03/2012 09:26 PM, wellywu pecked at the keyboard and wrote:
    > I canceled that zypper dup command. It would have reverted me from Linux
    > kernel 3.6.5-10-desktop to 3.4.x. I did not change vendors.


    If you are going to use Tumbleweed it is highly recommended to only use
    openSUSE-current repos, packman-tumbleweed and tumbleweed. The use of
    any other repos could lead to an unstable/unbootable system.


  8. #8
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    Okay, so I disabled some software repositories like Razor-QT, Google Earth, etc. This is what my software repositories looks like now:

    linux-pn0z:~ # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------------------+--------
    1 | KDE_SC_4.9_Core | KDE SC 4.9 Core | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Release:/49/openSUSE_12.2 |
    2 | KDE_SC_4.9_Extra | KDE SC 4.9 Extra | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_49_openSUSE_12.2 |
    3 | OpenSUSE_Current_OSS | OpenSUSE Current OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/oss |
    4 | OpenSUSE_Current_Updates | OpenSUSE Current Updates | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-current |
    5 | OpenSUSE_Current_non-OSS | OpenSUSE Current non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/non-oss |
    6 | OpenSUSE_non-OSS-current_Tumbleweed | OpenSUSE non-OSS-current | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-non-oss-current |
    7 | Oracle_VM_Virtualbox_OpenSuSE | Oracle VM Virtualbox OpenSuSE | Yes | Yes | 99 | rpm-md | Index of /virtualbox/rpm/opensuse/11.4/ |
    8 | Packman_Tumbleweed | Packman Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_Tumbleweed/ |
    9 | Realtek_Drivers | Realtek Drivers | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/malcolmlewis:/realtek_drivers/openSUSE_Tumbleweed |
    10 | X11:QtDesktop | X11:QtDesktop | No | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop/openSUSE_Tumbleweed |
    11 | X11:QtDesktop:trunk | X11:QtDesktop:trunk | No | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop:/trunk/openSUSE_Tumbleweed |
    12 | google-earth | google-earth | No | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64 |
    13 | isv:heinlein-support | isv:heinlein-support | Yes | Yes | 99 | rpm-md | Index of /repositories/isv:/heinlein-support/openSUSE_Tumbleweed |
    14 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.2/ |
    15 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | No | Yes | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208AB_R8JT6GFC400NYX,/dev/sr0 |
    16 | openSUSE:Tumbleweed | openSUSE:Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Tumbleweed/standard |
    linux-pn0z:~ #


    How does it look now?

  9. #9
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    Disregard my previous post. This is the latest current software repository list:

    wellywu@linux-pn0z:~> zypper ls -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI
    ---+-------------------------------------+-------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------------------
    1 | KDE_SC_4.9_Core | KDE SC 4.9 Core | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Release:/49/openSUSE_12.2
    2 | KDE_SC_4.9_Extra | KDE SC 4.9 Extra | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_49_openSUSE_12.2
    3 | OpenSUSE_Current_OSS | OpenSUSE Current OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/oss
    4 | OpenSUSE_Current_Updates | OpenSUSE Current Updates | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-current
    5 | OpenSUSE_Current_non-OSS | OpenSUSE Current non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/openSUSE-current/repo/non-oss
    6 | OpenSUSE_non-OSS-current_Tumbleweed | OpenSUSE non-OSS-current | Yes | Yes | 99 | rpm-md | Index of /update/openSUSE-non-oss-current
    7 | Oracle_VM_Virtualbox_OpenSuSE | Oracle VM Virtualbox OpenSuSE | Yes | Yes | 99 | rpm-md | Index of /virtualbox/rpm/opensuse/11.4/
    8 | Packman_Tumbleweed | Packman Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_Tumbleweed/
    9 | Realtek_Drivers | Realtek Drivers | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/malcolmlewis:/realtek_drivers/openSUSE_Tumbleweed
    10 | X11:QtDesktop | X11:QtDesktop | No | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop/openSUSE_Tumbleweed
    11 | X11:QtDesktop:trunk | X11:QtDesktop:trunk | No | Yes | 99 | rpm-md | Index of /repositories/X11:/QtDesktop:/trunk/openSUSE_Tumbleweed
    12 | google-earth | google-earth | No | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64
    13 | isv:heinlein-support | isv:heinlein-support | Yes | Yes | 99 | rpm-md | Index of /repositories/isv:/heinlein-support/openSUSE_Tumbleweed
    14 | libdvdcss repository | libdvdcss repository | No | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.2/
    15 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | No | Yes | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208AB_R8JT6GFC400NYX,/dev/sr0
    16 | openSUSE:Tumbleweed | openSUSE:Tumbleweed | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Tumbleweed/standard
    wellywu@linux-pn0z:~>

  10. #10
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Oracle VM Virtualbox errors

    How do I get Oracle VM Virtualbox to work properly?

    This is my output:

    wellywu@linux-pn0z:~> sudo su -
    root's password:
    linux-pn0z:~ # /etc/init.d/vboxdrv setup
    Stopping VirtualBox kernel modules done
    Uninstalling old VirtualBox DKMS kernel modules done
    Trying to register the VirtualBox kernel modules using DKMS
    Error! Your kernel headers for kernel 3.6.5-10-desktop cannot be found at
    /lib/modules/3.6.5-10-desktop/build or /lib/modules/3.6.5-10-desktop/source.
    failed
    (Failed, trying without DKMS)
    Recompiling VirtualBox kernel modules failed
    (Look at /var/log/vbox-install.log to find out what went wrong)
    linux-pn0z:~ #

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •