Results 1 to 5 of 5

Thread: touchpad configuration is auto reset to default on ICEWM

  1. #1

    Exclamation touchpad configuration is auto reset to default on ICEWM

    i am using opensuse with different desktop enviroment gnome,kde,icewm etc
    icewm is very efficient so i'm using that
    now the problem is that when i configured touchpad using KDE setting (available on icewm) it works fine till i end the session
    and then it automatically reset it to default (every setting related to the same will set to its default value)
    i googled a lot but icewm is not so popular window manager so i dont get any solution to the problem...
    hope anyone will help me.. thanks

  2. #2

    Default Re: touchpad configuration is auto reset to default on ICEWM

    Quote Originally Posted by khizar91 View Post
    i am using opensuse with different desktop enviroment gnome,kde,icewm etc
    icewm is very efficient so i'm using that
    now the problem is that when i configured touchpad using KDE setting (available on icewm) it works fine till i end the session
    and then it automatically reset it to default (every setting related to the same will set to its default value)
    i googled a lot but icewm is not so popular window manager so i dont get any solution to the problem...
    hope anyone will help me.. thanks
    Hi,
    Try using gsynaptics
    People who do not break things first will never learn to create anything

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: touchpad configuration is auto reset to default on ICEWM

    Are you using "icewm-default" or "icewm-lite"?

    It is "icewm-lite" that is installed by default. If you have not already done so, I suggest installing "icewm-default" (which automatically replaces the "lite" version).

    When I run icewm on an older laptop, I have it start synaptiks in the startup script (in $HOME/.icewm/startup). With that running, the synaptiks settings all hold.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: touchpad configuration is auto reset to default on ICEWM

    Quote Originally Posted by nrickert View Post
    Are you using "icewm-default" or "icewm-lite"?
    It is "icewm-lite" that is installed by default. If you have not already done so, I suggest installing "icewm-default" (which automatically replaces the "lite" version).
    installed icewm-default.. thanks

    Quote Originally Posted by nrickert View Post
    When I run icewm on an older laptop, I have it start synaptiks in the startup script (in $HOME/.icewm/startup). With that running, the synaptiks settings all hold.
    please can you explain me how to do this.. in synaptik config "i just wanted to accelerate the movement of pointer"

    thanks

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: touchpad configuration is auto reset to default on ICEWM

    I have a script $HOME/.icewm/startup
    Code:
    % ls -lL .icewm
    total 40
    -rw-r--r-- 1 rickert users    12 Mar 22  2011 focus_mode
    -rw-r--r-- 1 rickert users 30902 Feb  9  2012 preferences
    -rwxr-xr-x 1 rickert users  1647 Apr  5  2012 startup
    It needs execute permissions.

    I have the following commands in the file:
    Code:
    xterm -title Console -n Console -ls -geom 80x24-0-0 &
    sleep 2
    synaptiks &
    sleep 2
    /usr/lib/polkit-gnome-authentication-agent-1 &
    nm-applet &
    That starts an xterm at the bottom right of the screen. It starts synaptics, the gnome authentication agent, and the gnome networkmanager agent. The gnome authentication agent might be needed by the network manager applet (which is why I start it).

    I put those sleep lines because otherwise the session doesn't always start properly. I'm not sure why, but the sleep works around it.

    Once up and running, there is an icon for synaptiks in the panel (near the bottom of the screen - I have it set to auto-hide). Right clicking on the synaptiks icon gets me to the settings menu. And I can use the network-manager applet for managing wifi.

    I hope that helps.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •