Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: I really really hate packagekitd

  1. #11
    dd NNTP User

    Default Re: I really really hate packagekitd

    On 11/01/2012 12:26 PM, solanum wrote:
    > I was wondering about disabling it without uninstall (ie
    > temporarily), obviously I wasn't clear enough.


    right click in its icon in the tray and select disable ??

    that worked on _my_ KDE, but you didn't say what DE is in use by "I am
    not an idiot"..

    --
    dd

  2. #12
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: I really really hate packagekitd

    Quote Originally Posted by nrickert View Post
    I set "apper" to not automatically start (in KDE). That's at "Configure Desktop" ..> "Startup and Shutdown" --> "Service Manager"
    Depends how you install eg. from livecd, one of two ways gives "System Settings" > etc...

  3. #13
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: I really really hate packagekitd

    Quote Originally Posted by dd View Post
    On 11/01/2012 12:26 PM, solanum wrote:
    > I was wondering about disabling it without uninstall (ie
    > temporarily), obviously I wasn't clear enough.


    right click in its icon in the tray and select disable ??

    that worked on _my_ KDE, but you didn't say what DE is in use by "I am
    not an idiot"..
    And the icon is only in the tray when updates are available [on my default 12.2 KDE].

  4. #14

    Default Re: I really really hate packagekitd

    Quote Originally Posted by dd View Post
    On 11/01/2012 12:26 PM, solanum wrote:
    > I was wondering about disabling it without uninstall (ie
    > temporarily), obviously I wasn't clear enough.


    right click in its icon in the tray and select disable ??

    that worked on _my_ KDE, but you didn't say what DE is in use by "I am
    not an idiot"..

    --
    dd
    Except as noted elsewhere, the icon isn't always there...

    However, I have found it in the Service Manager, where Apper can be disabled (temporarily or permanently), so thanks to the person who suggested that. Hopefully, packagekitd is only locking because of apper and isn't doing it of its own accord...? What happens if packagekitd is locked when you disable it in the service manager... hopefully it doesn't stay locked and it stops immediately?

    But I take it from the other replies that there is no way of configuring it rather than disabling it then?

    For the record, searching the forum here brought up several messages about uninstalling everything and a lot of ranting - going through it again I did find some useful information several pages down a recent thread, but still nothing about configuring Apper (which I now see is the problem as it is calling packagekitd). Also openSUSE 12.2 64 bit stock KDE.

    Oh for the days when everything a configuration file you could edit.... e.g. .apper : update_interval=43200

  5. #15
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: I really really hate packagekitd

    You configure apper in in kde's settings (System Settings / Configure Desktop) > Software Management. The choice of update frequency is usually in a dropdown list.

  6. #16

    Angry Re: I really really hate packagekitd

    Quote Originally Posted by solanum View Post
    Literally 9 times out of ten that I want to install something I cannot because packagekitd is locked. In close to 15 years of using Linux, no other distribution has ever constantly prevented me from installing software so often! Command line or GUI, makes no difference... Kill the daemon and you have a few moments to do something or it restarts

    How often does packagekitd really need to lock?

    So a) can I safely disable packagekitd and if so how?
    Better still, b) can I have packagekitd only do anything, say once every 12 hours?

    Just to make sure that I am not being grumpy about this!
    Hello, new user here.
    I just installed OpenSUSE 12.2 from the KDE 64bit cd iso.
    On any Linux I usually remove any unwanted apps before doing an update to avoid downloading unnecessary amounts of unwanted files.

    After first boot into new system & before doing any system updates I try to remove Firefox : I get waiting for process to finish & cannot proceed because packagekti is running messages from Yast2 & Apper gui.

    I drop to a command line & ask zypper to rm firefox but it wants to remove half the system. WTF??
    Also I get messages about locked etc. Packagekit once again getting in the way.

    After about an hour of fighting I give up & click the apper updater in the task bar, it sits there with a back and forth animation doing...?? nothing??
    Eventually I click update and wait more.. more.. What is it doing?? I see nothing happening.

    I decide to leave it open and go away to do something productive.
    When I return I see apper is .. gone... wtf?
    When I check I see that the system has indeed been finally updated. <sigh..>

    I try again to use Yast2 to perform some simple add/removes of applications and run into this 'packagekit is running ask it to stop?' nonsense (of course asking it to stop does nothing).
    I assume packagekit is running a deamon so i try to use systemd to stop it but come up dry.. there is no daemon to stop of that name. WTF??
    I finally open a terminal and killall packagekit 9.. at last! I can finally do something with my packagemanager..

    I configured Apper checking to 'never'.
    Still same problems.

    I go to another machine and install the 32bit version from OpenSUSE KDE cd iso.
    Exactly the same experience.

    This way WAY suboptimal experience for a new user.

    I know from experience on Fedora systems that packagekit is a big pile of dung so I'm deciding to keep it simple & use zypper/Yast2.

    SO now I go on more time wasting journey through Googling and forum searching try to find out how to kill packagekit with a stake through the heart & excise it from all my OpenSUSE installations permanently. Also get rid of Apper because it is uneeded duplication.

    Guy's reporting its all fine and no problems, you must be very blessed to have not seen this or you're not telling the truth. Hmm?
    So far I like what of see of OpenSUSE otherwise.

    Authoritative advice/corrections is very welcome.
    Flames and vague opinions not needed thanks.

    Chris

  7. #17
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I really really hate packagekitd

    On 2012-11-02 01:46, chris2kari wrote:
    > Authoritative advice/corrections is very welcome.
    > Flames and vague opinions not needed thanks.


    Duplicate post.

    Just to mention that no one here is authoritative, we are just a bunch
    of users helping other users.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  8. #18
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,142

    Default Re: I really really hate packagekitd

    @chris2kari,

    If you have a question of your own, please start a thread of your own. Trying to hang on to someone else's thread is inproductive to both questions. The original thread will be poluted. And your own question will not come to the forefront in the list of new threads with it's own telling title ad thus, most likely, will not be seen by many here.

    I see this is your second try to post the same question hidden deep inside another thread. The result will be insatisfactory to you again I am afraid.

    And before you do so, please read @robin_listas advice and formulate your question in a way that encourages your fellow users to join you in trying to resolve your problem or to answer your question.
    Henk van Velden

  9. #19

    Default Re: I really really hate packagekitd

    Quote Originally Posted by consused View Post
    You configure apper in in kde's settings (System Settings / Configure Desktop) > Software Management. The choice of update frequency is usually in a dropdown list.
    Hi, thanks for that, but I don't see any settings... it starts Apper and you can look at installed/available software or run the updates (plus there are icons for software groups). Maybe I am an idiot afterall, but where can you alter the frequency of checks?

  10. #20

    Default Re: I really really hate packagekitd

    Quote Originally Posted by solanum View Post
    Hi, thanks for that, but I don't see any settings... it starts Apper and you can look at installed/available software or run the updates (plus there are icons for software groups). Maybe I am an idiot afterall, but where can you alter the frequency of checks?
    Sorry, got it! That is seriously well hidden. However, it was already set to daily and packagekitd is blocking nearly all the time, so there is obviously some problem....

    Is there anything else other than apper that could be polling packagekitd?

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •