Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Wine apps don't work anymore on 12.2

  1. #1

    Default Wine apps don't work anymore on 12.2

    Using openSUSE 12.2 x86_64 with GNOME 3.4.

    Applications and games that used to work on Wine (using latest available 1.5.16) practically out of the box now don't work at all and make Wine immediately crash.
    For example, for a game named Limbo I got this:
    SUSE Paste

    On Wine forums I was told that, from the entire console output above, this could be an issue:
    Code:
    err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
    And also probably this:
    Code:
    p11-kit: couldn't load module: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
    I didn't know what Winbind is, so after a search I saw that it's part of Samba. But then what does Samba have to do with the seemingly missing file ntlm_auth?
    And what about that p11-kit error?

    I post here in Applications subforum because it doesn't apply only for games.
    Thansk for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: Wine apps don't work anymore on 12.2

    I don't pretend to know the definitive answer to this, but I note from

    NtlmAuthSetupGuide - The Official Wine Wiki

    To get access to all the features while using NtlmSigningAndSealing, you need an up-to-date version of ntlm_auth. Samba 3.0.26 or later will do. In some distributions, you need to install the "winbind" package to get ntlm_auth.
    If you want client mode NTLM for Wine, e.g. reading your email using Outlook over a connection with NTLM encryption, that's all you need.
    If you need server mode NTLM, you need to make sure winbind works and ntlm_auth has access to the privileged winbind pipe. Please refer to the appropriate Samba documentation for this.
    Try installing the samba-winbind package first.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,845
    Blog Entries
    15

    Default Re: Wine apps don't work anymore on 12.2

    On Wed 31 Oct 2012 11:46:02 PM CDT, F style wrote:


    Using openSUSE 12.2 x86_64 with GNOME 3.4.

    Applications and games that used to work on Wine (using latest
    available 1.5.16) practically out of the box now don't work at all and
    make Wine immediately crash.
    For example, for a game named Limbo I got this:
    'SUSE Paste' (http://paste.opensuse.org/73945012)

    On Wine forums I was told that, from the entire console output above,
    this could be an issue:

    Code:
    --------------------
    err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is
    outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually,
    you can find it in the winbind package of your distribution.
    --------------------

    And also probably this:

    Code:
    --------------------
    p11-kit: couldn't load
    module: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/pkcs11/gnome-keyring-pkcs11.so:
    no se puede abrir el fichero del objeto compartido: No existe el
    fichero o el directorio --------------------


    I didn't know what Winbind is, so after a search I saw that it's part
    of Samba. But then what does Samba have to do with the seemingly missing
    file ntlm_auth?
    And what about that p11-kit error?

    I post here in Applications subforum because it doesn't apply only for
    games.
    Thansk for your help.


    Hi
    Your on x86_64 wine is 32bit, so you need to install the 32bit versions
    eg samba-winbind-32bit 32bit version of gnome-keyring-pkcs11.so doesn't
    exist in 12.2 only 12.1. See how installing the winbind rpm first...

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 3 days 1:22, 4 users, load average: 0.08, 0.13, 0.14
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  4. #4

    Default Re: Wine apps don't work anymore on 12.2

    Installed winbinf 32-bit. Same results, only difference was that the console fragments I first quoted were no more...

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Wine apps don't work anymore on 12.2

    Has the wine version changed since it was working > Now?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Wine apps don't work anymore on 12.2

    Quote Originally Posted by caf4926 View Post
    Has the wine version changed since it was working > Now?
    Well, last time I saw them working was back on 12.1, probably with a 1.4.xx or an early 1.5.x version. So, a few months ago.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Wine apps don't work anymore on 12.2

    Quote Originally Posted by F_style View Post
    Well, last time I saw them working was back on 12.1, probably with a 1.4.xx or an early 1.5.x version. So, a few months ago.
    So did you try a roll back?
    I have a copy of an earlier version synced locally on my machine, that I am using.

    You could always try the crossover package that was released free yesterday... did you get a copy?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    solenoid NNTP User

    Default Re: Wine apps don't work anymore on 12.2

    On 11/01/2012 07:06 AM, caf4926 wrote:
    >
    > F_style;2500365 Wrote:
    >> Well, last time I saw them working was back on 12.1, probably with a
    >> 1.4.xx or an early 1.5.x version. So, a few months ago.

    >
    > So did you try a roll back?
    > I have a copy of an earlier version synced locally on my machine, that
    > I am using.
    >
    > You could always try the crossover package that was released free
    > yesterday... did you get a copy?
    >
    >


    Crossover free? Where is it? I can't find it. There's only free trial there.
    Could you help me with the link, please?

    TIA

    ~rms~


  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Wine apps don't work anymore on 12.2

    It was avail for only 31/Oct

    You should see a contact me at this page
    User:Caf4926 - openSUSE

    Email me and I'll send you a link to get a copy
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Wine apps don't work anymore on 12.2

    Seemingly it got solved. First I was using
    Code:
    wine Documents/LIMBO/limbo.exe
    and I got the crash.

    Then I tried
    Code:
    cd Documents/LIMBO
    wine limbo.exe
    and it worked again like before.

    Also tried downloading the demo version, tried both ways and same results. As though Wine no longer supported running apps with a single command...

    Oh, forgot to mention that each time I run Limbo (my game, not the demo), 3 files are created in my /home directory: a folder named [user]_swarm, gamelanguage.txt, and playername.txt. These are actually game's files, they're in the game directory. Demo doesn't do this, WTH...

    Now, uninstalled the demo and deleted the wineprefix, but I still have that Limbo direct accesses (the exe and the uninstaller) among my applications, in the Wine group. How do I get rid of them?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •