Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Firefox cookie problem

  1. #1

    Default Firefox cookie problem

    Hello all. Firefox allows you to setup how cookies are processed. Before I when I set a cookie to be session cookie, it would be deleted after I closed Firefox. I would not see the prompt again. Every time I start firefox, I see the prompt for cookies I had already set for session the last time I closed firefox. Need help or know if I bug fix is pending. Thanks.

    opensuse 12.1, kde, firefox 16.01

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,479
    Blog Entries
    3

    Default Re: Firefox cookie problem

    I would guess that what you are seeing is due to a change at mozilla, rather than a change at opensuse.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Firefox cookie problem

    Quote Originally Posted by lord_valarian View Post
    Hello all. Firefox allows you to setup how cookies are processed. Before I when I set a cookie to be session cookie, it would be deleted after I closed Firefox. I would not see the prompt again. Every time I start firefox, I see the prompt for cookies I had already set for session the last time I closed firefox. Need help or know if I bug fix is pending. Thanks.

    opensuse 12.1, kde, firefox 16.01
    What are your Privacy settings for Cookies?

    I have "Accept cookies from sites", and "Accept third-party cookies" checked.

    Nothing in the Exceptions list, where I can add the Address of a website, and "Block", "Allow for session" or "Allow", for how to deal with the cookies for that site.

    Keep until: is set to "they expire". Other options being "I close Firefox", or "ask me every time".

    I would review those.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  4. #4

    Default Firefox cookie problem

    Quote Originally Posted by rafter22 View Post
    What are your Privacy settings for Cookies?

    I have "Accept cookies from sites", and "Accept third-party cookies" checked.

    Nothing in the Exceptions list, where I can add the Address of a website, and "Block", "Allow for session" or "Allow", for how to deal with the cookies for that site.

    Keep until: is set to "they expire". Other options being "I close Firefox", or "ask me every time".

    I would review those.
    It's changed. It's same setting as I always have. Firefox is acting differently. I set all yahoo cookies to session. They are all deleted on exit. Yahoo setup session cookie prompt only appears once. Now, every time I start Firefox the prompt comes up again. It didn't do that before the last update. It was once and once only.

    Use custom settings(pic available) +(checked)
    accept cookies from websites+
    clear firefox history on exit +

    Session setup is there. It's being reset on exit. Firefox didn't do that before. The same session prompt I already set are coming up again and again.

  5. #5
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Firefox cookie problem

    Quote Originally Posted by lord_valarian View Post
    It's changed. It's same setting as I always have. Firefox is acting differently. I set all yahoo cookies to session. They are all deleted on exit. Yahoo setup session cookie prompt only appears once. Now, every time I start Firefox the prompt comes up again. It didn't do that before the last update. It was once and once only.

    Use custom settings(pic available) +(checked)
    accept cookies from websites+
    clear firefox history on exit +

    Session setup is there. It's being reset on exit. Firefox didn't do that before. The same session prompt I already set are coming up again and again.
    Is this any help?

    Firefox amnesia - login/session cookies don't remain after restart | Firefox Support Forum | Mozilla Support

    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  6. #6

    Default Re: Firefox cookie problem

    It did what it said. Then figured out it. In on exit of firefox, site preferences checked deleted all my cookie preferences. It didn't do that before. I just unchecked it. I think it's fixed.

  7. #7

    Default Re: Firefox cookie problem

    I unchecked 'site preferences'(on firefox exit). That had no effect. I tried the reset. It didn't work. The same prompts keep appearing over and over on session.

  8. #8
    josephkk NNTP User

    Default Re: Firefox cookie problem

    On Thu, 08 Nov 2012 21:46:01 GMT, lord valarian
    <lord_valarian@no-mx.forums.opensuse.org> wrote:

    >
    >I unchecked 'site preferences'(on firefox exit). That had no effect. I
    >tried the reset. It didn't work. The same prompts keep appearing over
    >and over on session.


    Site preferences is not completely clear to me, but session cookies are.
    Session cookies always disappear when firefox closes and if your site
    preferences are in them they go away too. Perhaps you want to implement
    more fine grained cookies policies.

    ?-)

  9. #9
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Firefox cookie problem

    I do not know what version of Firefox people are running but on my setup I have no >tools or "cookies" menu options in the preferences.
    I fixed this problem by typing in the url area "about:config" and hit enter.
    You can then search for cookie and in the results will find settings to keep cookies on restart etc.... I had to fiddle with a couple of them that were false by default and now I get auto login on sites.
    Maybe something in there will help you.

  10. #10
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Firefox cookie problem

    Quote Originally Posted by anika200 View Post
    I do not know what version of Firefox people are running but on my setup I have no >tools or "cookies" menu options in the preferences.
    I fixed this problem by typing in the url area "about:config" and hit enter.
    You can then search for cookie and in the results will find settings to keep cookies on restart etc.... I had to fiddle with a couple of them that were false by default and now I get auto login on sites.
    Maybe something in there will help you.
    Do you have, Edit > Preferences > Privacy?

    Under the Privacy tab do you have "Use custom settings for history" selected? There are cookie settings there, and under "Clear history when Firefox closes" if checked.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •