Hi everyone,

I upgraded my OpenSuSE installation from 12.1 to 12.2, the problem is now, that Pidgin (or any other application using libpurple) won't connect to Gtalk anymore stating "Server does not use any supported authentication method". Running Pidgin with -d I get the following lines:

Code:
(17:02:35) jabber: Recv (ssl)(197): <stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>X-GOOGLE-TOKEN</mechanism><mechanism>X-OAUTH2</mechanism></mechanisms></stream:features>
(17:02:35) sasl: Mechs found: PLAIN X-GOOGLE-TOKEN X-OAUTH2
(17:02:35) sasl: No worthy mechs found
(17:02:35) connection: Connection error on 0x7f8019102840 (reason: 3 description: Server does not use any supported authentication method)
I know this problem has been widely discussed and should be solved by installing either the most current version of cyrus-sasl-*, which I have:

Code:
cyrus-sasl-digestmd5-2.1.25-21.2.1.x86_64
cyrus-sasl-plain-2.1.25-21.2.1.x86_64
cyrus-sasl-2.1.25-21.2.1.x86_64
or by setting the hostname properly in the files HOSTNAME, /etc/hosts and /etc/postfix/main.cf, which I think, I've done correctly as well.

So I'm running out of ideas and hope that someone has any great idea to get me out of authentication hell!

Thanks for any helpful replies!