Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Missing hibernate option

  1. #1

    Default Missing hibernate option

    hello friends,

    i have upgraded to opensuse 12.2 and now hibernate and shutdown options are missing

    when i press ALT then i'm able to see Power Off option

    but HIBERNATE is still missing

    please help .. i already searched on google and not found any solution

    thanks

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: Missing hibernate option

    On Wed, 24 Oct 2012 20:26:01 +0000, khizar91 wrote:

    > i have upgraded to opensuse 12.2 and now hibernate and shutdown options
    > are missing
    >
    > when i press ALT then i'm able to see Power Off option
    >
    > but HIBERNATE is still missing


    Have you got a swap partition large enough to hold the contents of RAM?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Missing hibernate option

    On 2012-10-24 22:26, khizar91 wrote:

    > but HIBERNATE is still missing


    try to hibernate by command to see if it works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  4. #4

    Default Re: Missing hibernate option

    when my laptop battery is low. it automatically hibernates so there is no issue about swap partition

    but the option is missing from the menu

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Missing hibernate option

    On 2012-10-25 07:26, khizar91 wrote:
    >
    > when my laptop battery is low. it automatically hibernates so there is
    > no issue about swap partition
    >
    > but the option is missing from the menu


    If the user doesn't have permission to hibernate, the option is removed. There are two commands to
    hibernate; one, pm-hibernate needs you be root. The other one I forget the name (some one may know),
    runs as user - but if policy forbids it, then it refuses. This route is similar to the menu entries,
    so they disappear. Check it, the error message will give a clue.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  6. #6

    Default Re: Missing hibernate option

    hibernate was available on opensuse 12.1 but not on 12.2 (i upgraded using repos)

    and now my question is that how to solve this issue ?

    Quote Originally Posted by robin_listas View Post
    On 2012-10-25 07:26, khizar91 wrote:
    >
    > when my laptop battery is low. it automatically hibernates so there is
    > no issue about swap partition
    >
    > but the option is missing from the menu


    If the user doesn't have permission to hibernate, the option is removed. There are two commands to
    hibernate; one, pm-hibernate needs you be root. The other one I forget the name (some one may know),
    runs as user - but if policy forbids it, then it refuses. This route is similar to the menu entries,
    so they disappear. Check it, the error message will give a clue.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Missing hibernate option

    On 2012-10-25 15:46, khizar91 wrote:
    >
    > hibernate was available on opensuse 12.1 but not on 12.2 (i upgraded
    > using repos)
    >
    > and now my question is that how to solve this issue ?


    You are not reading me.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,528
    Blog Entries
    15

    Default Re: Missing hibernate option

    Quote Originally Posted by khizar91
    hello friends,

    i have upgraded to opensuse 12.2 and now hibernate and shutdown options
    are missing

    when i press ALT then i'm able to see Power Off option

    but HIBERNATE is still missing

    please help .. i already searched on google and not found any solution

    thanks

    Hi
    In 'Advanced Settings' GUI, select the extensions and enable the
    'alternative status menu' extension.

    It may not have updated properly, so you can check via looking glass,
    press alt+F2 and enter lg <press enter> and check under the extensions
    and error tabs, else force a re-install;
    Code:
    zypper in -f gnome-shell-extension-alternative-status-menu
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 23:26, 3 users, load average: 0.09, 0.08, 0.08
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,528
    Blog Entries
    15

    Default Re: Missing hibernate option

    Quote Originally Posted by Carlos E. R.
    On 2012-10-25 07:26, khizar91 wrote:
    >
    > when my laptop battery is low. it automatically hibernates so there is
    > no issue about swap partition
    >
    > but the option is missing from the menu


    If the user doesn't have permission to hibernate, the option is
    removed. There are two commands to hibernate; one, pm-hibernate needs
    you be root. The other one I forget the name (some one may know), runs
    as user - but if policy forbids it, then it refuses. This route is
    similar to the menu entries, so they disappear. Check it, the error
    message will give a clue.

    Hi
    Are you running the Gnome Shell 3.4.2???

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 23:34, 3 users, load average: 0.05, 0.07, 0.07
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  10. #10

    Default Re: Missing hibernate option

    okay,
    when i run "sudo pm-hibernate" it show suspending and just after few second it bring back to normal position without any error..


    Quote Originally Posted by robin_listas View Post
    On 2012-10-25 15:46, khizar91 wrote:
    You are not reading me.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •