Results 1 to 7 of 7

Thread: Агрегаторы новостей

  1. #1
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Агрегаторы новостей

    Пытаюсь собрать версию 1.8.9 (на software.opensuse.org только 1.8.0 / у автора текущая- 1.8.9, бета- 1.9.6!)
    Ловлю при компиляции следущую ошибку:
    Code:
    ui/libliui.a(libliui_a-liferea_htmlview.o): In function `liferea_htmlview_finalize':
    liferea-1.8.9/src/ui/liferea_htmlview.c:80: undefined reference to `g_signal_handlers_disconnect_by_data'
    Это к тому, что у меня gtksourceview древний? (OpenSUSE 11.4) Чего-то не могу въехать..

  2. #2
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default re: Агрегаторы новостей

    Попробовал все-таки установить 1.8.0 из "домашнего "репо - не работает с https! Однако.
    Пошел читать чейнжлоги, которые никто не читает

  3. #3
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default re: Агрегаторы новостей

    Итого: ну его нафик! Просто заменил на другой вменяемый агрегатор RSS (с единственным минусом- не умеет авторизацию по https). А с сабжем постоянно какие-то проблемы, к примеру до версии 1.8 оно пару лент обновляло минут пять. У меня ощущение, что разработчик этого чудо-приложения разрабатывает его исключительно по дороге в метро))

  4. #4
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,952
    Blog Entries
    1

    Default re: Агрегаторы новостей

    joneone wrote:

    > undefined reference to `g_signal_handlers_disconnect_by_data'


    И не соберётся в 11.4.

    Overview of changes from GLib 2.31.10 to 2.31.12
    ================================================
    ....
    668269 gsignal: add g_signal_handlers_disconnect_by_data
    ....

    В oS 11.4 libglib версии 2.28.


  5. #5
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default re: Агрегаторы новостей

    С агрегаторами лент новостей в Gnome просто беда. Naufrago, про который было выше, тоже с изъянами:
    * не разрабатывается с версии 0.4 (это ерунда)
    * последовательная загрузка лент- загрузка списка прерывается (а приложение виснет), если какой-нибудь сервер не отвечает. Короче, студенческая поделка just 4 fun..
    Откопал Straw, и в отличии от всех прочих работает почти без нареканий. Но пришлось установить "левый" пакет, поскольку просто так собрать не выходит. В этом собственно и вопрос:
    Code:
    python setup.py bdist_rpm
    ...
    error: Installed (but unpackaged) file(s) found: 
       /usr/lib/python2.7/site-packages/straw/constants.py    
       /usr/lib/python2.7/site-packages/straw/constants.pyc 
    error: command 'rpmbuild' failed with exit status 1

  6. #6
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,952
    Blog Entries
    1

    Default re: Агрегаторы новостей

    Мы так не делаем пакеты. Нужно спек писать нормальный.


  7. #7
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Ну и в заключение

    Топик по хорошему бы надо переименовать в "агрегаторы новостей" или как-то так

    Пожалуй самый вменяемый вариант, не привязанный ни к одному DE, это проект QuiteRSS
    Умеет и https, русскоязычные разработчики, на software.opensuse.org есть готовые пакеты.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •