Results 1 to 7 of 7

Thread: Nautilus issue with openSUSE 12.2 (gnome)

  1. #1
    Join Date
    Oct 2012
    Location
    Bangladesh
    Posts
    4

    Question Nautilus issue with openSUSE 12.2 (gnome)

    i'm using openSUSE 12.2 with gnome 3.4.2, i have two NTFS partition with important data and i mounted theem with read-write enable. problem is- i can't access those partitions using nautilus file manager, while i'm trying to open any folder under those NTFS drive; nautilus crashes and exit suddenly. linux partitions are ok though. here is the error from Terminal (while nautilus crashes):
    Code:
    Initializing nautilus-open-terminal extension
    Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
    Segmentation fault
    any solution?
    here is my /etc/fstab file:
    Code:
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part6 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part5 /                    ext4       acl,user_xattr        1 1
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/sda3            /media/MY_DRIVE      ntfs-3g    users,gid=users,fmask=113,dmask=002,locale=en_US.utf8 0 0
    /dev/sda2            /media/PRIMARY       ntfs-3g    users,gid=users,fmask=113,dmask=002,locale=en_US.utf8 0 0
    here, /dev/sda3 and /dev/sda2 are NTFS partitions i'm talking about.

    FYI: i used ubuntu 12.04 before and faced the same problem with nautilus, so i changed my default file manager to marlin (instead of nautilus) and it worked well, but marlin is not available for openSUSE 12.2, so i'm in problem. seems this issue exists only in nautilus.

    Regards.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    try it like this
    Code:
     
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part6 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part5 /                    ext4       acl,user_xattr        1 1
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/sda3            /media/MY_DRIVE      ntfs-3g    defaults 0 0
    /dev/sda2            /media/PRIMARY       ntfs-3g    defaults 0 0
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Oct 2012
    Location
    Bangladesh
    Posts
    4

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    Quote Originally Posted by caf4926 View Post
    try it like this
    Code:
     
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part6 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100616PBN2003SEDESBU-part5 /                    ext4       acl,user_xattr        1 1
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/sda3            /media/MY_DRIVE      ntfs-3g    defaults 0 0
    /dev/sda2            /media/PRIMARY       ntfs-3g    defaults 0 0
    thanks for reply. i've done what you said, but still no luck. now nautilus freezing while trying to access those NTFS drives and totally stopped responsing, so i've to kill nautilus (force quit).
    here goes the error msg:
    Code:
    Initializing nautilus-open-terminal extension
    Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
    *** glibc detected *** nautilus: malloc(): smallbin double linked list corrupted: 0x087de9d0 ***
    Killed
    and sometimes it's crashing as i mentioned in my first post, with same error (segmentation fault).
    what to do now? should i need to try another file manager instead of nautilus? which one will be better?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    Here is the content of that file on my system
    <?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    <!-- Load per-user customization file -->
    <include ignore_missing="yes">~/.fonts.conf.d</include>
    <include ignore_missing="yes">~/.fonts.conf</include>
    </fontconfig>
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Dec 2009
    Location
    B'ham, UK
    Posts
    46

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    Well I have the following problem:

    This software_abomination nautilus cannot SEARCH files on NTFS partitions... !!

    I put that NTFS HDD into a friend's Linux MInt box and the caja (?) can find files.

    I am completely pissed off, really

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,517
    Blog Entries
    15

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    On Sun 25 Nov 2012 08:56:01 PM CST, xotto wrote:


    Well I have the following problem:

    This software_abomination nautilus cannot SEARCH files on NTFS
    partitions... !!

    I put that NTFS HDD into a friend's Linux MInt box and the caja (?) can
    find files.

    I am completely pissed off, really


    Hi
    Works fine for me mounting an ntfs formated drive in nautilus, uses
    fuseblk to mount. Was the drive cleanly unmounted from the system?

    Do you see the device appear in dmesg output, errors? What does the
    mount command show for the device? What about fdisk -l on the device.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 1 day 22:37, 5 users, load average: 0.10, 0.37, 0.50
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  7. #7
    Join Date
    Dec 2009
    Location
    B'ham, UK
    Posts
    46

    Default Re: Nautilus issue with openSUSE 12.2 (gnome)

    hm.. as I see it was a problem with some .config files... I deleted any config files and now everything is ok! I totaly freaked about this problem... thanx for the replies..
    cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •