Results 1 to 6 of 6

Thread: Gnome control center ("system settings") not working in Open SUSE 12.2 after upgrade form 11.4

  1. #1

    Default Gnome control center ("system settings") not working in Open SUSE 12.2 after upgrade form 11.4

    Hi,

    the subject pretty much says it all.

    It's showing an empty window with correct title and quick search bar, but the content is empty. Window is not resizable, but responds to moving and search bar is typeable. If ran from command line it doesn't print anything on the console.
    I don't know what to do now. Any help as to how I can diagnose what's wrong with this app is appreciated.



    RPM: gnome-control-center-3.4.2-3.8.1.x86_64
    uname: Linux linux-td5z 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64 x86_64 x86_64 GNU/Linux

  2. #2
    dd NNTP User

    Default Re: Gnome control center ("system settings") not working in OpenSUSE 12.2 after upgrade form 11.4

    On 10/24/2012 09:36 AM, bobbybrown wrote:
    > the subject pretty much says it all.


    not really!

    1. _how_ did you upgrade?

    2. did you upgrade because you were have problems in 11.4? what kinds of
    problems (because an upgrade will often leave in place configuration
    files which were the cause of the problems you tried to leave behind..)

    3. like did you go from 11.4 to 12.1 and then to 12.2?
    or, straight from 11.4 to 12.2, and _how_ did you do that...

    i ask, because it sounds like you have a failed upgrade attempt...these
    are the only three ways known to work (usually)--and, as noted even the
    recommended ways a just full of pitfalls and risks:
    http://tinyurl.com/35p966c
    http://tinyurl.com/93uemsr
    http://tinyurl.com/7l4m2td

    and, i wonder if you were using GNOME 2 or GNOME 3 in your 11.4..

    --
    dd http://tinyurl.com/DD-Caveat

  3. #3

    Default Re: Gnome control center ("system settings") not working in OpenSUSE 12.2 after upgrade form 11.4

    1. How I did the upgrade:
    • I downloaded the DVD image and wrote it on a USB stick.
    • Then I booted system from USB stick and chose 'Installation'.
    • I mostly used the default selections the installation processed was offering to me.
    • I was doing upgrade from 64 bit 11.4 straight to 64 bit 12.2.


    2. I had no problems with my 11.4 release whatsoever during my 1.5 years of using it, everything was working. The only reason I tried 12.2 is because some libraries/programs become old in 11.4 and newer versions never made it to 11.4 repos Like I tried updating skype 2.x to 4.x and it said it needed libtiff 4(5?) etc. If I knew how to make newer libraries coexist with the old ones and where to get them I'd probably be happy with my 11.4 release.

    I don't think upgrade is failed. Everything seems to be working in 12.2 after I fixed video drivers (installed proprietary nvidia) and network. Everything except the "System Settings".
    I was using GNOME 2 in 11.4 (I wish it was possible to keep using it instead of the 3rd one in 12.2)

  4. #4
    dd NNTP User

    Default Re: Gnome control center ("system settings") not working in OpenSUSE 12.2 after upgrade form 11.4

    On 10/24/2012 08:16 PM, bobbybrown wrote:
    > I don't think upgrade is failed. Everything seems to be working in 12.2
    > after I fixed video drivers (installed proprietary nvidia) and network.
    > Everything except the "System Settings".


    you could try using YaST > Security & Users > User & Group Management to
    add a TestUser, then log out of your desktop and log back into as the
    TestUser....and, see if the "systems settings" work there....if they do
    then you know some config files in your /home has been corrupted in some
    way.....like maybe it is still the GNOME2 config file...i do NOT know if
    that is even possible.....but, i DO know that the upgrade you described
    should only be done one step at a time....that is from 11.4 you upgrade
    to 12.1 *and* apply all the updates to it to bring it right up to date,
    and then boot from the 12.2 DVD and do what you did.....so, there is
    really no one who could tell you what got messed up..

    *if* your TestUser works ok come back and say so, and maybe a GNOME3
    guru will drop in and explain how to protect data and rename some config
    file so it will auto-generate a new one (which will exactly match the
    one in the working ok TestUser's desktop)

    --
    dd http://tinyurl.com/DD-Caveat

  5. #5

    Default Re: Gnome control center ("system settings") not working in OpenSUSE 12.2 after upgrade form 11.4

    Quote Originally Posted by dd View Post
    On 10/24/2012 08:16 PM, bobbybrown wrote:
    you could try using YaST > Security & Users > User & Group Management to
    add a TestUser ...
    Thanks dd, that actually worked, no such problem with the new user.

  6. #6
    dd NNTP User

    Default [SOLVED] Re: Gnome control center ("system settings") not workingin Open SUSE 12.2 after upgrade form 11.4

    On 10/25/2012 05:56 AM, bobbybrown wrote:
    > no such problem with the new user.


    congrats, and welcome!!

    --
    dd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •