Results 1 to 8 of 8

Thread: Epson Stylus TX115 Ink level monitor not working (ekpstm)

  1. #1

    Thumbs down Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Hi, I could not manage to get PIPS fully work on 12.1.

    The printer and scanner work fine, but some of the cartridges now has low ink level and cannot print anymore.

    The suggested tool for monitor ink levels is ekpstm as of my knowledge, but after resolving all dependencies it fails with an "Out of memory" error message.

    If I strace the program, this is what I get, although I'm not sure what can I do with that details:

    Code:
    open("/usr/share/locale-bundle/es.utf8/LC_MESSAGES/pips-snx110.mo", O_RDONLY) = -1 ENOENT (No such file or directory)open("/usr/share/locale-langpack/es/LC_MESSAGES/pips-snx110.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/usr/share/locale/es/LC_MESSAGES/pips-snx110.mo", O_RDONLY) = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=755, ...}) = 0
    mmap2(NULL, 755, PROT_READ, MAP_PRIVATE, 5, 0) = 0xfffffffff7779000
    close(5)                                = 0
    write(2, "Out of memory.\n", 15Out of memory.
    )        = 15
    exit_group(1)
    So, any help you may give would be greatly appreciated!!


    Thank you

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,026

    Default AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    ekpstm?
    I think this tool is replaced by pipslitestm.

    Where did you get the ekpstm?

    I found in an old pipslite Package pipslitestm and installed pipslite with one broken depency:
    Code:
    libjpeg, benötigt von pipslite-1.5.0-5.i386, wird von keinem Repository angeboten
    But this are installed:
    Code:
    S | Name            | Typ   | Version       | Arch | Repository                                 
    --+-----------------+-------+---------------+------+--------------------------------------------
    i | libjpeg-turbo   | Paket | 1.1.1-10.4.1  | i586 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    i | libjpeg62       | Paket | 62.0.0-10.4.1 | i586 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    i | libjpeg62-devel | Paket | 62.0.0-10.4.1 | i586 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    i | libjpeg8        | Paket | 8.0.2-8.1.2   | i586 | openSUSE-12.1-Oss
    These Epson-Driver are installed (pipslite only for pipslitestm):
    Code:
    S | Name                       | Typ   | Version       | Arch | Repository
    --+----------------------------+-------+---------------+------+-----------
    i | epson-inkjet-printer-escpr | Paket | 1.2.0-1lsb3.2 | i486 | Programme 
    i | pipslite                   | Paket | 1.5.0-5       | i386 | Programme
    And it is working with Epson DX 5000

  3. #3

    Default Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Hi

    Quote Originally Posted by Sauerland View Post
    ekpstm?
    I think this tool is replaced by pipslitestm.

    Where did you get the ekpstm?
    This post led me to that tool (ekpstm): http://forums.opensuse.org/opensusef...-tx-115-a.html

    Don't have right now that computer but I think it is part of pips-cups.

    I started to search software.opensuse.org: Download openSUSE 12.2 for some packages related to PIPS with no luck.

    Then I downloaded drivers and tools from here: Epson Inkjet Printer Driver (ESC/P) for Linux | AVASYS CORPORATION and here: All-in-Ones (Multifunction Inkjet Printers) | AVASYS CORPORATION (through the bottom form)

    At some point I installed 32 bit versions of pips-cups, pips-gtk2 and pips-core (found in pbone.net) attempting to fix dependencies.

    As I said, the printer and scanner work fine, but I don't know which ink cartridge needs to be replaced.

    Is pipslite part of the ESC/P-R driver? In that case I wont be able to use it as this printer is not supported by it.


    Regards,

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,026

    Default AW: Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Photo Image Print System Lite for LPRng | AVASYS CORPORATION
    The rpm is for 32-bit.

    I´ve found only Packages for 11.1 and earlier, see here:
    Index of /pub/linux/opensuse/distribution/11.1/repo/oss/suse

    Is pipslite part of the ESC/P-R driver?
    No in the ESC/R I found no ink level monitor.
    This is why I installed pipslite with broken depencies.

  5. #5

    Default Re: AW: Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Mmm ok, I am now remotely installing pipslite but I see that are required a few packages:
    Code:
        libgdk-1.2.so.0 is needed by pipslite-1.0.3-1.i386
        libglib-1.2.so.0 is needed by pipslite-1.0.3-1.i386
        libgmodule-1.2.so.0 is needed by pipslite-1.0.3-1.i386
        libgtk-1.2.so.0 is needed by pipslite-1.0.3-1.i386
    I'm about to search the repository that gently you pointed me to.

    I'll be back

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,026

    Default AW: Re: AW: Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Do you have a 32-bit install?
    Code:
    uname -a
    Here is my pipslite:
    http://depositfiles.com/files/w7670yi1i

  7. #7

    Default Re: AW: Re: AW: Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    Quote Originally Posted by Sauerland View Post
    Do you have a 32-bit install?
    Code:
    uname -a
    Here is my pipslite:
    DepositFiles
    Hey thank you a lot

    No, this is a 64 bit install.

  8. #8

    Default Re: AW: Re: AW: Re: AW: Epson Stylus TX115 Ink level monitor not working (ekpstm)

    No progresss so far. Uninstalled pips-core, pips-cups, pips-gtk2 and installed pipslite (not sure of pips-opensuse11.1 that I've downloaded last week but forgot from where!).

    pipslitestm says Connection Error, and in case I wish to setup the printer with /usr/lib/pipslite/setup (trying /dev/usblp0 and /dev/usb/lp0) won't work.

    Also pipslite-install says that the printer must be connected and disables the "Continue" button. I tried both connected and disconnected restarting and installing.

    This evening I'll get back on this. Regards and thank you
    Last edited by mgnome; 24-Oct-2012 at 13:03. Reason: to add more details

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •