Results 1 to 3 of 3

Thread: Gnuplot "enhanced" PNG doesn't produce Greek letters (libgd/fontconfig)

  1. #1

    Exclamation Gnuplot "enhanced" PNG doesn't produce Greek letters (libgd/fontconfig)

    Hi, I'm trying to create a plot with Greek letters in the labels. It isn't working in 12.2, but it was in 12.1. Here's the steps to reproduce:

    1. Open gnuplot
    2. Execute

    Code:
    set terminal png enhanced
    set output 'test.png'
    set xlabel '{/Symbol c}'
    plot sin(x)
    unset output
    exit
    For me, this produces two lines of error output:

    Code:
    gdImageStringFT: fontconfig: Didn't find expected font family. Perhaps URW Type 1 fonts need installing? while printing string c with font Symbol
    gdImageStringFT: fontconfig: Didn't find expected font family. Perhaps URW Type 1 fonts need installing? while printing string c with font Symbol
    and the figure does not have the Greek letter printed. I've tried installing various font packages and tried playing around with the fontconfig and libgd configurations, but I've had no success. Has anyone else encountered this? Could you please try this and see if you get the same output so I might have a better idea of what to put in a bug report?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Gnuplot "enhanced" PNG doesn't produce Greek letters (libgd/fontconfig)

    No idea how to solve the error when using the /Symbol c notation (never
    used that), but is using terminal epslatex an option for you such that
    you get full latex support?

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.2 | HD 3000
    eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

  3. #3

    Default Re: Gnuplot "enhanced" PNG doesn't produce Greek letters (libgd/fontconfig)

    I'm on Suse 11.4. I ran you code and got a greek chi. I did "help fonts" in gnuplot, and it said that it had no font facilities, instead using the font provided by the terminal. Maybe you should make sure your terminal is using a unicode (UTF-8) font? Or maybe try a different terminal?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •