Results 1 to 7 of 7

Thread: Strange quick launch behavior

  1. #1

    Default Strange quick launch behavior

    OS 12.2, 3.4.11 kernel on x86_64, KDE 4.9

    Simple question, really, but I was wondering if there was a more meaningful underlying cause to this issue.

    I can't add LibreOffice apps to the quicklaunch. If I choose "Show a Launcher When Not Running" from the application's taskbar context menu, an icon will indeed show up. However, after closing the application, when I click on the newly placed LibreOffice icon, I get an "Open with..." dialogue asking me which program to use to open soffice.bin, regardless of which LibreOffice application has been placed there, or how long or after how many reboots it's been placed there.

    So, exactly how does one add a useful LibreOffice icon to the quicklaunch?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Strange quick launch behavior

    Quote Originally Posted by HuaiDan View Post
    OS 12.2, 3.4.11 kernel on x86_64, KDE 4.9

    Simple question, really, but I was wondering if there was a more meaningful underlying cause to this issue.

    I can't add LibreOffice apps to the quicklaunch. If I choose "Show a Launcher When Not Running" from the application's taskbar context menu, an icon will indeed show up. However, after closing the application, when I click on the newly placed LibreOffice icon, I get an "Open with..." dialogue asking me which program to use to open soffice.bin, regardless of which LibreOffice application has been placed there, or how long or after how many reboots it's been placed there.

    So, exactly how does one add a useful LibreOffice icon to the quicklaunch?
    So I don't know why this does not work for LibreOffice, but its not applicable to other applications as well like YaST, cause it can not be run as root like this. Your best bet is to find menu / Office / LibreOffice, right click on it and select Add To Panel and get the next best thing that actually works. There is always more than one way to skin a cat, or start LibreOffice.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Strange quick launch behavior

    Thanks JD for your quick reply.

    When I go to the applications menu and right-click an LO application (or any application for that matter), I don't get "Add to Panel". The context menu gives me the app name "Add to Favorites" or "Remove from Favorites", and "Uninstall". I already have the apps added to favorites, so they're actually just one click away from the quick-launch. However, frankly I'm just curious as to why this happens and perhaps to alert others to a possible bug.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Strange quick launch behavior

    Quote Originally Posted by HuaiDan View Post
    Thanks JD for your quick reply.

    When I go to the applications menu and right-click an LO application (or any application for that matter), I don't get "Add to Panel". The context menu gives me the app name "Add to Favorites" or "Remove from Favorites", and "Uninstall". I already have the apps added to favorites, so they're actually just one click away from the quick-launch. However, frankly I'm just curious as to why this happens and perhaps to alert others to a possible bug.
    If you right click on the menu icon, switch to the Classic Menu, which I use, and the Add to Panel should be there.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: Strange quick launch behavior

    On 10/18/2012 07:16 AM, jdmcdaniel3 pecked at the keyboard and wrote:
    > HuaiDan;2496865 Wrote:
    >> Thanks JD for your quick reply.
    >>
    >> When I go to the applications menu and right-click an LO application
    >> (or any application for that matter), I don't get "Add to Panel". The
    >> context menu gives me the app name "Add to Favorites" or "Remove from
    >> Favorites", and "Uninstall". I already have the apps added to favorites,
    >> so they're actually just one click away from the quick-launch. However,
    >> frankly I'm just curious as to why this happens and perhaps to alert
    >> others to a possible bug.

    > If you right click on the menu icon, switch to the Classic Menu, which
    > I use, and the Add to Panel should be there.
    >
    > Thank You,
    >
    >

    You need to also "Unlock Widgets" to add to the desktop.

  6. #6

    Default Re: Strange quick launch behavior

    Thanks all fro the useful info. Now I have the LibreOffice icon set as a task-manager widget on the left side of the taskbar, rather than as a true quick-launcher, but it looks and functions much the same.

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Strange quick launch behavior

    Quote Originally Posted by HuaiDan View Post
    Thanks all fro the useful info. Now I have the LibreOffice icon set as a task-manager widget on the left side of the taskbar, rather than as a true quick-launcher, but it looks and functions much the same.
    We are happy you found a solution for your request. If you need anything else, just let us know.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •