Results 1 to 6 of 6

Thread: Get dbus error when opening file chooser in VirtualBox!

  1. #1

    Default Get dbus error when opening file chooser in VirtualBox!

    When I'm in the VirtualBox GUI and under "settings" and I click to add an ISO file, it hangs for a few seconds and then on top of the file chooser shows the error:

    Code:
    Could not start process Cannot talk to klauncher: Not connected to D-Bus server.
    I am using openSUSE 12.1 and when I check dbus version, it's only 1.5.8-2.6.1 so I know it's not this: https://forums.virtualbox.org/viewtopic.php?f=3&t=51960

    Any idea what causes this and how to fix it?

  2. #2

    Default Re: Get dbus error when opening file chooser in VirtualBox!


  3. #3

    Default Re: Get dbus error when opening file chooser in VirtualBox!

    Quote Originally Posted by please_try_again View Post
    Thanks! That appears to be exactly the issue. Looking at the bug report, it looks like this will be fixed in a future update.

  4. #4

    Default Re: Get dbus error when opening file chooser in VirtualBox!

    If I use the packages with the fix that are mentioned here: https://bugzilla.novell.com/show_bug.cgi?id=783657#c26 when the update finally comes out in the normal repository, will I have to manually switch back to get it?

  5. #5
    Join Date
    Jun 2008
    Location
    Geneva/Switzerland
    Posts
    39

    Default Re: Get dbus error when opening file chooser in VirtualBox!

    The better would be to install it from Index of /repositories/home:/thoenig:/branches:/openSUSE:/12.2:/Update/standard as mentionned and remove the repository from your repository list. The dbus packages will show up in red, you will be able to update them when a new version appear in the normal update repository.
    Box: i7-2700K CPU@3.50GHz | 32GbRAM | 14Tb HDD | nVidia GTX 690 | openSuSE 12.2-64 | KDE 4.8.5
    Lap: Lenovo W510 i7 820QM | 8GbRAM | 500Gb SSD | nVidia Quadro FX 880M | openSuSE12.2-64 | KDE 4.8.5

  6. #6

    Default Re: Get dbus error when opening file chooser in VirtualBox!

    Quote Originally Posted by gsancosme View Post
    The better would be to install it from Index of /repositories/home:/thoenig:/branches:/openSUSE:/12.2:/Update/standard as mentionned and remove the repository from your repository list. The dbus packages will show up in red, you will be able to update them when a new version appear in the normal update repository.
    Thanks. So to be sure the steps are:

    1. Install the repo Index of /repositories/home:/thoenig:/branches:/openSUSE:/12.2:/Update/standard

    2. Change to use the dbus packages from that new repo

    3. Remove that repo

    Is that right?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •