Results 1 to 3 of 3

Thread: Big KDM fonts.... Please help !!!

  1. #1

    Default Big KDM fonts.... Please help !!!

    Hi

    I have installed Opensuse 12.2 (32 bit) with KDE 4.9.2 "release 511" as my desktop. I am unable to change my kdm fonts no matter what I try. I went through different threads and tried the following:

    1) In personal settings, have anti-aliasing enabled and force fonts DPI to 96.
    2) Changed font size in Personal settings>Login Screen.
    3) Added "ServerArgsLocal=-nolisten tcp -dpi 96" in kdmrc under [X-*-Core] section.
    4) Added "-dpi 96 “ under DISPLAYMANAGER_KDM_LOCALARGS in /etc/sysconfig.
    5) Added "kdm4" under DISPLAYMANAGER in /etc/sysconfig.
    6) Included
    Option "UseEdidDpi" "FALSE"
    Option "DPI" "96 x 96"
    in 50-device.conf file.

    Nothing, I mean nothing has changed in the login screen. I have NVIDIA 304.43 driver installed and Kernel is 3.4.6-2.10-desktop i686. In previous versions of Opensuse, one of the 6 mentioned possible changes would solved the problem. Where am I going wrong this time ???? Please help, I am completely lost after trying for 2 days

  2. #2

    Default Re: Big KDM fonts.... Please help !!!

    It could be an EDID problem

    Below is from the Appendix




    Option "UseDisplayDevice" "string"
    When assigning display devices to X screens, the NVIDIA X driver by default assigns display devices in the order they are found (looking first at CRTs, then at DFPs, and finally at TVs). This option can be used to override this assignment. For example, if both a CRT and a DFP are connected, you could specify:

    Option "UseDisplayDevice" "DFP" to make the X screen use the DFP, even though it would have used a CRT by default.
    Note the subtle difference between this option and the "ConnectedMonitor" option: the "ConnectedMonitor" option overrides what display devices are actually detected, while the "UseDisplayDevice" option controls which of the detected display devices will be used on this X screen.
    Option "UseEdidFreqs" "boolean" This option controls whether the NVIDIA X driver will use the HorizSync and VertRefresh ranges given in a display device's EDID, if any. When UseEdidFreqs is set to True, EDID-provided range information will override the HorizSync and VertRefresh ranges specified in the Monitor section. If a display device does not provide an EDID, or the EDID does not specify an hsync or vrefresh range, then the X server will default to the HorizSync and VertRefresh ranges specified in the Monitor section of your X config file. These frequency ranges are used when validating modes for your display device.
    Default: True (EDID frequencies will be used)
    Option "UseEDID" "boolean" By default, the NVIDIA X driver makes use of a display device's EDID, when available, during construction of its mode pool. The EDID is used as a source for possible modes, for valid frequency ranges, and for collecting data on the physical dimensions of the display device for computing the DPI (see Appendix Y, Dots Per Inch). However, if you wish to disable the driver's use of the EDID, you can set this option to False:

    Option "UseEDID" "FALSE" Note that, rather than globally disable all uses of the EDID, you can individually disable each particular use of the EDID; e.g.,

    Option "UseEDIDFreqs" "FALSE" Option "UseEDIDDpi" "FALSE" Option "ModeValidation" "NoEdidModes" Default: True (use EDID).
    Option "IgnoreEDID" "boolean" This option is deprecated, and no longer affects behavior of the X driver. See the "UseEDID" option for details.
    Option "NoDDC" "boolean" Synonym for "IgnoreEDID". This option is deprecated, and no longer affects behavior of the X driver. See the "UseEDID" option for details.
    You can try setting yours to false
    People who do not break things first will never learn to create anything

  3. #3

    Default Re: Big KDM fonts.... Please help !!!

    Thank you for your reply. Problem is solved by editing the .xml of my theme file in /usr/share/apps/kdm/themes/ . I changed the font size in the line <style font="Sans 12" window-text-color="#bfd9ff" .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •