Results 1 to 7 of 7

Thread: Conflicts with packman repo's packages

  1. #1

    Default Conflicts with packman repo's packages

    If I understood correctly the release of Opensuse 12.2 delayed because the team was working to unify the project in a way that packages work right and avoid conflicts. Am I right? And it seems to have worked because packages from official repo's seem to blend together and cooperate with each other very nicely.
    However another repo's doesn't seem to work the same way.
    For example, I need (and I I believe many users also do) to install multimedia codecs from packman. But I haven't been able to update them from packman after they are installed because trying to update generate conflicts that I don't know the right way to solve.
    This week I tried to update packages installed from packman and got the following messages:

    libavfilter2-0.11.1-1.4x64 requires libavcodec54 = 0.11.1, but this requirement cannot be provided
    deleted providers libavcodec54-0.11.1-1.4.x86_64

    Following actions will be done:
    do not install libavcodec54-0.11.1-1.4.x86_64
    do not install libdevice54-0.11.1-1.4.x86_64
    do not install libswscale2-1.0-1.1.x86_64
    do not install libswresample0-1.0-1.1.x86_64

    deinstallation of libavfilter2-0.11.1-1.4x64

    break libavfilter2-0.11.1-1.4x64 by ignoring its dependencies

    And this is only one example. I have also had conflicts with ffmpeg-1.0-1.1.x86_64 that requires libavutil51 = 1.0. And such situations often occur with packman packages.

    What should I do when such things happen?

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Conflicts with packman repo's packages

    you need to remove libavfilter2 as it has been replaced by libavfilter3

    If you remove libavfilter2 and update the libavcodec files it will install libavfilter3 atomatically.

    I'm not sure why libavfilter2 isn't removed automatically. libavfilter2 is no longer even present in packman.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Conflicts with packman repo's packages

    On 2012-09-30 08:46, farcusnz wrote:
    >
    > you need to remove libavfilter2 as it has been replaced by libavfilter3
    >
    > If you remove libavfilter2 and update the libavcodec files it will
    > install libavfilter3 atomatically.
    >
    > I'm not sure why libavfilter2 isn't removed automatically. libavfilter2
    > is no longer even present in packman.



    Code:
    cer@Telcontar:~> rpm -qa | grep libavfilter
    libavfilter1-0.7.13-1.2.x86_64
    libavfilter2-0.11.1-1.2.x86_64

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  4. #4

    Default Re: Conflicts with packman repo's packages

    Quote Originally Posted by farcusnz View Post
    I'm not sure why libavfilter2 isn't removed automatically. libavfilter2 is no longer even present in packman.
    It happily did when I executed my regular "sudo zypper dup".

    Not sure. But it is well possible that the simplified "zypper up" algorithm doesn't let removes.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Conflicts with packman repo's packages

    Am 30.09.2012 14:26, schrieb RedDwarf:
    > Not sure. But it is well possible that the simplified "zypper up"
    > algorithm doesn't let removes.
    >

    The reason is simpler: libavfilter3 is no update to libavfilter2, it is
    a different package which is not installed, so "zypper up" does the
    correct thing.
    Instead of a "zypper dup" a simple "zypper in libavfilter3" would have
    done it (it gives you the option to remove libavfilter2).

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
    eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  6. #6

    Default Re: Conflicts with packman repo's packages

    Thanks for all ideas.
    I have to recognize taht I don't know how to use zypper. I always use yast and one thing I like in Opensuse is that I rarely need command line.
    But applying your ideas in yast worked too.
    There's only one thing I wonder:
    Opensuse developers said that to keep stability we would not always have the latest piece of software. But for how long will sofwares keep outdated on opensuse repo's?
    For example kde is already in 4.9 version but the one that came with opensuse is 4.8. Rosegarden is in 11.04 version but the one of repo's is 11.11. And so on.
    If we want an up-to-date software and install it from another repo it may conflict with the ones from standaed repo's. But if we don't we can't try the new releases of many things.

  7. #7
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Conflicts with packman repo's packages

    farcusnz wrote:

    >
    > you need to remove libavfilter2 as it has been replaced by
    > libavfilter3
    >
    > If you remove libavfilter2 and update the libavcodec files it

    will
    > install libavfilter3 atomatically.
    >
    > I'm not sure why libavfilter2 isn't removed automatically.
    > libavfilter2 is no longer even present in packman.
    >
    >

    Thanks for posting this. i ran into this yesterday, and was going
    to post question this morning, instead I found this thread and
    everything is fixed.

    Russ
    --
    openSUSE 12.2(Linux 3.4.6-2.10-desktop x86_64)|
    KDE 4.8.5 "release 521"|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
    8400GS(NVIDIA-Linux-x86_64-304.43)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •