Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Flash sound again

  1. #1

    Default Flash sound again

    Hi
    Using 12.1 with all updates done.
    Firefox is 15.0.1 and have been running this same setup since a bit after 12.1 release. All has been running quite happily and then an update ( i do not know which one ) seems to have knocked out the flash sound. that is audio on youtube, all other sound remains ok.
    Been two days of mucking about tried earlier flash versions, lots of stuff like.asoundrc files and mucked round with sound config.
    Tried gnash and sound works, but will not look at some videos.
    Tried lightspark, sound works, controls do not. again some videos blank.
    Returned to latest flash and all videos display and controls all ok but no sound.
    Finally some progress. Logged in as user as I normally do, open a terminal, change to su and then run firefox from command, and sound works.
    User is in audio group and pulse access group.
    Do not know where to go next.
    Any help appreciated though will now be tomorrow before continuing.
    This has driven me to drink and off for a small libation or six.
    Thanks for any replies.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Flash sound again

    No issues here
    But I'm 12.2
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Flash sound again

    Are you certain this is a flash issue, and not instead a pulse-audio/browser issue. Do you obtain sound from your browser when playing back mp4 files ? When playing back any other audio files with the browser ?

    Have you checked your browser audio settings with 'pulse audio volume control' (pavucontrol) ? pavucontrol is not installed by default on openSUSE KDE installations and needs to be installed there. I documented some pulse audio volume control basics here in this blog entry: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

  4. #4

    Default Re: Flash sound again

    Hi,
    Thanks for the reply.
    I believe it to be flash as removing flash and using gnash plays the sound from the same location.
    I do get sound from playing other files. a good example is from this site Capital Account — RT Programs and picking a programme the sound works and these seem to be mp4,
    for the same show on Capital Account - YouTube no sound?
    I have installed pavucontrol and this looks ok to me.
    As I have said the sound setup is ok for other apps and is not changed when using a flash alternative which then has sound.
    The other major point is if I start firefox from command line as root the youtube version again works correctly which would seem to say permisions somewhere.
    Any suggestions for approach? Thanks

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Flash sound again

    I had sound in all those.
    Are you using KDE?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Flash sound again

    Hi Cat,
    Yes been on KDE from install of 12.1.Sound on youtube was fine up to 3 days back.I accepted approx 30 updates that morning so think that one of them has changed something.
    The sound went off where it had been running in AM. tried reboots etc The same problems occur from Konq so I believed flash to be issue, then searched for similar probs and tried everything.
    Thanks

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Flash sound again

    You need to check your sound settings in kde's system settings > multimedia > Phonon

    How many sound devices do you have?

    If you have 2 or more, you need to set the 'Prefer' option in each area of Phonon
    And make sure you are pointing to the same device as is set as Primary sound device in Yast
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Flash sound again

    Hi,
    Two cards in yast
    82801H (ICH8 Family) HD Audio Controller

    • Configured as sound card number 0
    • Driver snd-hda-intel



    nVidia Corporation

    • Configured as sound card number 1
    • Driver snd-hda-intel

    HDaudio set as primary card, both cards pulse enabled.


    Phonon settings

    All audio playback sections as


    • Internal Audio Analog Stereo
    • GF110 High Definition Audio Controller Digital Stereo (HDMI)

    audio recording has many more devices, do these impact?


    • HDA Intel (ALC888 Analog)
    • HDA Intel, ALC888 Analog (Default Audio Device)
    • Default ALSA Output (currently PulseAudio Sound Server)
    • HDA Intel (ALC888 Digital)

    Phonon audio hardware setup is set to GF110 and when I have tried to change this to internal audio it reverts back to this setting. Is this a problem? it has been set this way for a long time and has worked ok.

    In pavucontrol both devices show same in config tab and listed as output devices with same vol levels .

    Any probs there? Thanks for the help

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Flash sound again

    I can't make much sense of what you posted. But I almost guarantee your problem is down to audio settings in kde system settings multimedia and or kmix
    And possibly also in Yast > Sound and which device is set a primary.

    Unfortunately I can't get my sticky mitts on your machine, so you'll just have to figure it out.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Flash sound again

    hi,
    sorry about the post , formatting went off somewhere, I like that you can edit post these days.
    may be a bit more intelligible now?
    The hardware setting for phonon has always bothered me a bit, it will not allow me to change to point to internal card. The hdmi device is part of the nvidea card and I do not know if it can be disabled.
    Cheers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •